Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление суммарных продаж и доли каждого магазина - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление суммарных продаж и доли каждого магазина (Формулы/Formulas)
Вычисление суммарных продаж и доли каждого магазина
qwerty45 Дата: Среда, 04.03.2020, 12:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день,

Помогите пожалуйста разобраться в вычислениях.
В таблице даны помесячные объемы продаж нескольких товаров в торговой сети из 40 магазинов
По каждому магазину даны две соседние колонки - продажи в штуках и рублях, соответственно

Нужно:
1. Вычислить для каждого товара:
- суммарный по всем магазинам объем продаж в упаковках;
- суммарный по всем магазинам объем продаж в денежном выражении.
2. Вычислить долю каждого магазина в общем объеме продаж товара1 в денежном выражении

Как это сделать более эффективно ? Файл в приложении
К сообщению приложен файл: 0370562.xls(32.0 Kb)
 
Ответить
СообщениеДобрый день,

Помогите пожалуйста разобраться в вычислениях.
В таблице даны помесячные объемы продаж нескольких товаров в торговой сети из 40 магазинов
По каждому магазину даны две соседние колонки - продажи в штуках и рублях, соответственно

Нужно:
1. Вычислить для каждого товара:
- суммарный по всем магазинам объем продаж в упаковках;
- суммарный по всем магазинам объем продаж в денежном выражении.
2. Вычислить долю каждого магазина в общем объеме продаж товара1 в денежном выражении

Как это сделать более эффективно ? Файл в приложении

Автор - qwerty45
Дата добавления - 04.03.2020 в 12:14
YouGreed Дата: Среда, 04.03.2020, 13:44 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 553
Репутация: 116 ±
Замечаний: 0% ±

Excel 2010
qwerty45, попробуем так:
Код
=ЛЕВБ(D3;2)
- выделяем название магазина
Код
=ПРАВБ(D3;6)
- выводим наименование колонки (кол-во или сумма)
Код
=СУММЕСЛИ($D$2:$CG$2;B$2;$D4:$CG4)
- суммируем по кол-ву или сумме.

По структуре вывода долей, я подумаю (через полчасика примерно).
К сообщению приложен файл: Sum_sales_and_r.xls(39.5 Kb)
 
Ответить
Сообщениеqwerty45, попробуем так:
Код
=ЛЕВБ(D3;2)
- выделяем название магазина
Код
=ПРАВБ(D3;6)
- выводим наименование колонки (кол-во или сумма)
Код
=СУММЕСЛИ($D$2:$CG$2;B$2;$D4:$CG4)
- суммируем по кол-ву или сумме.

По структуре вывода долей, я подумаю (через полчасика примерно).

Автор - YouGreed
Дата добавления - 04.03.2020 в 13:44
Pelena Дата: Среда, 04.03.2020, 13:58 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16037
Репутация: 3485 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
[offtop]Кто придумывает такие таблицы??!! :'( [/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]Кто придумывает такие таблицы??!! :'( [/offtop]

Автор - Pelena
Дата добавления - 04.03.2020 в 13:58
YouGreed Дата: Среда, 04.03.2020, 15:07 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 553
Репутация: 116 ±
Замечаний: 0% ±

Excel 2010
qwerty45, Часть 2.

Код
=ЕСЛИОШИБКА(ИНДЕКС($D$1:$CG$2;СТОЛБЕЦ(A1);СТРОКА(A1)*2;1);"")
- вытягиваем перечень магазинов;
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$1:$CG$2;СТОЛБЕЦ(B1);СТРОКА(B1)*2;1);"")
- вытягиваем критерий;
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$4:$CG$6;ПОИСКПОЗ(C$11;$A$4:$A$6;0);ПОИСКПОЗ($A12&$B12;$D$1:$CG$1&$D$2:$CG$2;0);1);"")
- вытягиваем данные (формула массива Shift+Ctrl+Enter).
Ну и конечно же, просчет доли
Код
=ЕСЛИОШИБКА(C12/$C$10;"")
К сообщению приложен файл: 8086965.xls(82.0 Kb)
 
Ответить
Сообщениеqwerty45, Часть 2.

Код
=ЕСЛИОШИБКА(ИНДЕКС($D$1:$CG$2;СТОЛБЕЦ(A1);СТРОКА(A1)*2;1);"")
- вытягиваем перечень магазинов;
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$1:$CG$2;СТОЛБЕЦ(B1);СТРОКА(B1)*2;1);"")
- вытягиваем критерий;
Код
=ЕСЛИОШИБКА(ИНДЕКС($D$4:$CG$6;ПОИСКПОЗ(C$11;$A$4:$A$6;0);ПОИСКПОЗ($A12&$B12;$D$1:$CG$1&$D$2:$CG$2;0);1);"")
- вытягиваем данные (формула массива Shift+Ctrl+Enter).
Ну и конечно же, просчет доли
Код
=ЕСЛИОШИБКА(C12/$C$10;"")

Автор - YouGreed
Дата добавления - 04.03.2020 в 15:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление суммарных продаж и доли каждого магазина (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!