Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование данных для выпадающего списка по двум критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование данных для выпадающего списка по двум критериям (Формулы/Formulas)
Формирование данных для выпадающего списка по двум критериям
ms041270 Дата: Пятница, 20.03.2020, 13:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.

УСЛОВИЕ:
1 Есть разные Участки (на заводе)
2 Есть четыре Вида поломок (одинаковый набор для каждого участка)
3 Есть Поломки в каждом Виде (разные/одинаковые)
4 Есть база Поломок по Участкам и Видам (H15:K23)
5 Есть 3 поля со списками ("Участок", "Вид поломки", "Поломка")

НЕОБХОДИМО:
1 При выборе в полях "Участок" и "Вид поломки" сформировать список в ячейках D13:D15 для поля "Поломка"

Файл примера прилагается.

Спасибо!!!
К сообщению приложен файл: .xlsm.xlsx(12.3 Kb)
 
Ответить
СообщениеДобрый день.

УСЛОВИЕ:
1 Есть разные Участки (на заводе)
2 Есть четыре Вида поломок (одинаковый набор для каждого участка)
3 Есть Поломки в каждом Виде (разные/одинаковые)
4 Есть база Поломок по Участкам и Видам (H15:K23)
5 Есть 3 поля со списками ("Участок", "Вид поломки", "Поломка")

НЕОБХОДИМО:
1 При выборе в полях "Участок" и "Вид поломки" сформировать список в ячейках D13:D15 для поля "Поломка"

Файл примера прилагается.

Спасибо!!!

Автор - ms041270
Дата добавления - 20.03.2020 в 13:01
Nic70y Дата: Пятница, 20.03.2020, 13:17 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6087
Репутация: 1338 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(СТРОКА(D1)>СЧЁТЕСЛИ($G$15:$G$23;$B$12);"";ИНДЕКС($H$15:$K$23;ПОИСКПОЗ($B$12;$G$15:$G$23;)-1+СТРОКА(D1);$C$12))
К сообщению приложен файл: xlsm.xlsx(16.8 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(СТРОКА(D1)>СЧЁТЕСЛИ($G$15:$G$23;$B$12);"";ИНДЕКС($H$15:$K$23;ПОИСКПОЗ($B$12;$G$15:$G$23;)-1+СТРОКА(D1);$C$12))

Автор - Nic70y
Дата добавления - 20.03.2020 в 13:17
ms041270 Дата: Пятница, 20.03.2020, 13:35 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
БООООООООЛЬШОЕ СПАСИБО!!!!
 
Ответить
СообщениеБООООООООЛЬШОЕ СПАСИБО!!!!

Автор - ms041270
Дата добавления - 20.03.2020 в 13:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование данных для выпадающего списка по двум критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!