Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор данных из массива по нескольким условиям, включая дату - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных из массива по нескольким условиям, включая дату (Формулы/Formulas)
Выбор данных из массива по нескольким условиям, включая дату
Alena_28 Дата: Суббота, 21.03.2020, 12:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!
Очень нужна помощь
В приложенном файле нужно заполнить лист Свод. Нужно выбрать из массива данные по нескольким условиям: перевозчик, и дата.
Буду очень благодарна!
К сообщению приложен файл: 2365822.xls(323.5 Kb)
 
Ответить
СообщениеДобрый день!
Очень нужна помощь
В приложенном файле нужно заполнить лист Свод. Нужно выбрать из массива данные по нескольким условиям: перевозчик, и дата.
Буду очень благодарна!

Автор - Alena_28
Дата добавления - 21.03.2020 в 12:41
Nic70y Дата: Суббота, 21.03.2020, 12:52 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6087
Репутация: 1338 ±
Замечаний: 0% ±

ru13;10;03
вметсо текста Месяц-год ввел 1-е число месяца-года, установил соот. формат,
чтоб формулы были проще:
Код
=СУММЕСЛИМН(Реестр!I:I;Реестр!$E:$E;$B4;Реестр!$A:$A;">="&$C$2;Реестр!$A:$A;"<="&КОНМЕСЯЦА($C$2;0))
проверяйте,
вдруг правильно
К сообщению приложен файл: 6031317.xls(335.5 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениевметсо текста Месяц-год ввел 1-е число месяца-года, установил соот. формат,
чтоб формулы были проще:
Код
=СУММЕСЛИМН(Реестр!I:I;Реестр!$E:$E;$B4;Реестр!$A:$A;">="&$C$2;Реестр!$A:$A;"<="&КОНМЕСЯЦА($C$2;0))
проверяйте,
вдруг правильно

Автор - Nic70y
Дата добавления - 21.03.2020 в 12:52
AlexM Дата: Суббота, 21.03.2020, 13:43 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4039
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2003
вметсо текста Месяц-год ввел 1-е число месяца-года, установил соот. формат,
чтоб формулы были проще:
Но формула другая
Код
=СУММПРОИЗВ((Реестр!$E$2:$E$999=$B4)*(ТЕКСТ(Реестр!$A$2:$A$999;"ММГГГ")=ТЕКСТ(C$2;"ММГГГ"))*Реестр!$I$2:$I$999)
К сообщению приложен файл: 7112836_01.xls(339.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
вметсо текста Месяц-год ввел 1-е число месяца-года, установил соот. формат,
чтоб формулы были проще:
Но формула другая
Код
=СУММПРОИЗВ((Реестр!$E$2:$E$999=$B4)*(ТЕКСТ(Реестр!$A$2:$A$999;"ММГГГ")=ТЕКСТ(C$2;"ММГГГ"))*Реестр!$I$2:$I$999)

Автор - AlexM
Дата добавления - 21.03.2020 в 13:43
Alena_28 Дата: Суббота, 21.03.2020, 15:24 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо огромное!!! hands
 
Ответить
СообщениеСпасибо огромное!!! hands

Автор - Alena_28
Дата добавления - 21.03.2020 в 15:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор данных из массива по нескольким условиям, включая дату (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!