Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменении расчета при изменении заголовка столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменении расчета при изменении заголовка столбца (Формулы/Formulas)
Изменении расчета при изменении заголовка столбца
blax8 Дата: Воскресенье, 22.03.2020, 19:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте. Есть таблица подсчета очков, можно ли сделать чтоб при изменении дистанции (B5)очки брались с другова столбца.
К сообщению приложен файл: 4551997.xlsx(11.4 Kb)
 
Ответить
СообщениеЗдравствуйте. Есть таблица подсчета очков, можно ли сделать чтоб при изменении дистанции (B5)очки брались с другова столбца.

Автор - blax8
Дата добавления - 22.03.2020 в 19:44
Pelena Дата: Воскресенье, 22.03.2020, 22:18 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15405
Репутация: 3370 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$E$2:$E$22;ПОИСКПОЗ(B6;ИНДЕКС(Лист2!$A$2:$E$22;0;ПОИСКПОЗ($B$5;Лист2!$A$1:$E$1;0));0));"")
К сообщению приложен файл: 5744105.xlsx(11.6 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$E$2:$E$22;ПОИСКПОЗ(B6;ИНДЕКС(Лист2!$A$2:$E$22;0;ПОИСКПОЗ($B$5;Лист2!$A$1:$E$1;0));0));"")

Автор - Pelena
Дата добавления - 22.03.2020 в 22:18
blax8 Дата: Понедельник, 23.03.2020, 04:55 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Pelena, большое спасибо!! Направление показали, дальше постараюсь закончить таблицу. hands
 
Ответить
СообщениеPelena, большое спасибо!! Направление показали, дальше постараюсь закончить таблицу. hands

Автор - blax8
Дата добавления - 23.03.2020 в 04:55
AlexM Дата: Понедельник, 23.03.2020, 09:44 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3976
Репутация: 996 ±
Замечаний: 0% ±

Excel 2003
Мне кажется, что В5 можно не учитывать.
Формула для очков
Код
=ЕСЛИ(B6;ИНДЕКС(Лист2!E$1:E$22;СУММПРОИЗВ((Лист2!A$2:D$22=B6)*СТРОКА(A$2:D$22)));"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеМне кажется, что В5 можно не учитывать.
Формула для очков
Код
=ЕСЛИ(B6;ИНДЕКС(Лист2!E$1:E$22;СУММПРОИЗВ((Лист2!A$2:D$22=B6)*СТРОКА(A$2:D$22)));"")

Автор - AlexM
Дата добавления - 23.03.2020 в 09:44
blax8 Дата: Понедельник, 23.03.2020, 19:53 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
AlexM, Спасибо большое, но если данные пересекаются, то это решение дает сбой. В некоторых условиях отличное решение, еще раз спасибо.
 
Ответить
СообщениеAlexM, Спасибо большое, но если данные пересекаются, то это решение дает сбой. В некоторых условиях отличное решение, еще раз спасибо.

Автор - blax8
Дата добавления - 23.03.2020 в 19:53
AlexM Дата: Понедельник, 23.03.2020, 19:57 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3976
Репутация: 996 ±
Замечаний: 0% ±

Excel 2003
Я обратил внимание, что значения идут по возрастанию. Решил что так будет всегда.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЯ обратил внимание, что значения идут по возрастанию. Решил что так будет всегда.

Автор - AlexM
Дата добавления - 23.03.2020 в 19:57
blax8 Дата: Понедельник, 23.03.2020, 20:00 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
AlexM, это "рыба" при таблице на 600, 800 метров данные будут пересекаться и результат может быть ошибочным. В узкой программе идеальное решение, где результат будет разный. Спасибо.
 
Ответить
СообщениеAlexM, это "рыба" при таблице на 600, 800 метров данные будут пересекаться и результат может быть ошибочным. В узкой программе идеальное решение, где результат будет разный. Спасибо.

Автор - blax8
Дата добавления - 23.03.2020 в 20:00
AlexM Дата: Понедельник, 23.03.2020, 20:06 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3976
Репутация: 996 ±
Замечаний: 0% ±

Excel 2003
Еще формула
Код
=ЕСЛИ(B6;ВПР(B6;ЕСЛИ({1;0};ИНДЕКС(Лист2!A$2:E$22;0;ПОИСКПОЗ(B$5;Лист2!A$1:E$1;));Лист2!E$2:E$22);2;);"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще формула
Код
=ЕСЛИ(B6;ВПР(B6;ЕСЛИ({1;0};ИНДЕКС(Лист2!A$2:E$22;0;ПОИСКПОЗ(B$5;Лист2!A$1:E$1;));Лист2!E$2:E$22);2;);"")

Автор - AlexM
Дата добавления - 23.03.2020 в 20:06
blax8 Дата: Понедельник, 23.03.2020, 20:46 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
AlexM, СУПЕР. СПАСИБО, сейчас таблицы оформлю и будет работать.
 
Ответить
СообщениеAlexM, СУПЕР. СПАСИБО, сейчас таблицы оформлю и будет работать.

Автор - blax8
Дата добавления - 23.03.2020 в 20:46
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменении расчета при изменении заголовка столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!