Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование простых и дробных чисел в табеле учета рабочего - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование простых и дробных чисел в табеле учета рабочего (Формулы/Formulas)
Суммирование простых и дробных чисел в табеле учета рабочего
katy Дата: Понедельник, 23.03.2020, 08:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем здравствуйте, помогите пожалуйста! нужно посчитать отработанные дни, часы и ночные в табеле учета рабочего времени, загвоздка в дробях, в том числе. Мучаюсь неделю, с перерывами. Спасибо заранее. [color=blue]
К сообщению приложен файл: ____2018.xlsx(26.1 Kb)
 
Ответить
СообщениеВсем здравствуйте, помогите пожалуйста! нужно посчитать отработанные дни, часы и ночные в табеле учета рабочего времени, загвоздка в дробях, в том числе. Мучаюсь неделю, с перерывами. Спасибо заранее. [color=blue]

Автор - katy
Дата добавления - 23.03.2020 в 08:07
AVI Дата: Понедельник, 23.03.2020, 08:41 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 518
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
katy, Вам самим-то удобно 7,2 часа считать?
 
Ответить
Сообщениеkaty, Вам самим-то удобно 7,2 часа считать?

Автор - AVI
Дата добавления - 23.03.2020 в 08:41
Nic70y Дата: Понедельник, 23.03.2020, 08:55 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6087
Репутация: 1338 ±
Замечаний: 0% ±

ru13;10;03
часы
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ(0&F22:AI22;ПОИСК("/";F22:AI22&"/"));))
ночные
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(F22:AI22;ПОИСК("/";F22:AI22)+1;2);0))
формулы массива
К сообщению приложен файл: _2018.xlsx(27.6 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениечасы
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ(0&F22:AI22;ПОИСК("/";F22:AI22&"/"));))
ночные
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(F22:AI22;ПОИСК("/";F22:AI22)+1;2);0))
формулы массива

Автор - Nic70y
Дата добавления - 23.03.2020 в 08:55
китин Дата: Понедельник, 23.03.2020, 08:59 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6153
Репутация: 950 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
И вам Доброго!!
Дни
Код
=СЧЁТ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ($F22:$AI22;"/";",");"В"))

Часы
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ($F22:$AI22;ПОИСК("/";$F22:$AI22)-1);$F22:$AI22))-AM22

Ночные
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР($F22:$AI22;ПОИСК("/";$F22:$AI22)+1;2);0))

Все формулы Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 2533530.xlsx(28.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеИ вам Доброго!!
Дни
Код
=СЧЁТ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ($F22:$AI22;"/";",");"В"))

Часы
Код
=СУММ(ЕСЛИОШИБКА(--ЛЕВБ($F22:$AI22;ПОИСК("/";$F22:$AI22)-1);$F22:$AI22))-AM22

Ночные
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР($F22:$AI22;ПОИСК("/";$F22:$AI22)+1;2);0))

Все формулы Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 23.03.2020 в 08:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование простых и дробных чисел в табеле учета рабочего (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!