Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Присвоение уникального артикула для категорий товаров - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение уникального артикула для категорий товаров (Формулы/Formulas)
Присвоение уникального артикула для категорий товаров
artemshk Дата: Вторник, 24.03.2020, 00:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Уважаемые форумчане, добрый день!
Нужна помощь в решение вопроса: присвоить уникальные артикулы категории товаров.
Ранее была похожая тема, но там решался чуть другой вопрос.

Пример файла прилагаю. В жизни это каталог с товарами (~100 тыс наимен).
Нужно чтобы уникальный артикул формировался для уникальной категории.

Пример того, что нужно:
Арт. 1 категория 1
1 птицы
1 птицы
2 звери
2 звери
2 звери

Заранее спасибо!
 
Ответить
СообщениеУважаемые форумчане, добрый день!
Нужна помощь в решение вопроса: присвоить уникальные артикулы категории товаров.
Ранее была похожая тема, но там решался чуть другой вопрос.

Пример файла прилагаю. В жизни это каталог с товарами (~100 тыс наимен).
Нужно чтобы уникальный артикул формировался для уникальной категории.

Пример того, что нужно:
Арт. 1 категория 1
1 птицы
1 птицы
2 звери
2 звери
2 звери

Заранее спасибо!

Автор - artemshk
Дата добавления - 24.03.2020 в 00:08
AlexM Дата: Вторник, 24.03.2020, 07:16 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4039
Репутация: 1008 ±
Замечаний: 0% ±

Excel 2003
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$2:B2;B2)=1;МАКС(A$1:A1)+1;"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(B$2:B2;B2)=1;МАКС(A$1:A1)+1;"")

Автор - AlexM
Дата добавления - 24.03.2020 в 07:16
artemshk Дата: Вторник, 24.03.2020, 12:38 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
=ЕСЛИ(СЧЁТЕСЛИ(B$2:B2;B2)=1;МАКС(A$1:A1)+1;"")


Спасибо за ответ. В таком варианте формулы получаются пустые ячейки при повторяющейся категории. Значение Артикула должно повторятся при совпадении значения категории. Когда уникальных категории > 1000, не предоставляется возможным копировать значение артикула.

Пример того, что получается с такой формулой:

Арт.1 Кат.1
1 птицы
птицы
2 звери
звери
звери
 
Ответить
Сообщение
=ЕСЛИ(СЧЁТЕСЛИ(B$2:B2;B2)=1;МАКС(A$1:A1)+1;"")


Спасибо за ответ. В таком варианте формулы получаются пустые ячейки при повторяющейся категории. Значение Артикула должно повторятся при совпадении значения категории. Когда уникальных категории > 1000, не предоставляется возможным копировать значение артикула.

Пример того, что получается с такой формулой:

Арт.1 Кат.1
1 птицы
птицы
2 звери
звери
звери

Автор - artemshk
Дата добавления - 24.03.2020 в 12:38
китин Дата: Вторник, 24.03.2020, 13:08 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6153
Репутация: 950 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
artemshk, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеartemshk, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 24.03.2020 в 13:08
artemshk Дата: Вторник, 24.03.2020, 13:49 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Файл приложил: две вкладки - исходник и как нужно. Спасибо.
К сообщению приложен файл: ___-_-.xls(33.5 Kb)
 
Ответить
СообщениеФайл приложил: две вкладки - исходник и как нужно. Спасибо.

Автор - artemshk
Дата добавления - 24.03.2020 в 13:49
Nic70y Дата: Вторник, 24.03.2020, 14:10 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6087
Репутация: 1338 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(СТРОКА()=2;ОКРУГЛВВЕРХ(СТОЛБЕЦ()/2;)*100&"-1";ЕСЛИ(B2=B1;A1;ОКРУГЛВВЕРХ(СТОЛБЕЦ()/2;)*100&-(1+ПСТР(A1;ПОИСК("-";A1)+1;15))))
Код
=ЕСЛИ(СТРОКА()=2;ПСТР(A$1;ПОИСК("-";A$1)+1;15)*100&"-1";ЕСЛИ(B2=B1;A1;ПСТР(A$1;ПОИСК("-";A$1)+1;15)*100&-(1+ПСТР(A1;ПОИСК("-";A1)+1;15))))
К сообщению приложен файл: 8277452.xls(37.0 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(СТРОКА()=2;ОКРУГЛВВЕРХ(СТОЛБЕЦ()/2;)*100&"-1";ЕСЛИ(B2=B1;A1;ОКРУГЛВВЕРХ(СТОЛБЕЦ()/2;)*100&-(1+ПСТР(A1;ПОИСК("-";A1)+1;15))))
Код
=ЕСЛИ(СТРОКА()=2;ПСТР(A$1;ПОИСК("-";A$1)+1;15)*100&"-1";ЕСЛИ(B2=B1;A1;ПСТР(A$1;ПОИСК("-";A$1)+1;15)*100&-(1+ПСТР(A1;ПОИСК("-";A1)+1;15))))

Автор - Nic70y
Дата добавления - 24.03.2020 в 14:10
artemshk Дата: Вторник, 24.03.2020, 14:47 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - artemshk
Дата добавления - 24.03.2020 в 14:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Присвоение уникального артикула для категорий товаров (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!