Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Протяжка формулы с шагом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протяжка формулы с шагом (Формулы/Formulas)
Протяжка формулы с шагом
Sergey_1985 Дата: Четверг, 02.04.2020, 18:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем привет. Может кто подскажет, вдруг повезет.
Есть лист2 где данные по порядку, нужно заполнить лист1 этими данными, но с пропуском через 32 ячейки. Вот ломаю голову, простое протягивание делает шаг и все смещается.
Пример во вложении.
Заранее благодарю.
К сообщению приложен файл: 2723708.xlsx(9.4 Kb)


Сообщение отредактировал Sergey_1985 - Четверг, 02.04.2020, 18:01
 
Ответить
СообщениеВсем привет. Может кто подскажет, вдруг повезет.
Есть лист2 где данные по порядку, нужно заполнить лист1 этими данными, но с пропуском через 32 ячейки. Вот ломаю голову, простое протягивание делает шаг и все смещается.
Пример во вложении.
Заранее благодарю.

Автор - Sergey_1985
Дата добавления - 02.04.2020 в 18:00
jakim Дата: Четверг, 02.04.2020, 19:10 | Сообщение № 2
Группа: Друзья
Ранг: Ветеран
Сообщений: 963
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Может так?
Для первой строки формула

Код
=INDEX(Лист2!A$1:A$9;1)

Для второй и последующих строк

Код
=IFERROR(INDEX(Лист2!A$1:A$9;IF(MOD(ROWS($2:2)-1;32)+1=32;CEILING(ROW()/32;1);""));"")
К сообщению приложен файл: 9729001.xlsx(11.0 Kb)
 
Ответить
Сообщение
Может так?
Для первой строки формула

Код
=INDEX(Лист2!A$1:A$9;1)

Для второй и последующих строк

Код
=IFERROR(INDEX(Лист2!A$1:A$9;IF(MOD(ROWS($2:2)-1;32)+1=32;CEILING(ROW()/32;1);""));"")

Автор - jakim
Дата добавления - 02.04.2020 в 19:10
AlexM Дата: Четверг, 02.04.2020, 19:46 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);32)=1;ИНДЕКС(Лист2!A:A;СТРОКА(A32)/32);"")
Вставить в первую строку и протянуть



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Четверг, 02.04.2020, 19:48
 
Ответить
Сообщение
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A1);32)=1;ИНДЕКС(Лист2!A:A;СТРОКА(A32)/32);"")
Вставить в первую строку и протянуть

Автор - AlexM
Дата добавления - 02.04.2020 в 19:46
Sergey_1985 Дата: Пятница, 03.04.2020, 10:31 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM, Спасибо, в точку!
 
Ответить
СообщениеAlexM, Спасибо, в точку!

Автор - Sergey_1985
Дата добавления - 03.04.2020 в 10:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протяжка формулы с шагом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!