Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Упрощение формулы применением Индекса или другим способом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упрощение формулы применением Индекса или другим способом (Формулы/Formulas)
Упрощение формулы применением Индекса или другим способом
nifra Дата: Суббота, 04.04.2020, 23:05 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 154
Репутация: 0 ±
Замечаний: 20% ±

Доброго дня! Уважаемые.

Прошу помочь с построением формулы. Ранее была формула, показанная в ячейке D21, но добавляя новые столбцы, понял, что она не удобна для использования.

решил в ячейке D22 сделать с индексом, но как я понимаю, этот вариант возможен, когда делаешь выпадающий список через вкладку "Разработчик" (поправьте если не прав)

Суть:
в Ячейке D22 должна появляться цифра из массива С13:К17, при выборе двух значений в ячейках Q4 и Q5
К сообщению приложен файл: 7093250.xlsx(15.3 Kb)
 
Ответить
СообщениеДоброго дня! Уважаемые.

Прошу помочь с построением формулы. Ранее была формула, показанная в ячейке D21, но добавляя новые столбцы, понял, что она не удобна для использования.

решил в ячейке D22 сделать с индексом, но как я понимаю, этот вариант возможен, когда делаешь выпадающий список через вкладку "Разработчик" (поправьте если не прав)

Суть:
в Ячейке D22 должна появляться цифра из массива С13:К17, при выборе двух значений в ячейках Q4 и Q5

Автор - nifra
Дата добавления - 04.04.2020 в 23:05
Pelena Дата: Суббота, 04.04.2020, 23:10 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16779
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ИНДЕКС(C13:K17;ПОИСКПОЗ(Q5;B13:B17;0);ПОИСКПОЗ(Q4;C19:K19;0))
К сообщению приложен файл: 4389946.xlsx(15.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ИНДЕКС(C13:K17;ПОИСКПОЗ(Q5;B13:B17;0);ПОИСКПОЗ(Q4;C19:K19;0))

Автор - Pelena
Дата добавления - 04.04.2020 в 23:10
nifra Дата: Воскресенье, 05.04.2020, 23:33 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 154
Репутация: 0 ±
Замечаний: 20% ±

Pelena, у меня ещё 1 вопрос , возможно этой же формулой можно его решить, но у меня не получилось.

Сможете помочь?

в ячейке К8 формула .

Суть:в диапазоне С19:N19 имеется текст в каждой ячейке. при выборе значения в ячейке Т4, должна выполняться формула (2*U2+V2)*L36/1000 , если ячейка содержит текст "Ei". в противном случае ничего не должно происходить.
К сообщению приложен файл: 2786435.xls(56.0 Kb)
 
Ответить
СообщениеPelena, у меня ещё 1 вопрос , возможно этой же формулой можно его решить, но у меня не получилось.

Сможете помочь?

в ячейке К8 формула .

Суть:в диапазоне С19:N19 имеется текст в каждой ячейке. при выборе значения в ячейке Т4, должна выполняться формула (2*U2+V2)*L36/1000 , если ячейка содержит текст "Ei". в противном случае ничего не должно происходить.

Автор - nifra
Дата добавления - 05.04.2020 в 23:33
Pelena Дата: Понедельник, 06.04.2020, 07:59 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16779
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("Ei";T4));(2*U2+V2)*L36/1000;0)

если буквы всегда первые
Код
=ЕСЛИ(ЛЕВСИМВ(T4;2)="Ei";(2*U2+V2)*L36/1000;0)


И да, не надо складывать все вопросы в одну тему


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("Ei";T4));(2*U2+V2)*L36/1000;0)

если буквы всегда первые
Код
=ЕСЛИ(ЛЕВСИМВ(T4;2)="Ei";(2*U2+V2)*L36/1000;0)


И да, не надо складывать все вопросы в одну тему

Автор - Pelena
Дата добавления - 06.04.2020 в 07:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упрощение формулы применением Индекса или другим способом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!