Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух прайс-листов, поиск лучшей цены - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух прайс-листов, поиск лучшей цены (Формулы/Formulas)
Сравнение двух прайс-листов, поиск лучшей цены
ArSon Дата: Среда, 08.04.2020, 15:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Помогите разобраться: Есть два поставщика (может и три) овощей, номенклатура у всех одинакова. Требуется сравнить у кого выгодней цена. Проблема в том что некоторые позиции из списка в данный период отсутствуют у поставщика и их цена либо Ноль либо можно оставить пустую ячейку. При сравнении пустая (нулевая) ячейка становится как более низкая цена и в ячейке где выводится лучшее предложение прописывается поставщик у которого этой позиции нет в наличии.

Второй момент, это одинаковые цены: у обоих поставщиков есть товар с одинаковой ценой, нужно при возникновении ситуации когда цены одинаковы выбирать того поставщика у которого больше позиций с более низкой ценой. Например из 30 сравниваемых позиций 18 выгодней покупать у Поставщик_1, следовательно если у 6 позиций цена одинаковая с Поставщик_2 то в колонке выбора поставщика должен прописаться Поставщик_1, либо если автоматизация этой операции сложная, то иметь возможность назначать поставщика. Номенклатура порядка 100-150 позиций.
К сообщению приложен файл: 08042020ARS.xlsx(9.8 Kb)
 
Ответить
СообщениеДобрый день!
Помогите разобраться: Есть два поставщика (может и три) овощей, номенклатура у всех одинакова. Требуется сравнить у кого выгодней цена. Проблема в том что некоторые позиции из списка в данный период отсутствуют у поставщика и их цена либо Ноль либо можно оставить пустую ячейку. При сравнении пустая (нулевая) ячейка становится как более низкая цена и в ячейке где выводится лучшее предложение прописывается поставщик у которого этой позиции нет в наличии.

Второй момент, это одинаковые цены: у обоих поставщиков есть товар с одинаковой ценой, нужно при возникновении ситуации когда цены одинаковы выбирать того поставщика у которого больше позиций с более низкой ценой. Например из 30 сравниваемых позиций 18 выгодней покупать у Поставщик_1, следовательно если у 6 позиций цена одинаковая с Поставщик_2 то в колонке выбора поставщика должен прописаться Поставщик_1, либо если автоматизация этой операции сложная, то иметь возможность назначать поставщика. Номенклатура порядка 100-150 позиций.

Автор - ArSon
Дата добавления - 08.04.2020 в 15:30
_Boroda_ Дата: Четверг, 09.04.2020, 02:52 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Сделал для трех
В первой строке
Код
=СУММПРОИЗВ(--(МУМНОЖ(--(--ТЕКСТ($C3:$E16;"0,00;;99999")>C3:C16);{1:1:1})=2))

В столбце
если в таблице нули
Код
=ПРОСМОТР(;-1/ЕСЛИ(СЧЁТЕСЛИ(C3:E3;МИН(--ТЕКСТ(C3:E3;"0,00;;99999")))>1;МАКС(C$1:E$1)=C$1:E$1;МИН(--ТЕКСТ(C3:E3;"0,00;;99999"))=C3:E3);C$2:E$2)

если пусто
Код
=ПРОСМОТР(;-1/ЕСЛИ(СЧЁТЕСЛИ(C3:E3;МИН(C3:E3))>1;МАКС(C$1:E$1)=C$1:E$1;МИН(C3:E3)=C3:E3);C$2:E$2)

Две последние - формулы массива. Вводятся одновременным нажатием Контрл Шифт Ентер
К сообщению приложен файл: 08042020ARS_1.xlsx(12.2 Kb) · 08042020ARS_2.xlsx(12.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСделал для трех
В первой строке
Код
=СУММПРОИЗВ(--(МУМНОЖ(--(--ТЕКСТ($C3:$E16;"0,00;;99999")>C3:C16);{1:1:1})=2))

В столбце
если в таблице нули
Код
=ПРОСМОТР(;-1/ЕСЛИ(СЧЁТЕСЛИ(C3:E3;МИН(--ТЕКСТ(C3:E3;"0,00;;99999")))>1;МАКС(C$1:E$1)=C$1:E$1;МИН(--ТЕКСТ(C3:E3;"0,00;;99999"))=C3:E3);C$2:E$2)

если пусто
Код
=ПРОСМОТР(;-1/ЕСЛИ(СЧЁТЕСЛИ(C3:E3;МИН(C3:E3))>1;МАКС(C$1:E$1)=C$1:E$1;МИН(C3:E3)=C3:E3);C$2:E$2)

Две последние - формулы массива. Вводятся одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 09.04.2020 в 02:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух прайс-листов, поиск лучшей цены (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!