Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка значений по двум исходным - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений по двум исходным (Формулы/Formulas)
Выборка значений по двум исходным
AlZ Дата: Среда, 08.04.2020, 18:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Коллеги, вспоможите, плз... Весь мозг вскипел... Как использовать ГПР при совпадении двух обязательных условий Даты и Признака...
К сообщению приложен файл: 9469502.xlsx(11.0 Kb)


Ал
 
Ответить
СообщениеКоллеги, вспоможите, плз... Весь мозг вскипел... Как использовать ГПР при совпадении двух обязательных условий Даты и Признака...

Автор - AlZ
Дата добавления - 08.04.2020 в 18:54
AlexM Дата: Среда, 08.04.2020, 19:03 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Если нет решения с ГПР() другие предлагать?



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕсли нет решения с ГПР() другие предлагать?

Автор - AlexM
Дата добавления - 08.04.2020 в 19:03
AlZ Дата: Среда, 08.04.2020, 19:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
С Индексом у меня тоже как-то не сложилось))))... Очень не хотелось бы лезть в VBA...


Ал
 
Ответить
СообщениеС Индексом у меня тоже как-то не сложилось))))... Очень не хотелось бы лезть в VBA...

Автор - AlZ
Дата добавления - 08.04.2020 в 19:07
AlexM Дата: Среда, 08.04.2020, 19:15 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММПРОИЗВ(($B$2:$Z$2=B$11)*($B$3:$Z$3=$A$10)*ИНДЕКС($B$4:$Z$7;ПОИСКПОЗ($A12;$A$4:$A$7;);))
К сообщению приложен файл: 9469502_01.xlsx(11.2 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($B$2:$Z$2=B$11)*($B$3:$Z$3=$A$10)*ИНДЕКС($B$4:$Z$7;ПОИСКПОЗ($A12;$A$4:$A$7;);))

Автор - AlexM
Дата добавления - 08.04.2020 в 19:15
jakim Дата: Среда, 08.04.2020, 19:31 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 999
Репутация: 272 ±
Замечаний: 0% ±

Excel 2010
Или так по трём условиям

Код
=IFERROR(INDEX($B$4:$Q$7;MATCH($A12;$A$4:$A$7;0);AGGREGATE(15;6;COLUMN($A:$V)/($B$2:$Q$2=B$11)/($A$4:$A$7=$A12)/($B$3:$Q$3=$A$10);1));0)
К сообщению приложен файл: 5989373.xlsx(11.9 Kb)
 
Ответить
Сообщение
Или так по трём условиям

Код
=IFERROR(INDEX($B$4:$Q$7;MATCH($A12;$A$4:$A$7;0);AGGREGATE(15;6;COLUMN($A:$V)/($B$2:$Q$2=B$11)/($A$4:$A$7=$A12)/($B$3:$Q$3=$A$10);1));0)

Автор - jakim
Дата добавления - 08.04.2020 в 19:31
_Boroda_ Дата: Среда, 08.04.2020, 19:32 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
У меня такой вариант (с учетом того, что наименования расположены одинаково
Код
=ИНДЕКС($B$10:$AH$32;ПОИСКПОЗ(B$3;$A$9:$A$27;)+СТРОКА(B1);ПОИСКПОЗ(B$2;$B$10:$AH$10;))

Или так
Код
=ИНДЕКС($B11:$AH$32;ПОИСКПОЗ(B$3;$A$9:$A$27;);ПОИСКПОЗ(B$2;$B$10:$AH$10;))
К сообщению приложен файл: _1_1.xlsx(10.9 Kb) · _1_2.xlsx(11.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУ меня такой вариант (с учетом того, что наименования расположены одинаково
Код
=ИНДЕКС($B$10:$AH$32;ПОИСКПОЗ(B$3;$A$9:$A$27;)+СТРОКА(B1);ПОИСКПОЗ(B$2;$B$10:$AH$10;))

Или так
Код
=ИНДЕКС($B11:$AH$32;ПОИСКПОЗ(B$3;$A$9:$A$27;);ПОИСКПОЗ(B$2;$B$10:$AH$10;))

Автор - _Boroda_
Дата добавления - 08.04.2020 в 19:32
AlexM Дата: Среда, 08.04.2020, 19:36 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Александр, формула нужна для целевой таблицы. У тебя в исходной.

[offtop]Александр, что-то давно тебя не было видно на форуме.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеАлександр, формула нужна для целевой таблицы. У тебя в исходной.

[offtop]Александр, что-то давно тебя не было видно на форуме.

Автор - AlexM
Дата добавления - 08.04.2020 в 19:36
AlZ Дата: Среда, 08.04.2020, 19:40 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Супер!!! Премного благодарен!!!


Ал
 
Ответить
СообщениеСупер!!! Премного благодарен!!!

Автор - AlZ
Дата добавления - 08.04.2020 в 19:40
AlexM Дата: Среда, 08.04.2020, 19:45 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Еще вариант с протягиваемой формулой. Ничего не надо менять в таблицах с цветом.
Формула массива, очень длинная
Код
=СУММПРОИЗВ(($B$2:$Z$2=B$11)*($B$3:$Z$3=ПРОСМОТР(2;1/МУМНОЖ(ТРАНСП(--($A$10:$A10={"красный";"зеленый";"синий";"желтый"}));СТРОКА($A$10:$A10)^0);{"красный";"зеленый";"синий";"желтый"}))*ИНДЕКС($B$4:$Z$7;ПОИСКПОЗ($A12;$A$4:$A$7;);))
К сообщению приложен файл: 9469502_02.xlsx(12.6 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант с протягиваемой формулой. Ничего не надо менять в таблицах с цветом.
Формула массива, очень длинная
Код
=СУММПРОИЗВ(($B$2:$Z$2=B$11)*($B$3:$Z$3=ПРОСМОТР(2;1/МУМНОЖ(ТРАНСП(--($A$10:$A10={"красный";"зеленый";"синий";"желтый"}));СТРОКА($A$10:$A10)^0);{"красный";"зеленый";"синий";"желтый"}))*ИНДЕКС($B$4:$Z$7;ПОИСКПОЗ($A12;$A$4:$A$7;);))

Автор - AlexM
Дата добавления - 08.04.2020 в 19:45
AlZ Дата: Среда, 08.04.2020, 22:59 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Господа, кто-нить встречался с такой хренью... Выгружено в ёксель из 1С. Вышеуказанные формулы (ВСЕ!) работают на первых 6 столбцах, а дальше никак - либо #Н/Д, либо 0 вместо значения. Исходник пробовал перевставить только значения, изменить формат... Ни хрена не помогает!


Ал
 
Ответить
СообщениеГоспода, кто-нить встречался с такой хренью... Выгружено в ёксель из 1С. Вышеуказанные формулы (ВСЕ!) работают на первых 6 столбцах, а дальше никак - либо #Н/Д, либо 0 вместо значения. Исходник пробовал перевставить только значения, изменить формат... Ни хрена не помогает!

Автор - AlZ
Дата добавления - 08.04.2020 в 22:59
_Boroda_ Дата: Среда, 08.04.2020, 23:49 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Александр, формула нужна для целевой таблицы. У тебя в исходной.

[offtop]
Александр, что-то давно тебя не было видно на форуме.[/offtop]


А, блин, отвык :D
Тогда такой вариант
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($B$2:$Z$2&$B$3:$Z$3=B$11&ПРОСМОТР(;-1/(B$10:B11="");$A$10:$A11));ИНДЕКС($B$4:$Z$7;ПОИСКПОЗ($A12;$A$4:$A$7;);));)


[offtop]Да, давно. Некогда. Я теперь безработный, много времени уходит на поиски[/offtop]

AlZ, по поводу хрени - приложите файл-пример
К сообщению приложен файл: 9469502_1.xlsx(12.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Александр, формула нужна для целевой таблицы. У тебя в исходной.

[offtop]
Александр, что-то давно тебя не было видно на форуме.[/offtop]


А, блин, отвык :D
Тогда такой вариант
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($B$2:$Z$2&$B$3:$Z$3=B$11&ПРОСМОТР(;-1/(B$10:B11="");$A$10:$A11));ИНДЕКС($B$4:$Z$7;ПОИСКПОЗ($A12;$A$4:$A$7;);));)


[offtop]Да, давно. Некогда. Я теперь безработный, много времени уходит на поиски[/offtop]

AlZ, по поводу хрени - приложите файл-пример

Автор - _Boroda_
Дата добавления - 08.04.2020 в 23:49
AlZ Дата: Четверг, 09.04.2020, 00:36 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем спасибо! Разобрался сам... Если честно, то не понимаю, как можно написать скрипт выгрузки, что бы по ходу дела менялся формат данных???? В начале листа даты были как даты, а с 7го столбца пошли как текст. Переубедить удалось только преобразованием вида <значение ячейки с датой>*1 с последующим назначением формата даты))))...


Ал
 
Ответить
СообщениеВсем спасибо! Разобрался сам... Если честно, то не понимаю, как можно написать скрипт выгрузки, что бы по ходу дела менялся формат данных???? В начале листа даты были как даты, а с 7го столбца пошли как текст. Переубедить удалось только преобразованием вида <значение ячейки с датой>*1 с последующим назначением формата даты))))...

Автор - AlZ
Дата добавления - 09.04.2020 в 00:36
_Boroda_ Дата: Четверг, 09.04.2020, 00:43 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Переубедить удалось только преобразованием вида <значение ячейки с датой>*1 с последующим назначением формата даты


Не обязательно преобразовывать, и так все нормально работает. Только две черточки добавить надо
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(--$B$2:$Z$2&$B$3:$Z$3=B$11&ПРОСМОТР(;-1/(B$10:B11="");$A$10:$A11));ИНДЕКС($B$4:$Z$7;ПОИСКПОЗ($A12;$A$4:$A$7;);));)
К сообщению приложен файл: 9469502_2.xlsx(12.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Переубедить удалось только преобразованием вида <значение ячейки с датой>*1 с последующим назначением формата даты


Не обязательно преобразовывать, и так все нормально работает. Только две черточки добавить надо
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(--$B$2:$Z$2&$B$3:$Z$3=B$11&ПРОСМОТР(;-1/(B$10:B11="");$A$10:$A11));ИНДЕКС($B$4:$Z$7;ПОИСКПОЗ($A12;$A$4:$A$7;);));)

Автор - _Boroda_
Дата добавления - 09.04.2020 в 00:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значений по двум исходным (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!