Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнить значения двух таблиц и суммировать если условие удв - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить значения двух таблиц и суммировать если условие удв (Формулы/Formulas)
Сравнить значения двух таблиц и суммировать если условие удв
ilnur89 Дата: Четверг, 09.04.2020, 17:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем привет

Может быть тема не корректно названа, но пока в голову ничего умного так и не пришло.
Сломал голову, целый день потратил, но ответа для себя и не нашел
Вообщем вместо тысячи слов прикрепил файл, там суть проблемы.
На листе1 не решенная задача, которую прошу помочь решить если это возможно,
а на листе2 решенная мной задача спустя целый день мытарств, но как мне кажется не совсем изящно.
К сообщению приложен файл: ___09.04.2020.xlsx(24.9 Kb)
 
Ответить
СообщениеВсем привет

Может быть тема не корректно названа, но пока в голову ничего умного так и не пришло.
Сломал голову, целый день потратил, но ответа для себя и не нашел
Вообщем вместо тысячи слов прикрепил файл, там суть проблемы.
На листе1 не решенная задача, которую прошу помочь решить если это возможно,
а на листе2 решенная мной задача спустя целый день мытарств, но как мне кажется не совсем изящно.

Автор - ilnur89
Дата добавления - 09.04.2020 в 17:00
Pelena Дата: Четверг, 09.04.2020, 19:49 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16796
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Можно формулой массива
Код
=ЕСЛИОШИБКА(СУММ(МУМНОЖ(--(ИНДЕКС($C$57:$W$82;ПОИСКПОЗ($B27;$B$57:$B$82;0);0)=$B$5:$B$25);ТРАНСП(СТОЛБЕЦ($C$57:$W$82)^0))*C$5:C$25);"")
К сообщению приложен файл: _09.04.2020.xlsx(30.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно формулой массива
Код
=ЕСЛИОШИБКА(СУММ(МУМНОЖ(--(ИНДЕКС($C$57:$W$82;ПОИСКПОЗ($B27;$B$57:$B$82;0);0)=$B$5:$B$25);ТРАНСП(СТОЛБЕЦ($C$57:$W$82)^0))*C$5:C$25);"")

Автор - Pelena
Дата добавления - 09.04.2020 в 19:49
_Boroda_ Дата: Четверг, 09.04.2020, 21:37 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант обычной формулой
Код
=СУММПРОИЗВ(СУММЕСЛИ($B$5:$B$25;$C57:$W57;C$5:C$25))

Если названия в таблицах 2 и 3 написаны в разном порядке, то так можно
Код
=СУММПРОИЗВ(СУММЕСЛИ($B$5:$B$25;ИНДЕКС($C$57:$W$82;ПОИСКПОЗ($B27;$B$57:$B$82;););C$5:C$25))
К сообщению приложен файл: _09.04.2020_1.xlsx(26.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант обычной формулой
Код
=СУММПРОИЗВ(СУММЕСЛИ($B$5:$B$25;$C57:$W57;C$5:C$25))

Если названия в таблицах 2 и 3 написаны в разном порядке, то так можно
Код
=СУММПРОИЗВ(СУММЕСЛИ($B$5:$B$25;ИНДЕКС($C$57:$W$82;ПОИСКПОЗ($B27;$B$57:$B$82;););C$5:C$25))

Автор - _Boroda_
Дата добавления - 09.04.2020 в 21:37
ilnur89 Дата: Пятница, 10.04.2020, 07:17 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
hands в голове пазл сошелся. Спасибо за ответы!!!
Сам я пытался сообразить что то подобное как предложил Boroda, но знаний не хватило
как предложила Pelena я бы точно никогда не додумался, это крэйзи вариант для меня (не в обиду)
 
Ответить
Сообщениеhands в голове пазл сошелся. Спасибо за ответы!!!
Сам я пытался сообразить что то подобное как предложил Boroda, но знаний не хватило
как предложила Pelena я бы точно никогда не додумался, это крэйзи вариант для меня (не в обиду)

Автор - ilnur89
Дата добавления - 10.04.2020 в 07:17
ilnur89 Дата: Пятница, 10.04.2020, 07:35 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Boroda, если не затруднит, поясните пожалуйста порядок вычисления
Код
=СУММПРОИЗВ(СУММЕСЛИ($B$5:$B$25;$C57:$W57;C$5:C$25))

не могу понять как работает формула, технологию вычисления так сказать
 
Ответить
СообщениеBoroda, если не затруднит, поясните пожалуйста порядок вычисления
Код
=СУММПРОИЗВ(СУММЕСЛИ($B$5:$B$25;$C57:$W57;C$5:C$25))

не могу понять как работает формула, технологию вычисления так сказать

Автор - ilnur89
Дата добавления - 10.04.2020 в 07:35
_Boroda_ Дата: Суббота, 11.04.2020, 21:47 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
ilnur89, да все просто - считаем СУММЕСЛИ для каждой ячейки из диапазона $C57:$W57, получаем массив из результатов этих подсчетов, а затем все это складываем с помощью СУММПРОИЗВ

Прочитайте Правила форума. В следующий рах для оформления формул используйте теги - кнопка fx


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеilnur89, да все просто - считаем СУММЕСЛИ для каждой ячейки из диапазона $C57:$W57, получаем массив из результатов этих подсчетов, а затем все это складываем с помощью СУММПРОИЗВ

Прочитайте Правила форума. В следующий рах для оформления формул используйте теги - кнопка fx

Автор - _Boroda_
Дата добавления - 11.04.2020 в 21:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить значения двух таблиц и суммировать если условие удв (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!