Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение победителей рейтинга с выводом имен - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение победителей рейтинга с выводом имен (Формулы/Formulas)
Определение победителей рейтинга с выводом имен
aleksei5555 Дата: Вторник, 14.04.2020, 15:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте, нужна помощь в создании формулы для определения победителей рейтинга (1,2,3 место) с выводом имен в отдельную ячейку, но так же если количество баллов в у двух человек одинаково нужно вывести два имени в одну ячейку в зависимости от занятого места.
 
Ответить
СообщениеЗдравствуйте, нужна помощь в создании формулы для определения победителей рейтинга (1,2,3 место) с выводом имен в отдельную ячейку, но так же если количество баллов в у двух человек одинаково нужно вывести два имени в одну ячейку в зависимости от занятого места.

Автор - aleksei5555
Дата добавления - 14.04.2020 в 15:07
прохожий2019 Дата: Вторник, 14.04.2020, 15:18 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 382
Репутация: 64 ±
Замечаний: 0% ±

365 Beta Channel
для начала РАНГ(), а вообще PQ
 
Ответить
Сообщениедля начала РАНГ(), а вообще PQ

Автор - прохожий2019
Дата добавления - 14.04.2020 в 15:18
_Boroda_ Дата: Вторник, 14.04.2020, 15:21 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
aleksei5555, а для самого начала - прочитайте Правила форума и приложите пример файла


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеaleksei5555, а для самого начала - прочитайте Правила форума и приложите пример файла

Автор - _Boroda_
Дата добавления - 14.04.2020 в 15:21
aleksei5555 Дата: Вторник, 14.04.2020, 15:37 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
_Boroda_, прикрепляю файл.
в нем я создал рабочую формулу для опредления трех мест, но если одинаковые баллы у двух людей, то выводится один.
К сообщению приложен файл: 1700233.rar(19.7 Kb)
 
Ответить
Сообщение_Boroda_, прикрепляю файл.
в нем я создал рабочую формулу для опредления трех мест, но если одинаковые баллы у двух людей, то выводится один.

Автор - aleksei5555
Дата добавления - 14.04.2020 в 15:37
_Boroda_ Дата: Вторник, 14.04.2020, 17:38 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Дабы формулы не усложнять сильно, сделал 2 допстолбца (их можно потом скрыть или белыми буквами сделать) - ранг и сборщик фамилий по рангу
Код
=ЕСЛИ(AL6;РАНГ(AL6;AL$7:AL$38))

Код
=ЕСЛИ(AL6;ЕСЛИОШИБКА(ПРОСМОТР(;-1/(AO6=AO$5:AO5);AP$5:AP5)&", ";"")&C6;C$6)

А потом оттуда
Код
=ПРОСМОТР(;-1/(B4=СЕНТЯБРЬ!$AL6:$AL38);СЕНТЯБРЬ!$AP6:$AP38)


В таблице удалил лишние столбцы, убрал ненужные объединенные ячейки (это зло!!!) и переписал формулы в D4 и F4
К сообщению приложен файл: __1.xlsx(24.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДабы формулы не усложнять сильно, сделал 2 допстолбца (их можно потом скрыть или белыми буквами сделать) - ранг и сборщик фамилий по рангу
Код
=ЕСЛИ(AL6;РАНГ(AL6;AL$7:AL$38))

Код
=ЕСЛИ(AL6;ЕСЛИОШИБКА(ПРОСМОТР(;-1/(AO6=AO$5:AO5);AP$5:AP5)&", ";"")&C6;C$6)

А потом оттуда
Код
=ПРОСМОТР(;-1/(B4=СЕНТЯБРЬ!$AL6:$AL38);СЕНТЯБРЬ!$AP6:$AP38)


В таблице удалил лишние столбцы, убрал ненужные объединенные ячейки (это зло!!!) и переписал формулы в D4 и F4

Автор - _Boroda_
Дата добавления - 14.04.2020 в 17:38
aleksei5555 Дата: Вторник, 14.04.2020, 18:29 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
_Boroda_, спасибо большое))) очень помогли. B) B) B)
а то уже всю голову сломал как можно это сделать %)
 
Ответить
Сообщение_Boroda_, спасибо большое))) очень помогли. B) B) B)
а то уже всю голову сломал как можно это сделать %)

Автор - aleksei5555
Дата добавления - 14.04.2020 в 18:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение победителей рейтинга с выводом имен (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!