Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проставить у всех работников старшего смены по дате - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проставить у всех работников старшего смены по дате (Формулы/Formulas)
Проставить у всех работников старшего смены по дате
Olenka_ Дата: Пятница, 17.04.2020, 12:36 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день. Ребята, очень нужна помощь. Как сделать так, чтобы если за 01.01.2020 встречается хоть раз фамилия старшего смены или его зама, то значит это его смена была сегодня, и у всех работающих в этот день проставлялась фамилия старшего в отдельном столбце. Приложила пример, так думаю будет понятнее. Заранее спасибо
К сообщению приложен файл: 1792310.xlsx(9.2 Kb)
 
Ответить
СообщениеДобрый день. Ребята, очень нужна помощь. Как сделать так, чтобы если за 01.01.2020 встречается хоть раз фамилия старшего смены или его зама, то значит это его смена была сегодня, и у всех работающих в этот день проставлялась фамилия старшего в отдельном столбце. Приложила пример, так думаю будет понятнее. Заранее спасибо

Автор - Olenka_
Дата добавления - 17.04.2020 в 12:36
_Boroda_ Дата: Пятница, 17.04.2020, 13:06 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(I:I;МАКС(ЕСЛИОШИБКА(2+ПОИСКПОЗ(ЕСЛИ(A2=A$2:A$99;"*"&B$2:B$99&"*");I$3:I$4&J$3:J$4;);)))&""

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 1792310_1.xlsx(10.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(I:I;МАКС(ЕСЛИОШИБКА(2+ПОИСКПОЗ(ЕСЛИ(A2=A$2:A$99;"*"&B$2:B$99&"*");I$3:I$4&J$3:J$4;);)))&""

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 17.04.2020 в 13:06
AlexM Дата: Пятница, 17.04.2020, 13:12 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Еще вариант, формула массива.
Код
=ИНДЕКС(B$2:B$99;ПОИСКПОЗ(1;МУМНОЖ(--(ЕСЛИ(A$2:A$99=A2;B$2:B$99)=ВЫБОР({1;2;3;4};I$3;J$3;I$4;J$4));{1:1:1:1});))

Александр, 3.01.2020 старшая смены не работала, а работала заместитель, значит нужно поставить заместителя. Я так понял.
К сообщению приложен файл: 1792310_01.xlsx(9.3 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант, формула массива.
Код
=ИНДЕКС(B$2:B$99;ПОИСКПОЗ(1;МУМНОЖ(--(ЕСЛИ(A$2:A$99=A2;B$2:B$99)=ВЫБОР({1;2;3;4};I$3;J$3;I$4;J$4));{1:1:1:1});))

Александр, 3.01.2020 старшая смены не работала, а работала заместитель, значит нужно поставить заместителя. Я так понял.

Автор - AlexM
Дата добавления - 17.04.2020 в 13:12
_Boroda_ Дата: Пятница, 17.04.2020, 13:15 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А я как раз понял, что если даже работал зам, то все равно пишем старшего. Вот из этой фразы
если за 01.01.2020 встречается хоть раз фамилия старшего смены или его зама, то значит это его смена была сегодня, и у всех работающих в этот день проставлялась фамилия старшего


Сначала да, я тоже про зама также, как и ты, подумал. Но потом передумал
Да так даже и лучше, у Оленьки теперь два варианта на выбор есть


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА я как раз понял, что если даже работал зам, то все равно пишем старшего. Вот из этой фразы
если за 01.01.2020 встречается хоть раз фамилия старшего смены или его зама, то значит это его смена была сегодня, и у всех работающих в этот день проставлялась фамилия старшего


Сначала да, я тоже про зама также, как и ты, подумал. Но потом передумал
Да так даже и лучше, у Оленьки теперь два варианта на выбор есть

Автор - _Boroda_
Дата добавления - 17.04.2020 в 13:15
Olenka_ Дата: Пятница, 17.04.2020, 13:26 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
_Boroda_, да, необходимо проставить фамилию старшего смены. Спасибо, Вы мне очень помогли!
 
Ответить
Сообщение_Boroda_, да, необходимо проставить фамилию старшего смены. Спасибо, Вы мне очень помогли!

Автор - Olenka_
Дата добавления - 17.04.2020 в 13:26
_Boroda_ Дата: Пятница, 17.04.2020, 13:35 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Пожалуйста. И Алексей тоже старался :D


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПожалуйста. И Алексей тоже старался :D

Автор - _Boroda_
Дата добавления - 17.04.2020 в 13:35
AlexM Дата: Пятница, 17.04.2020, 13:56 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Реабилитируюсь. ;-)
Код
=ИНДЕКС(I$3:I$4;МАКС(МУМНОЖ(--(ЕСЛИ(A$2:A$99=A2;B$2:B$99)=ВЫБОР({1;2;3;4};I$3;J$3;I$4;J$4));{1:1:2:2})))
Массивная формула
К сообщению приложен файл: 1792310_02.xlsx(9.4 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеРеабилитируюсь. ;-)
Код
=ИНДЕКС(I$3:I$4;МАКС(МУМНОЖ(--(ЕСЛИ(A$2:A$99=A2;B$2:B$99)=ВЫБОР({1;2;3;4};I$3;J$3;I$4;J$4));{1:1:2:2})))
Массивная формула

Автор - AlexM
Дата добавления - 17.04.2020 в 13:56
Olenka_ Дата: Пятница, 17.04.2020, 14:34 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
_Boroda_, хотела у Вас уточнить, переношу сейчас на свою таблицу этот пример, и почему-то не просчитывает. Подскажите, пожалуйста, в формуле "2+", почему именно так?
 
Ответить
Сообщение_Boroda_, хотела у Вас уточнить, переношу сейчас на свою таблицу этот пример, и почему-то не просчитывает. Подскажите, пожалуйста, в формуле "2+", почему именно так?

Автор - Olenka_
Дата добавления - 17.04.2020 в 14:34
Olenka_ Дата: Пятница, 17.04.2020, 14:39 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
_Boroda_, хотела у Вас уточнить, переношу сейчас на свою таблицу этот пример, и почему-то не просчитывает. Подскажите, пожалуйста, в формуле "2+", почему именно так?
 
Ответить
Сообщение_Boroda_, хотела у Вас уточнить, переношу сейчас на свою таблицу этот пример, и почему-то не просчитывает. Подскажите, пожалуйста, в формуле "2+", почему именно так?

Автор - Olenka_
Дата добавления - 17.04.2020 в 14:39
Olenka_ Дата: Пятница, 17.04.2020, 14:40 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM, спасибо огромнейшее)
 
Ответить
СообщениеAlexM, спасибо огромнейшее)

Автор - Olenka_
Дата добавления - 17.04.2020 в 14:40
_Boroda_ Дата: Пятница, 17.04.2020, 14:45 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Откуда +2
ПОИСКПОЗ считает данные со строки 3 - I$3:I$4&J$3:J$4
ИНДЕКС со строки 1 - I:I
Чтобы их выравнять, добавляем +2


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОткуда +2
ПОИСКПОЗ считает данные со строки 3 - I$3:I$4&J$3:J$4
ИНДЕКС со строки 1 - I:I
Чтобы их выравнять, добавляем +2

Автор - _Boroda_
Дата добавления - 17.04.2020 в 14:45
Olenka_ Дата: Пятница, 17.04.2020, 14:48 | Сообщение № 12
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM, спасибо огромнейшее)
 
Ответить
СообщениеAlexM, спасибо огромнейшее)

Автор - Olenka_
Дата добавления - 17.04.2020 в 14:48
AlexM Дата: Пятница, 17.04.2020, 19:17 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=ИНДЕКС(I$3:I$4;1-ПРОСМОТР(;-ПОИСК(ЕСЛИ(A$2:A$99=A2;B$2:B$99);I$3&J$3&ПОВТОР(0;99)&I$4&J$4))%)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Пятница, 17.04.2020, 19:18
 
Ответить
СообщениеЕще вариант
Код
=ИНДЕКС(I$3:I$4;1-ПРОСМОТР(;-ПОИСК(ЕСЛИ(A$2:A$99=A2;B$2:B$99);I$3&J$3&ПОВТОР(0;99)&I$4&J$4))%)

Автор - AlexM
Дата добавления - 17.04.2020 в 19:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проставить у всех работников старшего смены по дате (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!