Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти в диапазоне максимальные баллы, посчитать и записать.. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в диапазоне максимальные баллы, посчитать и записать.. (Формулы/Formulas)
Найти в диапазоне максимальные баллы, посчитать и записать..
maksbv Дата: Пятница, 17.04.2020, 13:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!
Не могу решить третью задачу из файла, школьная программа.
Желательно самыми простыми формулами.
Спасибо.
К сообщению приложен файл: exam.xls(101.0 Kb)


Сообщение отредактировал maksbv - Пятница, 17.04.2020, 13:55
 
Ответить
СообщениеДобрый день!
Не могу решить третью задачу из файла, школьная программа.
Желательно самыми простыми формулами.
Спасибо.

Автор - maksbv
Дата добавления - 17.04.2020 в 13:55
_Boroda_ Дата: Пятница, 17.04.2020, 14:21 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Первое можно без допстолбца, просто звездочку добавьте
Код
=СЧЁТЕСЛИ(A2:A264;"З*")


По №3. Такая формула достаточно проста? Или нужно попроще?
Для I4
Код
=ЕСЛИОШИБКА(ИНДЕКС($A1:$A264;НАИМЕНЬШИЙ($F2:$F264;СТОЛБЕЦ(A4)));"")

А в столбце F формула
Код
=ЕСЛИ($C$2:$C$264=$I$6;СТРОКА();"")

Поясню немного словами
В F при нахождении макс выводится номер текущей строки
1. СТОЛБЕЦ(A4) - это номер столбца А, то есть 1. Когда мы потянем формулу вправо, то ссылка тоже поедет (доллара перед А нет) и в ячейке J4 будет уже СТОЛБЕЦ(В4). В - второй столбец, поэтому СТОЛБЕЦ(В4) = 2
2. НАИМЕНЬШИЙ($F2:$F264;СТОЛБЕЦ(A4)) - даст нам первый наименьший из столбца F. Это будет первая цифровая запись в нем. И она равна номеру текущей строки (см. п.1)
3. ИНДЕКС($A1:$A264; п.2) - выведет из столбца А то по порядку значение, какое мы нашли в п.2
Это все для ячейки I4
А для J4 п.1 будет равняться 2, а в п.2 найдется номер второй строки, где оценка по русскому тоже максимальна. Ну и п.3 выведет соответствующую фамилию
И т.д.
ЕСЛИОШИБКА(п.3 ; "") для того случая, когда макс значения закончились (в примере их всего два у нас). В этом случае НАИМЕНЬШИЙ($F2:$F264;СТОЛБЕЦ(C4)) даст ошибку (нет у нас третьего наименьшего, их всего два у нас), ИНДЕКС тогда тоже даст ошибку и тогда мы выводим второй аргумент ЕСЛИОШИБКА - пусто
К сообщению приложен файл: exam_1.xls(101.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПервое можно без допстолбца, просто звездочку добавьте
Код
=СЧЁТЕСЛИ(A2:A264;"З*")


По №3. Такая формула достаточно проста? Или нужно попроще?
Для I4
Код
=ЕСЛИОШИБКА(ИНДЕКС($A1:$A264;НАИМЕНЬШИЙ($F2:$F264;СТОЛБЕЦ(A4)));"")

А в столбце F формула
Код
=ЕСЛИ($C$2:$C$264=$I$6;СТРОКА();"")

Поясню немного словами
В F при нахождении макс выводится номер текущей строки
1. СТОЛБЕЦ(A4) - это номер столбца А, то есть 1. Когда мы потянем формулу вправо, то ссылка тоже поедет (доллара перед А нет) и в ячейке J4 будет уже СТОЛБЕЦ(В4). В - второй столбец, поэтому СТОЛБЕЦ(В4) = 2
2. НАИМЕНЬШИЙ($F2:$F264;СТОЛБЕЦ(A4)) - даст нам первый наименьший из столбца F. Это будет первая цифровая запись в нем. И она равна номеру текущей строки (см. п.1)
3. ИНДЕКС($A1:$A264; п.2) - выведет из столбца А то по порядку значение, какое мы нашли в п.2
Это все для ячейки I4
А для J4 п.1 будет равняться 2, а в п.2 найдется номер второй строки, где оценка по русскому тоже максимальна. Ну и п.3 выведет соответствующую фамилию
И т.д.
ЕСЛИОШИБКА(п.3 ; "") для того случая, когда макс значения закончились (в примере их всего два у нас). В этом случае НАИМЕНЬШИЙ($F2:$F264;СТОЛБЕЦ(C4)) даст ошибку (нет у нас третьего наименьшего, их всего два у нас), ИНДЕКС тогда тоже даст ошибку и тогда мы выводим второй аргумент ЕСЛИОШИБКА - пусто

Автор - _Boroda_
Дата добавления - 17.04.2020 в 14:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти в диапазоне максимальные баллы, посчитать и записать.. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!