Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт через суммесли и соединение строк. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт через суммесли и соединение строк. (Формулы/Formulas)
Расчёт через суммесли и соединение строк.
Liteks Дата: Понедельник, 20.04.2020, 03:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Здравствуйте,есть проблема, есть лист на котором есть таблица в ней в одном столбце фамилия человека, в другом имя в третьем сумма. На другом листе фамилия и имя в одном столбце и в другом необходимо посчитать через формулу суммесли сумму по каждому человеку (на первом листе одни и те же фамилия и имя могут быть несколько раз). Никак неп олучается пробовал через сцепить и другие формулы,но что-то не получается.Буду рад помощи. Наверное задание лёгкое,но что-то не пойму всё равно. Файл скинул если надо кому.
К сообщению приложен файл: 5676617.xls(28.0 Kb)
 
Ответить
СообщениеЗдравствуйте,есть проблема, есть лист на котором есть таблица в ней в одном столбце фамилия человека, в другом имя в третьем сумма. На другом листе фамилия и имя в одном столбце и в другом необходимо посчитать через формулу суммесли сумму по каждому человеку (на первом листе одни и те же фамилия и имя могут быть несколько раз). Никак неп олучается пробовал через сцепить и другие формулы,но что-то не получается.Буду рад помощи. Наверное задание лёгкое,но что-то не пойму всё равно. Файл скинул если надо кому.

Автор - Liteks
Дата добавления - 20.04.2020 в 03:18
_Boroda_ Дата: Понедельник, 20.04.2020, 06:00 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Именно через СУММЕСЛИ нужно? По-другому никак нельзя?
Например, вот так
Код
=СУММПРОИЗВ((Лист1!A$2:A$11&" "&Лист1!B$2:B$11=A2)*Лист1!C$2:C$11)

Или хотябы СУММЕСЛИМН
Код
=СУММЕСЛИМН(Лист1!C:C;Лист1!A:A;ЛЕВСИМВ(A2;ПОИСК(" ";A2)-1);Лист1!B:B;ПСТР(A2;ПОИСК(" ";A2)+1;99))


С СУММЕСЛИ Вам придется в первой таблице делать допстолбец, в котором нужно сцепить Ф и О. А потом уже СУММЕСЛИ (см. файл)
К сообщению приложен файл: 5676617_2.xls(31.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИменно через СУММЕСЛИ нужно? По-другому никак нельзя?
Например, вот так
Код
=СУММПРОИЗВ((Лист1!A$2:A$11&" "&Лист1!B$2:B$11=A2)*Лист1!C$2:C$11)

Или хотябы СУММЕСЛИМН
Код
=СУММЕСЛИМН(Лист1!C:C;Лист1!A:A;ЛЕВСИМВ(A2;ПОИСК(" ";A2)-1);Лист1!B:B;ПСТР(A2;ПОИСК(" ";A2)+1;99))


С СУММЕСЛИ Вам придется в первой таблице делать допстолбец, в котором нужно сцепить Ф и О. А потом уже СУММЕСЛИ (см. файл)

Автор - _Boroda_
Дата добавления - 20.04.2020 в 06:00
Liteks Дата: Понедельник, 20.04.2020, 15:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Именно через СУММЕСЛИ нужно? По-другому никак нельзя?
Например, вот так
[Перевод / Translate]
=СУММПРОИЗВ((Лист1!A$2:A$11&" "&Лист1!B$2:B$11=A2)*Лист1!C$2:C$11)

Или хотябы СУММЕСЛИМН
[Перевод / Translate]
=СУММЕСЛИМН(Лист1!C:C;Лист1!A:A;ЛЕВСИМВ(A2;ПОИСК(" ";A2)-1);Лист1!B:B;ПСТР(A2;ПОИСК(" ";A2)+1;99))

С СУММЕСЛИ Вам придется в первой таблице делать допстолбец, в котором нужно сцепить Ф и О. А потом уже СУММЕСЛИ (см. файл)

Да, надо именно суммесли.
спасибо за ответ. Понял. Я думал,что может есть способ без дополнительных столбцов,оказалось,что нет. Спасибо за помощь,разобрался.
 
Ответить
Сообщение
Именно через СУММЕСЛИ нужно? По-другому никак нельзя?
Например, вот так
[Перевод / Translate]
=СУММПРОИЗВ((Лист1!A$2:A$11&" "&Лист1!B$2:B$11=A2)*Лист1!C$2:C$11)

Или хотябы СУММЕСЛИМН
[Перевод / Translate]
=СУММЕСЛИМН(Лист1!C:C;Лист1!A:A;ЛЕВСИМВ(A2;ПОИСК(" ";A2)-1);Лист1!B:B;ПСТР(A2;ПОИСК(" ";A2)+1;99))

С СУММЕСЛИ Вам придется в первой таблице делать допстолбец, в котором нужно сцепить Ф и О. А потом уже СУММЕСЛИ (см. файл)

Да, надо именно суммесли.
спасибо за ответ. Понял. Я думал,что может есть способ без дополнительных столбцов,оказалось,что нет. Спасибо за помощь,разобрался.

Автор - Liteks
Дата добавления - 20.04.2020 в 15:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт через суммесли и соединение строк. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!