Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать кол0во дней с учетом введенных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать кол0во дней с учетом введенных (Формулы/Formulas)
Как посчитать кол0во дней с учетом введенных
Barbos_TN Дата: Понедельник, 20.04.2020, 11:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

OFFICE 365
Уважаемые Гуру, доброго всем дня!

Подскажите, плз., формулу для подсчета кол-ва дней между двумя датами с учетом введенных.
Например, если мы вводим формулу, например, ячейки А2-А1, в которые введены нач. и кон. даты, то получаем разницу без учёта одного дня.
Т.е. если ввести 14.04 и 29.04, то в ответе будет 15, а в самом деле это 16 дней!
 
Ответить
СообщениеУважаемые Гуру, доброго всем дня!

Подскажите, плз., формулу для подсчета кол-ва дней между двумя датами с учетом введенных.
Например, если мы вводим формулу, например, ячейки А2-А1, в которые введены нач. и кон. даты, то получаем разницу без учёта одного дня.
Т.е. если ввести 14.04 и 29.04, то в ответе будет 15, а в самом деле это 16 дней!

Автор - Barbos_TN
Дата добавления - 20.04.2020 в 11:38
bigor Дата: Понедельник, 20.04.2020, 11:40 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 418
Репутация: 76 ±
Замечаний: 0% ±

нет
Ну так прибавьте к ответу 1 :)
 
Ответить
СообщениеНу так прибавьте к ответу 1 :)

Автор - bigor
Дата добавления - 20.04.2020 в 11:40
Nic70y Дата: Понедельник, 20.04.2020, 11:43 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
прибавьте к ответу 1
не, ну так не прикольно :)
Код
=A2-A1+И(A1;A2)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
прибавьте к ответу 1
не, ну так не прикольно :)
Код
=A2-A1+И(A1;A2)

Автор - Nic70y
Дата добавления - 20.04.2020 в 11:43
Barbos_TN Дата: Понедельник, 20.04.2020, 11:56 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

OFFICE 365
Все сложнее.

У меня несколько промежутков дат и нужно посчитать все промежутки одной формулой.
Ни первый ни второй ответы не работают корректно.


Сообщение отредактировал Barbos_TN - Понедельник, 20.04.2020, 11:57
 
Ответить
СообщениеВсе сложнее.

У меня несколько промежутков дат и нужно посчитать все промежутки одной формулой.
Ни первый ни второй ответы не работают корректно.

Автор - Barbos_TN
Дата добавления - 20.04.2020 в 11:56
Nic70y Дата: Понедельник, 20.04.2020, 11:57 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Все сложнее.
ну так приложите файл-пример-excel


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Все сложнее.
ну так приложите файл-пример-excel

Автор - Nic70y
Дата добавления - 20.04.2020 в 11:57
Barbos_TN Дата: Понедельник, 20.04.2020, 12:47 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

OFFICE 365
так приложите файл-пример-excel
К сообщению приложен файл: 6040881.xlsx(9.7 Kb)
 
Ответить
Сообщение
так приложите файл-пример-excel

Автор - Barbos_TN
Дата добавления - 20.04.2020 в 12:47
bigor Дата: Понедельник, 20.04.2020, 13:01 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 418
Репутация: 76 ±
Замечаний: 0% ±

нет
Добавьте еще к формулам +3, по +1 к каждой разнице дат

Хотя у Nic70y чутье есть, похоже он что-то предвидел :)
лучше так
Код
=B4-A4+D4-C4+F4-E4+AND(-A4;-B4)+AND(-C4;-D4)+AND(-E4;-F4)


Сообщение отредактировал bigor - Понедельник, 20.04.2020, 13:22
 
Ответить
СообщениеДобавьте еще к формулам +3, по +1 к каждой разнице дат

Хотя у Nic70y чутье есть, похоже он что-то предвидел :)
лучше так
Код
=B4-A4+D4-C4+F4-E4+AND(-A4;-B4)+AND(-C4;-D4)+AND(-E4;-F4)

Автор - bigor
Дата добавления - 20.04.2020 в 13:01
Nic70y Дата: Понедельник, 20.04.2020, 13:29 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 6832
Репутация: 1567 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ((ОСТАТ(СТОЛБЕЦ(A4:F4);2)=0)*A4:F4-(ОСТАТ(СТОЛБЕЦ(A4:F4);2))*A4:F4)+СЧЁТ(A4:F4)/2


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((ОСТАТ(СТОЛБЕЦ(A4:F4);2)=0)*A4:F4-(ОСТАТ(СТОЛБЕЦ(A4:F4);2))*A4:F4)+СЧЁТ(A4:F4)/2

Автор - Nic70y
Дата добавления - 20.04.2020 в 13:29
Barbos_TN Дата: Понедельник, 20.04.2020, 14:26 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

OFFICE 365
Спасибо вам, друзья, обе формулы рабочие!
 
Ответить
СообщениеСпасибо вам, друзья, обе формулы рабочие!

Автор - Barbos_TN
Дата добавления - 20.04.2020 в 14:26
AlexM Дата: Понедельник, 20.04.2020, 15:16 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4257
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
еще вариант
Код
=СУММПРОИЗВ((B4:F4-A4:E4+1)*(A4:E4>0)*ОСТАТ(СТОЛБЕЦ(A4:E4);2))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениееще вариант
Код
=СУММПРОИЗВ((B4:F4-A4:E4+1)*(A4:E4>0)*ОСТАТ(СТОЛБЕЦ(A4:E4);2))

Автор - AlexM
Дата добавления - 20.04.2020 в 15:16
_Boroda_ Дата: Понедельник, 20.04.2020, 17:15 | Сообщение № 11
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15979
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
И еще
Код
=СУММПРОИЗВ((B4:F4-A4:E4)*(A$1:E$1<>""))+СЧЁТ(A4:F4)/2

И стащив кусок у Алексея
Код
=СУММПРОИЗВ((B4:F4-A4:E4+1)*(A4:E4>0)*(A$1:E$1<>""))
К сообщению приложен файл: 6040881_1.xlsx(10.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИ еще
Код
=СУММПРОИЗВ((B4:F4-A4:E4)*(A$1:E$1<>""))+СЧЁТ(A4:F4)/2

И стащив кусок у Алексея
Код
=СУММПРОИЗВ((B4:F4-A4:E4+1)*(A4:E4>0)*(A$1:E$1<>""))

Автор - _Boroda_
Дата добавления - 20.04.2020 в 17:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать кол0во дней с учетом введенных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!