Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод фамилий с наивысшим баллом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод фамилий с наивысшим баллом (Формулы/Formulas)
Вывод фамилий с наивысшим баллом
Rassell89 Дата: Четверг, 23.04.2020, 22:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго времени суток, подскажите пожалуйста формулу для решения задачи п.3 в прилагаемом файле.

3. Кто из учащихся получил высший балл по русскому языку?
Запишите фамилии учащихся в ячейки 4-й строки, начиная с G4.
К сообщению приложен файл: 9410706.xls(64.5 Kb)
 
Ответить
СообщениеДоброго времени суток, подскажите пожалуйста формулу для решения задачи п.3 в прилагаемом файле.

3. Кто из учащихся получил высший балл по русскому языку?
Запишите фамилии учащихся в ячейки 4-й строки, начиная с G4.

Автор - Rassell89
Дата добавления - 23.04.2020 в 22:16
_Boroda_ Дата: Четверг, 23.04.2020, 22:22 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16357
Репутация: 6351 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
http://www.excelworld.ru/forum/2-44660-1#294888
Если без допстолбцов, то
Код
=ЕСЛИОШИБКА(ИНДЕКС($A:$A;НАИМЕНЬШИЙ(ЕСЛИ($C2:$C999=МАКС($C2:$C999);СТРОКА(2:999));СТОЛБЕЦ(A4)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

И да, в формуле
Код
=СЧЁТЕСЛИ(C:C;"=41")
кавычки и равно не обязательны, можно вот так
Код
=СЧЁТЕСЛИ(C:C;41)

А в вопросе 5 Вас спрашивают не про проценты, а про количество

* И еще, допустим, первое задание звучит вот так
1. У скольких учащихся фамилия начинается с буквы "У"?
Проверьте. По Вашей формуле получится ответ 4, а на самом деле 3. Не всегда краткость - сестра, иногда в СЧЁТЕСЛИ лучше диапазон нормальный писать
Код
=СЧЁТЕСЛИ(A2:A999;"у*")
К сообщению приложен файл: 9410706_2.xls(72.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеhttp://www.excelworld.ru/forum/2-44660-1#294888
Если без допстолбцов, то
Код
=ЕСЛИОШИБКА(ИНДЕКС($A:$A;НАИМЕНЬШИЙ(ЕСЛИ($C2:$C999=МАКС($C2:$C999);СТРОКА(2:999));СТОЛБЕЦ(A4)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

И да, в формуле
Код
=СЧЁТЕСЛИ(C:C;"=41")
кавычки и равно не обязательны, можно вот так
Код
=СЧЁТЕСЛИ(C:C;41)

А в вопросе 5 Вас спрашивают не про проценты, а про количество

* И еще, допустим, первое задание звучит вот так
1. У скольких учащихся фамилия начинается с буквы "У"?
Проверьте. По Вашей формуле получится ответ 4, а на самом деле 3. Не всегда краткость - сестра, иногда в СЧЁТЕСЛИ лучше диапазон нормальный писать
Код
=СЧЁТЕСЛИ(A2:A999;"у*")

Автор - _Boroda_
Дата добавления - 23.04.2020 в 22:22
Rassell89 Дата: Четверг, 23.04.2020, 23:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, hands

Спасибо огромное!!! Ошибки учтём.
 
Ответить
Сообщение_Boroda_, hands

Спасибо огромное!!! Ошибки учтём.

Автор - Rassell89
Дата добавления - 23.04.2020 в 23:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод фамилий с наивысшим баллом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!