Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверка значение формулой СЧЕТЕСЛИ выдает ложно значение. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка значение формулой СЧЕТЕСЛИ выдает ложно значение. (Формулы/Formulas)
Проверка значение формулой СЧЕТЕСЛИ выдает ложно значение.
mikaelw Дата: Пятница, 24.04.2020, 04:19 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 120
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
Доброго времени суток, ВСЕ!

Файл с ним много работают.

Но вот какая проблема, после попытки оптимизации БД чтоб убрать тормоза,
формула СЧЕТЕСЛИ начала выдавать неправильное значение,
почему не въезжаю.....

Суть в столбце В уникальное значение в каждой ячейке, в столбце G проверяется формулой СЧЕТЕСЛИ на равность значению 1(Истина, прочие ЛОЖЬ).

Почему всегда истина, но ведь тут сплошняком дубли..
Откуда проблема?
Может сменить формулу?

Заранее спасибо...
К сообщению приложен файл: 7258976.xlsx(11.3 Kb)


Сообщение отредактировал mikaelw - Пятница, 24.04.2020, 04:19
 
Ответить
СообщениеДоброго времени суток, ВСЕ!

Файл с ним много работают.

Но вот какая проблема, после попытки оптимизации БД чтоб убрать тормоза,
формула СЧЕТЕСЛИ начала выдавать неправильное значение,
почему не въезжаю.....

Суть в столбце В уникальное значение в каждой ячейке, в столбце G проверяется формулой СЧЕТЕСЛИ на равность значению 1(Истина, прочие ЛОЖЬ).

Почему всегда истина, но ведь тут сплошняком дубли..
Откуда проблема?
Может сменить формулу?

Заранее спасибо...

Автор - mikaelw
Дата добавления - 24.04.2020 в 04:19
_Boroda_ Дата: Пятница, 24.04.2020, 04:32 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
формула СЧЕТЕСЛИ начала выдавать неправильное значение

Вы хотите сказать, что формула
Код
=СЧЁТЕСЛИ(B2;$B$2:$B$17)=1
когда-то выдавала ПРАВИЛЬНОЕ значение? Она всегда будет выдавать массив из 16 элементов, первый из которых ИСТИНА (его и показывает Excel в ячейке)
Почитайте справку по СЧЁТЕСЛИ. Особенно внимательно раздел про синтаксис


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
формула СЧЕТЕСЛИ начала выдавать неправильное значение

Вы хотите сказать, что формула
Код
=СЧЁТЕСЛИ(B2;$B$2:$B$17)=1
когда-то выдавала ПРАВИЛЬНОЕ значение? Она всегда будет выдавать массив из 16 элементов, первый из которых ИСТИНА (его и показывает Excel в ячейке)
Почитайте справку по СЧЁТЕСЛИ. Особенно внимательно раздел про синтаксис

Автор - _Boroda_
Дата добавления - 24.04.2020 в 04:32
mikaelw Дата: Пятница, 24.04.2020, 05:20 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 120
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010, 2013, 2016
Почитайте справку по СЧЁТЕСЛИ. Особенно внимательно раздел про синтаксис


Спасибо. Как только отправил на форум увидел ошибку, формула перестала работать, когда делали оптимизацию.
После оптимизации, прекратило все тормозить и не удивительно почему......

А может есть другая формула(Функция) на что еще заменить?
 
Ответить
Сообщение
Почитайте справку по СЧЁТЕСЛИ. Особенно внимательно раздел про синтаксис


Спасибо. Как только отправил на форум увидел ошибку, формула перестала работать, когда делали оптимизацию.
После оптимизации, прекратило все тормозить и не удивительно почему......

А может есть другая формула(Функция) на что еще заменить?

Автор - mikaelw
Дата добавления - 24.04.2020 в 05:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверка значение формулой СЧЕТЕСЛИ выдает ложно значение. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!