Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/вывести значение при определенном значении в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести значение при определенном значении в столбце (Формулы/Formulas)
вывести значение при определенном значении в столбце
Artemon Дата: Воскресенье, 26.04.2020, 01:12 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток
Помогите с формулой, пожалуйста
Есть столбец чисел двоек и единиц. Если после 2121 идет цифра 1, нужно вывести 2 в соседней ячейке, если же после 2121 идет 2, нужно вывести единицу. НО перед 2121 не должно быть 21, тоесть 2121 должно быть ровно 2 раза, если появляется 212121 или 21212121 или любое другое выводить 2 и 1 (первое и второе условие) не нужно
Во вложении пример, надеюсь объяснил понятно
К сообщению приложен файл: 6392459.xlsx(8.6 Kb)
 
Ответить
СообщениеДоброго времени суток
Помогите с формулой, пожалуйста
Есть столбец чисел двоек и единиц. Если после 2121 идет цифра 1, нужно вывести 2 в соседней ячейке, если же после 2121 идет 2, нужно вывести единицу. НО перед 2121 не должно быть 21, тоесть 2121 должно быть ровно 2 раза, если появляется 212121 или 21212121 или любое другое выводить 2 и 1 (первое и второе условие) не нужно
Во вложении пример, надеюсь объяснил понятно

Автор - Artemon
Дата добавления - 26.04.2020 в 01:12
_Boroda_ Дата: Воскресенье, 26.04.2020, 07:07 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Начиная со строки 7
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=И(A3:A6={2:1:2:1})*НЕ(И(A1:A6={2:1:2:1:2:1}))*2^(A7=1)

Или обычная формула
Код
=ИНДЕКС(И(A3:A6={2:1:2:1})*НЕ(И(A1:A6={2:1:2:1:2:1}))*2^(A7=1);)

Формат ячеек
0;;
К сообщению приложен файл: 6392459_2.xlsx(13.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Начиная со строки 7
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=И(A3:A6={2:1:2:1})*НЕ(И(A1:A6={2:1:2:1:2:1}))*2^(A7=1)

Или обычная формула
Код
=ИНДЕКС(И(A3:A6={2:1:2:1})*НЕ(И(A1:A6={2:1:2:1:2:1}))*2^(A7=1);)

Формат ячеек
0;;

Автор - _Boroda_
Дата добавления - 26.04.2020 в 07:07
Artemon Дата: Воскресенье, 26.04.2020, 16:27 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 65
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, как всегда спасибо огромное!
все как надо
 
Ответить
Сообщение_Boroda_, как всегда спасибо огромное!
все как надо

Автор - Artemon
Дата добавления - 26.04.2020 в 16:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » вывести значение при определенном значении в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!