Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если А>0 то А+В >0 или А+В>C = Истина - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если А>0 то А+В >0 или А+В>C = Истина (Формулы/Formulas)
Если А>0 то А+В >0 или А+В>C = Истина
ННН Дата: Воскресенье, 26.04.2020, 10:53 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Код
ЕСЛИ(И(A1>0;A1<0;) "ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)";"ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(H:H;D1+1)>D*0,5"))


Т.е. Если A >0, то
Код
"ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)"
===Истина , Если A <0, то
Код
"ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(H:H;D1+1)>D*0,5"))
то это истина.

Где то в написании ошибка потому не работает, помогите осилить! Думал справлюсь сам не выходит.
К сообщению приложен файл: 6051872.xlsx(8.2 Kb)


Сообщение отредактировал ННН - Воскресенье, 26.04.2020, 10:54
 
Ответить
Сообщение
Код
ЕСЛИ(И(A1>0;A1<0;) "ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)";"ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(H:H;D1+1)>D*0,5"))


Т.е. Если A >0, то
Код
"ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)"
===Истина , Если A <0, то
Код
"ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(H:H;D1+1)>D*0,5"))
то это истина.

Где то в написании ошибка потому не работает, помогите осилить! Думал справлюсь сам не выходит.

Автор - ННН
Дата добавления - 26.04.2020 в 10:53
AlexM Дата: Воскресенье, 26.04.2020, 11:28 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Формулы в таблице нет.
Кавычками обозначают текст
И(A1>0;A1<0;) - всегда ЛОЖЬ



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормулы в таблице нет.
Кавычками обозначают текст
И(A1>0;A1<0;) - всегда ЛОЖЬ

Автор - AlexM
Дата добавления - 26.04.2020 в 11:28
ННН Дата: Воскресенье, 26.04.2020, 11:40 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день! Я помню это работало в какой то из формул. А как тогда про
писать?
 
Ответить
СообщениеДобрый день! Я помню это работало в какой то из формул. А как тогда про
писать?

Автор - ННН
Дата добавления - 26.04.2020 в 11:40
AlexM Дата: Воскресенье, 26.04.2020, 11:46 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Объясните что вы хотите сделать. Словами, без формул.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеОбъясните что вы хотите сделать. Словами, без формул.

Автор - AlexM
Дата добавления - 26.04.2020 в 11:46
ННН Дата: Воскресенье, 26.04.2020, 11:58 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Т.е. Если A >0, то тогда идем по этому пути
"
Код
ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)
" Если это условие выполнено то ИСТИНА

Если А<0, то тогда по этому пути
Код
"ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(H:H;D1+1)>D*0,5"
))Если это условие выполнено то ИСТИНА.
 
Ответить
СообщениеТ.е. Если A >0, то тогда идем по этому пути
"
Код
ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)
" Если это условие выполнено то ИСТИНА

Если А<0, то тогда по этому пути
Код
"ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(H:H;D1+1)>D*0,5"
))Если это условие выполнено то ИСТИНА.

Автор - ННН
Дата добавления - 26.04.2020 в 11:58
AlexM Дата: Воскресенье, 26.04.2020, 12:08 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)
Тут две лог функции ИНДЕКС(A:A;D1+1)>0 и D*0,5>=ИНДЕКС(B:B;D1+1) Причем во второй D???
Опишите словами что вы хотите и приложите файл-пример. Где это хотите применить.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)
Тут две лог функции ИНДЕКС(A:A;D1+1)>0 и D*0,5>=ИНДЕКС(B:B;D1+1) Причем во второй D???
Опишите словами что вы хотите и приложите файл-пример. Где это хотите применить.

Автор - AlexM
Дата добавления - 26.04.2020 в 12:08
ННН Дата: Воскресенье, 26.04.2020, 12:19 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM, Да, это моя ошибка там другой столбец например I
К сообщению приложен файл: 3440543.xlsx(8.2 Kb)
 
Ответить
СообщениеAlexM, Да, это моя ошибка там другой столбец например I

Автор - ННН
Дата добавления - 26.04.2020 в 12:19
AlexM Дата: Воскресенье, 26.04.2020, 13:23 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Чем этот файл отличается от двух предыдущих?
Ваши пробы с формулами ссылаются на столбец В и Н, а ф примере эти столбцы пустые.
Опишите словами что вы хотите и приложите файл-пример. Где это хотите применить.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЧем этот файл отличается от двух предыдущих?
Ваши пробы с формулами ссылаются на столбец В и Н, а ф примере эти столбцы пустые.
Опишите словами что вы хотите и приложите файл-пример. Где это хотите применить.

Автор - AlexM
Дата добавления - 26.04.2020 в 13:23
ННН Дата: Воскресенье, 26.04.2020, 13:39 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM, Фаил обьемный сюда не поместится. В тех столбцах произвольно у меня там значения. Вот новый вариант я исправил
К сообщению приложен файл: 4671506.xlsx(8.3 Kb)
 
Ответить
СообщениеAlexM, Фаил обьемный сюда не поместится. В тех столбцах произвольно у меня там значения. Вот новый вариант я исправил

Автор - ННН
Дата добавления - 26.04.2020 в 13:39
ННН Дата: Воскресенье, 26.04.2020, 13:43 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Т.е. Если A >0, то тогда идем по этому пути
"
Код
ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)

" Если одно условие из двух (
Код
ИНДЕКС(A:A;D1+1)>0
-первое условие.
Код
I*0,5>=ИНДЕКС(B:B;D1+1)
- второе) выполнено то ИСТИНА

Если А<0 то по другому пути..
 
Ответить
СообщениеТ.е. Если A >0, то тогда идем по этому пути
"
Код
ИНДЕКС(A:A;D1+1)>0;D*0,5>=ИНДЕКС(B:B;D1+1)

" Если одно условие из двух (
Код
ИНДЕКС(A:A;D1+1)>0
-первое условие.
Код
I*0,5>=ИНДЕКС(B:B;D1+1)
- второе) выполнено то ИСТИНА

Если А<0 то по другому пути..

Автор - ННН
Дата добавления - 26.04.2020 в 13:43
ННН Дата: Воскресенье, 26.04.2020, 17:44 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Код
ЕСЛИ(K2<0;ИНДЕКС(K:K;P2+1)<0;ИНДЕКС(L:L;P2+1)<=0,5*ИНДЕКС(L:L;Q2+1));И(K2>0;ИНДЕКС(K:K;P2+1)>0;ИНДЕКС(M:M;P2+1)<=0,5*ИНДЕКС(M:M;Q2+1))
Вот так ее пробую, но все равно ошибка...
 
Ответить
Сообщение
Код
ЕСЛИ(K2<0;ИНДЕКС(K:K;P2+1)<0;ИНДЕКС(L:L;P2+1)<=0,5*ИНДЕКС(L:L;Q2+1));И(K2>0;ИНДЕКС(K:K;P2+1)>0;ИНДЕКС(M:M;P2+1)<=0,5*ИНДЕКС(M:M;Q2+1))
Вот так ее пробую, но все равно ошибка...

Автор - ННН
Дата добавления - 26.04.2020 в 17:44
ННН Дата: Воскресенье, 26.04.2020, 18:29 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM, Если К<0 то по числу из столбца Р( например 15) отступаем столько строк вниз в столбце К(включая точку отсчета это будет К15), число К15 тоже отрицательное если нет,то смотрим на предидущее значение в столбце L это будет L 14 умножаем его на 0,5 и результат меньше или равен результату следуюей ячейки L15 это будет Истина или Если К>0 то по числу из столбца Р( например 15) отступаем столько строк вниз в столбце К(включая точку отсчета это будет К15), число К15 тоже положительное если нет,то смотрим на предидущее значение в столбце М это будет М14 умножаем его на 0,5 и результат меньше или равен результату следуюей ячейки М15 это будет Истина. Фаил я сделал исчерпывающим по информации . Помогите!
К сообщению приложен файл: 5710571.xlsx(18.8 Kb)
 
Ответить
СообщениеAlexM, Если К<0 то по числу из столбца Р( например 15) отступаем столько строк вниз в столбце К(включая точку отсчета это будет К15), число К15 тоже отрицательное если нет,то смотрим на предидущее значение в столбце L это будет L 14 умножаем его на 0,5 и результат меньше или равен результату следуюей ячейки L15 это будет Истина или Если К>0 то по числу из столбца Р( например 15) отступаем столько строк вниз в столбце К(включая точку отсчета это будет К15), число К15 тоже положительное если нет,то смотрим на предидущее значение в столбце М это будет М14 умножаем его на 0,5 и результат меньше или равен результату следуюей ячейки М15 это будет Истина. Фаил я сделал исчерпывающим по информации . Помогите!

Автор - ННН
Дата добавления - 26.04.2020 в 18:29
Pelena Дата: Воскресенье, 26.04.2020, 20:52 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 16780
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как поняла
Код
=ЕСЛИ(K1<0;ИЛИ(ИНДЕКС(K:K;P1+СТРОКА()-1)<0;ИНДЕКС(L:L;P1+СТРОКА()-2)*0,5<=ИНДЕКС(L:L;P1+СТРОКА()-1));ИЛИ(ИНДЕКС(K:K;P1+СТРОКА()-1)>0;ИНДЕКС(M:M;P1+СТРОКА()-2)*0,5<=ИНДЕКС(M:M;P1+СТРОКА()-1)))
К сообщению приложен файл: 8167091.xlsx(20.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак поняла
Код
=ЕСЛИ(K1<0;ИЛИ(ИНДЕКС(K:K;P1+СТРОКА()-1)<0;ИНДЕКС(L:L;P1+СТРОКА()-2)*0,5<=ИНДЕКС(L:L;P1+СТРОКА()-1));ИЛИ(ИНДЕКС(K:K;P1+СТРОКА()-1)>0;ИНДЕКС(M:M;P1+СТРОКА()-2)*0,5<=ИНДЕКС(M:M;P1+СТРОКА()-1)))

Автор - Pelena
Дата добавления - 26.04.2020 в 20:52
ННН Дата: Понедельник, 27.04.2020, 00:23 | Сообщение № 14
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Код
=ЕСЛИ(K2<0;ИЛИ(ИНДЕКС(K:K;P2+СТРОКА()-1)<0;ИНДЕКС(L:L;P2+СТРОКА()-2)*0,5<=ИНДЕКС(L:L;P2+СТРОКА()-1));ЕСЛИ(K2>0;ИЛИ(ИНДЕКС(K:K;P2+СТРОКА()-1)>0;ИНДЕКС(M:M;P2+СТРОКА()-2)*0,5<=ИНДЕКС(M:M;P2+СТРОКА()-1))))
Я извиняюсь, но добавил в Вашу формулу K>0. Я правильно это сделал?


Сообщение отредактировал ННН - Понедельник, 27.04.2020, 00:24
 
Ответить
Сообщение
Код
=ЕСЛИ(K2<0;ИЛИ(ИНДЕКС(K:K;P2+СТРОКА()-1)<0;ИНДЕКС(L:L;P2+СТРОКА()-2)*0,5<=ИНДЕКС(L:L;P2+СТРОКА()-1));ЕСЛИ(K2>0;ИЛИ(ИНДЕКС(K:K;P2+СТРОКА()-1)>0;ИНДЕКС(M:M;P2+СТРОКА()-2)*0,5<=ИНДЕКС(M:M;P2+СТРОКА()-1))))
Я извиняюсь, но добавил в Вашу формулу K>0. Я правильно это сделал?

Автор - ННН
Дата добавления - 27.04.2020 в 00:23
Pelena Дата: Понедельник, 27.04.2020, 09:03 | Сообщение № 15
Группа: Админы
Ранг: Местный житель
Сообщений: 16780
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Я правильно это сделал?

Смотря, что должно происходить при К=0


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Я правильно это сделал?

Смотря, что должно происходить при К=0

Автор - Pelena
Дата добавления - 27.04.2020 в 09:03
ННН Дата: Понедельник, 27.04.2020, 09:26 | Сообщение № 16
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, K><0. K=0 можно пропустить.
 
Ответить
СообщениеPelena, K><0. K=0 можно пропустить.

Автор - ННН
Дата добавления - 27.04.2020 в 09:26
Pelena Дата: Понедельник, 27.04.2020, 09:36 | Сообщение № 17
Группа: Админы
Ранг: Местный житель
Сообщений: 16780
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Тогда без разницы, обе формулы будут работать одинаково


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТогда без разницы, обе формулы будут работать одинаково

Автор - Pelena
Дата добавления - 27.04.2020 в 09:36
ННН Дата: Понедельник, 27.04.2020, 09:50 | Сообщение № 18
Группа: Пользователи
Ранг: Участник
Сообщений: 54
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Спасибо!Работает!
 
Ответить
СообщениеPelena, Спасибо!Работает!

Автор - ННН
Дата добавления - 27.04.2020 в 09:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если А>0 то А+В >0 или А+В>C = Истина (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!