Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнить два массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить два массива (Формулы/Formulas)
Сравнить два массива
zhendos37 Дата: Воскресенье, 03.05.2020, 01:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
В таблице в диапазоне, например, А1:В30 есть числовые значения от 0 до 5. В этом диапазоне нужно посчитать количество строк, в которых значение А: больше В, равно В, меньше В. Никак не могу придумать. Заранее спасибо!
 
Ответить
СообщениеВ таблице в диапазоне, например, А1:В30 есть числовые значения от 0 до 5. В этом диапазоне нужно посчитать количество строк, в которых значение А: больше В, равно В, меньше В. Никак не могу придумать. Заранее спасибо!

Автор - zhendos37
Дата добавления - 03.05.2020 в 01:47
DrMini Дата: Воскресенье, 03.05.2020, 06:43 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 505
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
zhendos37,
И Вам здрасте.
Вот с доп. столбцами.
Уверен, гуру скоро проснутся и сделают всё намного изящнее. Без допов.
К сообщению приложен файл: 20050301.xlsx(10.1 Kb)


Сообщение отредактировал DrMini - Воскресенье, 03.05.2020, 06:43
 
Ответить
Сообщениеzhendos37,
И Вам здрасте.
Вот с доп. столбцами.
Уверен, гуру скоро проснутся и сделают всё намного изящнее. Без допов.

Автор - DrMini
Дата добавления - 03.05.2020 в 06:43
DrMini Дата: Воскресенье, 03.05.2020, 08:19 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 505
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Вот решение массивной формулой без дополнительных ячеек.
Вводится Shift+Ctrl+Enter
А>В
Код
=СУММ(--(A1:A30>B1:B30))

A<В
Код
=СУММ(--(A1:A30<B1:B30))

A=В
Код
=СУММ(--(A1:A30=B1:B30))
К сообщению приложен файл: 20050302.xlsx(9.4 Kb)


Сообщение отредактировал DrMini - Воскресенье, 03.05.2020, 08:25
 
Ответить
СообщениеВот решение массивной формулой без дополнительных ячеек.
Вводится Shift+Ctrl+Enter
А>В
Код
=СУММ(--(A1:A30>B1:B30))

A<В
Код
=СУММ(--(A1:A30<B1:B30))

A=В
Код
=СУММ(--(A1:A30=B1:B30))

Автор - DrMini
Дата добавления - 03.05.2020 в 08:19
jakim Дата: Воскресенье, 03.05.2020, 08:58 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 942
Репутация: 247 ±
Замечаний: 0% ±

Excel 2010
Можно и без использования массивных формул.

Код
=SUMPRODUCT(--(A1:A30>B1:B30))
 
Ответить
Сообщение
Можно и без использования массивных формул.

Код
=SUMPRODUCT(--(A1:A30>B1:B30))

Автор - jakim
Дата добавления - 03.05.2020 в 08:58
zhendos37 Дата: Воскресенье, 03.05.2020, 10:42 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
=СУММПРОИЗВ(--(A1:A30>B1:B30))

Большое спасибо! Однако у меня эта формула явно неправильно считает. Предполагаю, что это связано с тем, что в зеленом столбце не просто число, а результат подсчета другой формулы. Это можно как-то обыграть?
К сообщению приложен файл: 5833964.xlsx(17.2 Kb)


Сообщение отредактировал zhendos37 - Воскресенье, 03.05.2020, 10:47
 
Ответить
Сообщение
=СУММПРОИЗВ(--(A1:A30>B1:B30))

Большое спасибо! Однако у меня эта формула явно неправильно считает. Предполагаю, что это связано с тем, что в зеленом столбце не просто число, а результат подсчета другой формулы. Это можно как-то обыграть?

Автор - zhendos37
Дата добавления - 03.05.2020 в 10:42
Hugo Дата: Воскресенье, 03.05.2020, 11:08 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2944
Репутация: 649 ±
Замечаний: 0% ±

Формула считает правильно,потому что там не число, а текст!
Чтобы она считала/сравнивала числа - добавьте --
Код
=СУММПРОИЗВ(--(--S19:S48>T19:T48))


Можно конечно и саму формулу изменить - убрать эти лишние кавычки, но их там так много... :(
Вообще нужно бы её упростить. Попробуйте ВПР() с приблизительным сравнением.
Например
Код
=ВПР(R19;{0;2:5;3:8;4:12;5};2;1)

А если там вдруг будет ошибка, то и с Вашим вариантом внизу не просуммирует.

P.S. и вот тут кажется диапазон не дотянули:
Код
=СЧЁТЕСЛИ(S20:S46;2)


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069


Сообщение отредактировал Hugo - Воскресенье, 03.05.2020, 12:15
 
Ответить
СообщениеФормула считает правильно,потому что там не число, а текст!
Чтобы она считала/сравнивала числа - добавьте --
Код
=СУММПРОИЗВ(--(--S19:S48>T19:T48))


Можно конечно и саму формулу изменить - убрать эти лишние кавычки, но их там так много... :(
Вообще нужно бы её упростить. Попробуйте ВПР() с приблизительным сравнением.
Например
Код
=ВПР(R19;{0;2:5;3:8;4:12;5};2;1)

А если там вдруг будет ошибка, то и с Вашим вариантом внизу не просуммирует.

P.S. и вот тут кажется диапазон не дотянули:
Код
=СЧЁТЕСЛИ(S20:S46;2)

Автор - Hugo
Дата добавления - 03.05.2020 в 11:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнить два массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!