Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для подсчёта отработанных часов в графике работы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для подсчёта отработанных часов в графике работы (Формулы/Formulas)
Формула для подсчёта отработанных часов в графике работы
tvyur Дата: Воскресенье, 03.05.2020, 09:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе утро, уважаемые участники форума. Помогите, пожалуйста, прописать в графике формулу подсчёта отработанных часов за месяц так, чтобы формула выводила общее количество отработанных часов, за вычетом 1 часа ежедневного перерыва на обед.
К сообщению приложен файл: 5301400.xlsm(30.0 Kb)


tvyur
 
Ответить
СообщениеДоброе утро, уважаемые участники форума. Помогите, пожалуйста, прописать в графике формулу подсчёта отработанных часов за месяц так, чтобы формула выводила общее количество отработанных часов, за вычетом 1 часа ежедневного перерыва на обед.

Автор - tvyur
Дата добавления - 03.05.2020 в 09:22
DrMini Дата: Воскресенье, 03.05.2020, 09:57 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 506
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Может так?
Код
=СУММ(ЕСЛИОШИБКА(AC22-AC21;0);ЕСЛИОШИБКА(AI22-AI21-DU25;0);ЕСЛИОШИБКА(AO22-AO21-AO25;0);ЕСЛИОШИБКА(AU22-AU21-AU25;0);ЕСЛИОШИБКА(BA22-BA21-BA25;0);ЕСЛИОШИБКА(BG22-BG21-BG25;0);ЕСЛИОШИБКА(BM22-BM21-BM25;0);ЕСЛИОШИБКА(BS22-BS21-BS25;0);ЕСЛИОШИБКА(BY22-BY21-BY25;0);ЕСЛИОШИБКА(CE22-CE21-ce25;0);ЕСЛИОШИБКА(CK22-CK21-ck25;0);ЕСЛИОШИБКА(CQ22-CQ21-cq25;0);ЕСЛИОШИБКА(CW22-CW21-cw25;0);ЕСЛИОШИБКА(DC22-DC21-dc25;0);ЕСЛИОШИБКА(DI22-DI21-di25;0);ЕСЛИОШИБКА(DO22-DO21-do25;0);ЕСЛИОШИБКА(DU22-DU21-du25;0);ЕСЛИОШИБКА(EA22-EA21-ea25;0);ЕСЛИОШИБКА(EG22-EG21-eg25;0);ЕСЛИОШИБКА(EM22-EM21-em25;0);ЕСЛИОШИБКА(ES22-ES21-es25;0);ЕСЛИОШИБКА(EY22-EY21-ey25;0);ЕСЛИОШИБКА(FE22-FE21-fe25;0);ЕСЛИОШИБКА(FK22-FK21-fk25;0);ЕСЛИОШИБКА(FQ22-FQ21-fq25;0);ЕСЛИОШИБКА(FW22-FW21-fw25;0);ЕСЛИОШИБКА(GC22-GC21-gc25;0);ЕСЛИОШИБКА(GI22-GI21-gi25;0);ЕСЛИОШИБКА(GO22-GO21-go25;0);ЕСЛИОШИБКА(GU22-GU21-gu25;0);ЕСЛИОШИБКА(HA22-HA21-ha25;0))

Уверен, что местные гуру Вам формулу уменьшат в разы.
К сообщению приложен файл: 20050303.xlsm(30.2 Kb)
 
Ответить
СообщениеМожет так?
Код
=СУММ(ЕСЛИОШИБКА(AC22-AC21;0);ЕСЛИОШИБКА(AI22-AI21-DU25;0);ЕСЛИОШИБКА(AO22-AO21-AO25;0);ЕСЛИОШИБКА(AU22-AU21-AU25;0);ЕСЛИОШИБКА(BA22-BA21-BA25;0);ЕСЛИОШИБКА(BG22-BG21-BG25;0);ЕСЛИОШИБКА(BM22-BM21-BM25;0);ЕСЛИОШИБКА(BS22-BS21-BS25;0);ЕСЛИОШИБКА(BY22-BY21-BY25;0);ЕСЛИОШИБКА(CE22-CE21-ce25;0);ЕСЛИОШИБКА(CK22-CK21-ck25;0);ЕСЛИОШИБКА(CQ22-CQ21-cq25;0);ЕСЛИОШИБКА(CW22-CW21-cw25;0);ЕСЛИОШИБКА(DC22-DC21-dc25;0);ЕСЛИОШИБКА(DI22-DI21-di25;0);ЕСЛИОШИБКА(DO22-DO21-do25;0);ЕСЛИОШИБКА(DU22-DU21-du25;0);ЕСЛИОШИБКА(EA22-EA21-ea25;0);ЕСЛИОШИБКА(EG22-EG21-eg25;0);ЕСЛИОШИБКА(EM22-EM21-em25;0);ЕСЛИОШИБКА(ES22-ES21-es25;0);ЕСЛИОШИБКА(EY22-EY21-ey25;0);ЕСЛИОШИБКА(FE22-FE21-fe25;0);ЕСЛИОШИБКА(FK22-FK21-fk25;0);ЕСЛИОШИБКА(FQ22-FQ21-fq25;0);ЕСЛИОШИБКА(FW22-FW21-fw25;0);ЕСЛИОШИБКА(GC22-GC21-gc25;0);ЕСЛИОШИБКА(GI22-GI21-gi25;0);ЕСЛИОШИБКА(GO22-GO21-go25;0);ЕСЛИОШИБКА(GU22-GU21-gu25;0);ЕСЛИОШИБКА(HA22-HA21-ha25;0))

Уверен, что местные гуру Вам формулу уменьшат в разы.

Автор - DrMini
Дата добавления - 03.05.2020 в 09:57
tvyur Дата: Воскресенье, 03.05.2020, 10:14 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
DrMini, Спасибо. Считает верно. Формула громоздкая, конечно, но что получилось, то получилось. Ещё раз спасибо. hands


tvyur
 
Ответить
СообщениеDrMini, Спасибо. Считает верно. Формула громоздкая, конечно, но что получилось, то получилось. Ещё раз спасибо. hands

Автор - tvyur
Дата добавления - 03.05.2020 в 10:14
прохожий2019 Дата: Воскресенье, 03.05.2020, 10:21 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 111
Репутация: 20 ±
Замечаний: 0% ±

365
а вот так разве нельзя (массивка):
Код
=СУММ(ЕСЛИОШИБКА(AC22:HF22-AC21:HF21-AC25:HF25;0))
К сообщению приложен файл: 1478209.xlsm(30.4 Kb)
 
Ответить
Сообщениеа вот так разве нельзя (массивка):
Код
=СУММ(ЕСЛИОШИБКА(AC22:HF22-AC21:HF21-AC25:HF25;0))

Автор - прохожий2019
Дата добавления - 03.05.2020 в 10:21
tvyur Дата: Воскресенье, 03.05.2020, 16:08 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
hands Спасибо большое, всё считает.


tvyur
 
Ответить
Сообщениеhands Спасибо большое, всё считает.

Автор - tvyur
Дата добавления - 03.05.2020 в 16:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для подсчёта отработанных часов в графике работы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!