Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разложить общую недостачу товара по коробам с учетом емкости - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разложить общую недостачу товара по коробам с учетом емкости (Формулы/Formulas)
Разложить общую недостачу товара по коробам с учетом емкости
Ailebe Дата: Вторник, 12.05.2020, 11:59 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!

Есть результаты приемки товара на складе. Теперь на основании расхождений нужно скорректировать количество товаров внутри коробов. ВПР тут не поможет, он не учитывает сумму товаров в коробе. СУММАЕСЛИ тоже мимо. С какой стороны подойти к решению задачи?

Спасибо за советы.
 
Ответить
СообщениеДобрый день!

Есть результаты приемки товара на складе. Теперь на основании расхождений нужно скорректировать количество товаров внутри коробов. ВПР тут не поможет, он не учитывает сумму товаров в коробе. СУММАЕСЛИ тоже мимо. С какой стороны подойти к решению задачи?

Спасибо за советы.

Автор - Ailebe
Дата добавления - 12.05.2020 в 11:59
китин Дата: Вторник, 12.05.2020, 12:03 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6319
Репутация: 970 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Ailebe, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеAilebe, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 12.05.2020 в 12:03
Ailebe Дата: Вторник, 12.05.2020, 12:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
похоже не приложился файл, исправляю
К сообщению приложен файл: 6877833.xls(31.5 Kb)
 
Ответить
Сообщениепохоже не приложился файл, исправляю

Автор - Ailebe
Дата добавления - 12.05.2020 в 12:07
AlexM Дата: Вторник, 12.05.2020, 12:23 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Покажите ожидаемый результат. Так задача не понятна.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПокажите ожидаемый результат. Так задача не понятна.

Автор - AlexM
Дата добавления - 12.05.2020 в 12:23
Ailebe Дата: Вторник, 12.05.2020, 12:31 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
прикладываю файл, который хочу получить
К сообщению приложен файл: 1_.xls(31.5 Kb)
 
Ответить
Сообщениеприкладываю файл, который хочу получить

Автор - Ailebe
Дата добавления - 12.05.2020 в 12:31
AlexM Дата: Вторник, 12.05.2020, 12:43 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Похоже у вас есть секретик и вы его не говорите.
Недостача это разница план и факт. Это понятно, а откуда взялись данные в D9:D19? Если они расчетные, то как считать?



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПохоже у вас есть секретик и вы его не говорите.
Недостача это разница план и факт. Это понятно, а откуда взялись данные в D9:D19? Если они расчетные, то как считать?

Автор - AlexM
Дата добавления - 12.05.2020 в 12:43
Ailebe Дата: Вторник, 12.05.2020, 12:52 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Берем артикул 1 в коробе 1, уменьшаем остаток до тех пор, пока или кол-во станет 0, или расхождение будет полностью отражено. Если дошли до остатка в коробе =0, а расхождение еще есть, берем этот артикул в коробе 2, повторяем. И так далее, пока расхождение по артикулу не закроем в ноль.

Далее берем артикул 2, повторяем. И так до тех пор, пока всю недостачу не "разложим" по коробам.

В данном примере "колво факт" и "недостача" - расчетные.
 
Ответить
СообщениеБерем артикул 1 в коробе 1, уменьшаем остаток до тех пор, пока или кол-во станет 0, или расхождение будет полностью отражено. Если дошли до остатка в коробе =0, а расхождение еще есть, берем этот артикул в коробе 2, повторяем. И так далее, пока расхождение по артикулу не закроем в ноль.

Далее берем артикул 2, повторяем. И так до тех пор, пока всю недостачу не "разложим" по коробам.

В данном примере "колво факт" и "недостача" - расчетные.

Автор - Ailebe
Дата добавления - 12.05.2020 в 12:52
AlexM Дата: Вторник, 12.05.2020, 13:06 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
План, факт, расхождение. Понятно.
Остаток этот где?



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПлан, факт, расхождение. Понятно.
Остаток этот где?

Автор - AlexM
Дата добавления - 12.05.2020 в 13:06
AlexM Дата: Вторник, 12.05.2020, 14:09 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Получилось.
Код
=ЕСЛИ(ВПР(B9;A$2:D$6;4;)<0;МАКС(-C9;ВПР(B9;A$2:D$6;4;)-СУММЕСЛИ(B10:B$99;B9;E10:E$99));ВПР(B9;A$2:D$6;4;)-СУММЕСЛИ(B$8:B8;B9;E$8:E8))
К сообщению приложен файл: 1_02.xls(34.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПолучилось.
Код
=ЕСЛИ(ВПР(B9;A$2:D$6;4;)<0;МАКС(-C9;ВПР(B9;A$2:D$6;4;)-СУММЕСЛИ(B10:B$99;B9;E10:E$99));ВПР(B9;A$2:D$6;4;)-СУММЕСЛИ(B$8:B8;B9;E$8:E8))

Автор - AlexM
Дата добавления - 12.05.2020 в 14:09
Ailebe Дата: Вторник, 12.05.2020, 15:54 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо вам огромное!
 
Ответить
СообщениеСпасибо вам огромное!

Автор - Ailebe
Дата добавления - 12.05.2020 в 15:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разложить общую недостачу товара по коробам с учетом емкости (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!