Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по разным условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по разным условиям (Формулы/Formulas)
Суммирование по разным условиям
FoxLord Дата: Вторник, 12.05.2020, 13:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день! Excel 2010(Не могу поменять в настройках)
Подскажите как можно просуммировать разные ячейки с разными условиями?
В ячейке Год План нужно выводить значение в зависимости от наличия данных в ячейке факт в определенном месяце.
Вот как хотел я. Эксель говорит, что много аргументов.
Код
ЕСЛИ(K3<>0;B3+D3+F3+H3+J3;ЕСЛИ(I3<>0;H3+F3+D3+B3;ЕСЛИ(G3<>0;F3+D3+B3;E3<>0;D3+B3;ЕСЛИ(C3<>0;B3;0))))
К сообщению приложен файл: 9579924.xlsx(10.1 Kb)


Делить на ноль можно, как процесс, но результат непредсказуем.

Сообщение отредактировал FoxLord - Вторник, 12.05.2020, 13:31
 
Ответить
СообщениеДобрый день! Excel 2010(Не могу поменять в настройках)
Подскажите как можно просуммировать разные ячейки с разными условиями?
В ячейке Год План нужно выводить значение в зависимости от наличия данных в ячейке факт в определенном месяце.
Вот как хотел я. Эксель говорит, что много аргументов.
Код
ЕСЛИ(K3<>0;B3+D3+F3+H3+J3;ЕСЛИ(I3<>0;H3+F3+D3+B3;ЕСЛИ(G3<>0;F3+D3+B3;E3<>0;D3+B3;ЕСЛИ(C3<>0;B3;0))))

Автор - FoxLord
Дата добавления - 12.05.2020 в 13:30
Pelena Дата: Вторник, 12.05.2020, 14:04 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16805
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если именно Вашу формулу доработать, то так
Код
=ЕСЛИ(K3<>0;B3+D3+F3+H3+J3;ЕСЛИ(I3<>0;H3+F3+D3+B3;ЕСЛИ(G3<>0;F3+D3+B3;ЕСЛИ(E3<>0;D3+B3;ЕСЛИ(C3<>0;B3;0)))))

или немного короче
Код
=СУММЕСЛИМН($B3:$J3;$B$2:$J$2;"План";$C3:$K3;">0")
К сообщению приложен файл: 8593132.xlsx(11.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если именно Вашу формулу доработать, то так
Код
=ЕСЛИ(K3<>0;B3+D3+F3+H3+J3;ЕСЛИ(I3<>0;H3+F3+D3+B3;ЕСЛИ(G3<>0;F3+D3+B3;ЕСЛИ(E3<>0;D3+B3;ЕСЛИ(C3<>0;B3;0)))))

или немного короче
Код
=СУММЕСЛИМН($B3:$J3;$B$2:$J$2;"План";$C3:$K3;">0")

Автор - Pelena
Дата добавления - 12.05.2020 в 14:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по разным условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!