Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор из нескольких диапазонов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор из нескольких диапазонов (Формулы/Formulas)
Выбор из нескольких диапазонов
kroly77 Дата: Вторник, 12.05.2020, 22:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем привет!

Подкажите какую формулу можно применить для расчета и условий ниже?

Дано: 3 тарифа за доставку груза - пешком, авто и грузовой.
Нужно: Формулу, которая расчитает в ячейке итоговую цену.

Тарифы пешком и авто расчитываются по формуле = вес * на ставку из диапазона веса
Тариф грузовой фиксирован в приделах до 500, 700, 1000, 1500 кг.

Не могу подобрать формулу, которая будет учитывать все эти условия и считать в одной ячейке.
К сообщению приложен файл: 1553017.xlsx(9.4 Kb) · 5508573.xlsx(9.4 Kb)
 
Ответить
СообщениеВсем привет!

Подкажите какую формулу можно применить для расчета и условий ниже?

Дано: 3 тарифа за доставку груза - пешком, авто и грузовой.
Нужно: Формулу, которая расчитает в ячейке итоговую цену.

Тарифы пешком и авто расчитываются по формуле = вес * на ставку из диапазона веса
Тариф грузовой фиксирован в приделах до 500, 700, 1000, 1500 кг.

Не могу подобрать формулу, которая будет учитывать все эти условия и считать в одной ячейке.

Автор - kroly77
Дата добавления - 12.05.2020 в 22:27
AlexM Дата: Вторник, 12.05.2020, 23:32 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4164
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2003
Так нужно?
Формулы массива
Код
=B1^(B1<500)*ИНДЕКС(B5:B20;ПОИСКПОЗ(1=1;(B1<ЕСЛИ(ЕОШ(-A5:A20);0;A5:A20));))

PS. исправил ошибку, заменил файл
К сообщению приложен файл: 1553017_01.xlsx(9.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Вторник, 12.05.2020, 23:39
 
Ответить
СообщениеТак нужно?
Формулы массива
Код
=B1^(B1<500)*ИНДЕКС(B5:B20;ПОИСКПОЗ(1=1;(B1<ЕСЛИ(ЕОШ(-A5:A20);0;A5:A20));))

PS. исправил ошибку, заменил файл

Автор - AlexM
Дата добавления - 12.05.2020 в 23:32
gling Дата: Вторник, 12.05.2020, 23:33 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2074
Репутация: 523 ±
Замечаний: 0% ±

2010
Здравствуйте. Вариант в файле. Немного изменил диапазон с ценами.
Код
=ЕСЛИ(B1>=500;ПРОСМОТР(B1;D13:D16;E13:E16);ПРОСМОТР(B1;D5:D12;E5:E12)*B1)
Еще не понятно если до 500..., то и до 1500, а свыше 1500 груза не бывает? От 200 до 500 это грузовой или легковой?
К сообщению приложен файл: 4375667.xlsx(10.8 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Вторник, 12.05.2020, 23:40
 
Ответить
СообщениеЗдравствуйте. Вариант в файле. Немного изменил диапазон с ценами.
Код
=ЕСЛИ(B1>=500;ПРОСМОТР(B1;D13:D16;E13:E16);ПРОСМОТР(B1;D5:D12;E5:E12)*B1)
Еще не понятно если до 500..., то и до 1500, а свыше 1500 груза не бывает? От 200 до 500 это грузовой или легковой?

Автор - gling
Дата добавления - 12.05.2020 в 23:33
kroly77 Дата: Вторник, 12.05.2020, 23:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
От 200 до 500 это грузовой или легковой?

Верно, от 200 до 500 - это уже грузовой по фиксированной цене.
 
Ответить
Сообщение
От 200 до 500 это грузовой или легковой?

Верно, от 200 до 500 - это уже грузовой по фиксированной цене.

Автор - kroly77
Дата добавления - 12.05.2020 в 23:59
gling Дата: Среда, 13.05.2020, 00:25 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2074
Репутация: 523 ±
Замечаний: 0% ±

2010
от 200 до 500 - это уже грузовой
Тогда немного по другому.
Код
=ЕСЛИ(B1>200;ПРОСМОТР(B1;D13:D16;E13:E16);ПРОСМОТР(B1;D5:D12;E5:E12)*B1)
К сообщению приложен файл: 8141710.xlsx(16.7 Kb)


ЯД-41001506838083
 
Ответить
Сообщение
от 200 до 500 - это уже грузовой
Тогда немного по другому.
Код
=ЕСЛИ(B1>200;ПРОСМОТР(B1;D13:D16;E13:E16);ПРОСМОТР(B1;D5:D12;E5:E12)*B1)

Автор - gling
Дата добавления - 13.05.2020 в 00:25
AlexM Дата: Среда, 13.05.2020, 09:41 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4164
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2003
Исправил на (B1<200)
К сообщению приложен файл: 1553017_02.xlsx(9.0 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеИсправил на (B1<200)

Автор - AlexM
Дата добавления - 13.05.2020 в 09:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор из нескольких диапазонов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!