Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если последние 4 не пустые ячейки то - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если последние 4 не пустые ячейки то (Формулы/Formulas)
Если последние 4 не пустые ячейки то
pain2430 Дата: Четверг, 21.05.2020, 17:03 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, прошу помощи в таком задании:
Нужна формула которая ищет последние 4 не пустые ячейки в двух столбцах, и выводит значение ИСТИНА.
При этом все эти 4 значения должны быть равны "A".
Если ИСТИНА, тогда ставим "Да".

Спасибо!
К сообщению приложен файл: forum.xlsx(8.8 Kb)
 
Ответить
СообщениеЗдравствуйте, прошу помощи в таком задании:
Нужна формула которая ищет последние 4 не пустые ячейки в двух столбцах, и выводит значение ИСТИНА.
При этом все эти 4 значения должны быть равны "A".
Если ИСТИНА, тогда ставим "Да".

Спасибо!

Автор - pain2430
Дата добавления - 21.05.2020 в 17:03
Nic70y Дата: Четверг, 21.05.2020, 17:22 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6146
Репутация: 1357 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(СЧЁТЕСЛИ(ИНДЕКС(B$1:C8;МАКС(8;СУММПРОИЗВ(МАКС((B$8:C8="B")*СТРОКА($B$8:C8))));):C8;"A")=4;"Да";"")
а может так:
Код
=ЕСЛИ(СЧЁТЕСЛИ(ИНДЕКС(B$1:C8;МАКС(8;СУММПРОИЗВ(МАКС((B$8:C8<>"")*(B$8:C8<>"A")*СТРОКА($B$8:C8))));):C8;"A")=4;"Да";"")
или совсем так
Код
=ЕСЛИ(СЧЁТЕСЛИ(ИНДЕКС(B$1:C8;СУММПРОИЗВ(МАКС((B$8:C8<>"")*(B$8:C8<>"A")*СТРОКА($B$8:C8)));):C8;"A")=4;"Да";"")
К сообщению приложен файл: 18-1-.xlsx(9.9 Kb)


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Четверг, 21.05.2020, 17:37
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(ИНДЕКС(B$1:C8;МАКС(8;СУММПРОИЗВ(МАКС((B$8:C8="B")*СТРОКА($B$8:C8))));):C8;"A")=4;"Да";"")
а может так:
Код
=ЕСЛИ(СЧЁТЕСЛИ(ИНДЕКС(B$1:C8;МАКС(8;СУММПРОИЗВ(МАКС((B$8:C8<>"")*(B$8:C8<>"A")*СТРОКА($B$8:C8))));):C8;"A")=4;"Да";"")
или совсем так
Код
=ЕСЛИ(СЧЁТЕСЛИ(ИНДЕКС(B$1:C8;СУММПРОИЗВ(МАКС((B$8:C8<>"")*(B$8:C8<>"A")*СТРОКА($B$8:C8)));):C8;"A")=4;"Да";"")

Автор - Nic70y
Дата добавления - 21.05.2020 в 17:22
pain2430 Дата: Четверг, 21.05.2020, 18:14 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 59
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Nic70y, спасибо Вам огромное!
 
Ответить
СообщениеNic70y, спасибо Вам огромное!

Автор - pain2430
Дата добавления - 21.05.2020 в 18:14
AlexM Дата: Четверг, 21.05.2020, 19:34 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4161
Репутация: 1023 ±
Замечаний: 0% ±

Excel 2003
Чуть ужал формулу Николая.
Код
=ЕСЛИ(СЧЁТЕСЛИ(ИНДЕКС(B:B;ИНДЕКС(МАКС((B$8:C8<>"")*(B$8:C8<>"A")*СТРОКА(B$8:C8));)):C8;"A")=4;"Да";"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЧуть ужал формулу Николая.
Код
=ЕСЛИ(СЧЁТЕСЛИ(ИНДЕКС(B:B;ИНДЕКС(МАКС((B$8:C8<>"")*(B$8:C8<>"A")*СТРОКА(B$8:C8));)):C8;"A")=4;"Да";"")

Автор - AlexM
Дата добавления - 21.05.2020 в 19:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если последние 4 не пустые ячейки то (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!