Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Проверить, совпадают ли значения с эталоном - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверить, совпадают ли значения с эталоном (Формулы/Formulas)
Проверить, совпадают ли значения с эталоном
Nikonka89 Дата: Пятница, 22.05.2020, 21:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Добрый день.
помогите, пожалуйста, с составлением формулы. Файл вкладываю.
у меня есть "эталон" - значения, которые верны. Мне нужно проверить (лист 1 ) совпадают ли значения с эталоном.
Цветом выделены колонки, где я протягивала формулы, чтобы получить нужную информацию (зеленая - итог). По идее я это сделала. Но сначала ВПР, потом истина/ложь.
По любому можно это сделать как-то быстрее, сложными формулами.

Помогите, пожалуйста.

к тому же, у меня этот файл будет на 100тыс строк, или даже больше. И лишние колонки с формулами только загружают его. Пробовала - долго пересчитывает и виснет.
К сообщению приложен файл: 3055712.xlsx(12.9 Kb)
 
Ответить
СообщениеДобрый день.
помогите, пожалуйста, с составлением формулы. Файл вкладываю.
у меня есть "эталон" - значения, которые верны. Мне нужно проверить (лист 1 ) совпадают ли значения с эталоном.
Цветом выделены колонки, где я протягивала формулы, чтобы получить нужную информацию (зеленая - итог). По идее я это сделала. Но сначала ВПР, потом истина/ложь.
По любому можно это сделать как-то быстрее, сложными формулами.

Помогите, пожалуйста.

к тому же, у меня этот файл будет на 100тыс строк, или даже больше. И лишние колонки с формулами только загружают его. Пробовала - долго пересчитывает и виснет.

Автор - Nikonka89
Дата добавления - 22.05.2020 в 21:00
Pelena Дата: Пятница, 22.05.2020, 21:09 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16763
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
лишние колонки с формулами только загружают его

Далеко не факт, что одной формулой будет быстрее.
А вот ВПР можно оптимизировать, если не обращаться к целым столбцам. Задайте конечный диапазон, можно с запасом. Всё-таки 100 000 строк это не миллион
Код
=ВПР(A2;Эталон!$A$1:$F$100000;4;0)


Если всё же хочется одной формулой, можно так
Код
=ИНДЕКС(Эталон!$D$1:$D$100000;АГРЕГАТ(15;6;СТРОКА(Эталон!$D$1:$D$100000)/(C2=Эталон!$C$1:$C$100000)/(F2=Эталон!$F$1:$F$100000)/(E2=Эталон!$B$1:$B$100000);1))=B2

или так
Код
=ПРОСМОТР(;-1/(C2=Эталон!$C$1:$C$100000)/(F2=Эталон!$F$1:$F$100000)/(E2=Эталон!$B$1:$B$100000);Эталон!$D$1:$D$100000)=B2
К сообщению приложен файл: 1411620.xlsx(13.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
лишние колонки с формулами только загружают его

Далеко не факт, что одной формулой будет быстрее.
А вот ВПР можно оптимизировать, если не обращаться к целым столбцам. Задайте конечный диапазон, можно с запасом. Всё-таки 100 000 строк это не миллион
Код
=ВПР(A2;Эталон!$A$1:$F$100000;4;0)


Если всё же хочется одной формулой, можно так
Код
=ИНДЕКС(Эталон!$D$1:$D$100000;АГРЕГАТ(15;6;СТРОКА(Эталон!$D$1:$D$100000)/(C2=Эталон!$C$1:$C$100000)/(F2=Эталон!$F$1:$F$100000)/(E2=Эталон!$B$1:$B$100000);1))=B2

или так
Код
=ПРОСМОТР(;-1/(C2=Эталон!$C$1:$C$100000)/(F2=Эталон!$F$1:$F$100000)/(E2=Эталон!$B$1:$B$100000);Эталон!$D$1:$D$100000)=B2

Автор - Pelena
Дата добавления - 22.05.2020 в 21:09
Nikonka89 Дата: Суббота, 23.05.2020, 14:52 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
Гениально!)
спасибо, огромное
 
Ответить
СообщениеГениально!)
спасибо, огромное

Автор - Nikonka89
Дата добавления - 23.05.2020 в 14:52
Nikonka89 Дата: Пятница, 29.05.2020, 10:12 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2019
А можно еще вас попросить помочь.
Все в этом же отчете. Если мне надо получить колонку G. Какую формула применить, чтобы сцепить значения с одного листа, с другого листа и получить значение из нужного мне столбца ? Одной формулой ?
 
Ответить
СообщениеА можно еще вас попросить помочь.
Все в этом же отчете. Если мне надо получить колонку G. Какую формула применить, чтобы сцепить значения с одного листа, с другого листа и получить значение из нужного мне столбца ? Одной формулой ?

Автор - Nikonka89
Дата добавления - 29.05.2020 в 10:12
китин Дата: Пятница, 29.05.2020, 10:20 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6313
Репутация: 968 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Nikonka89, - Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема
- Создайте новую тему согласно п.5q Правил форума


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеNikonka89, - Прочитайте Правила форума
- п.4 Правил форума: один вопрос - одна тема
- Создайте новую тему согласно п.5q Правил форума

Автор - китин
Дата добавления - 29.05.2020 в 10:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Проверить, совпадают ли значения с эталоном (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!