Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/По нескольким критериям найти определенную ячейку из таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » По нескольким критериям найти определенную ячейку из таблицы (Формулы/Formulas)
По нескольким критериям найти определенную ячейку из таблицы
Kadet__7 Дата: Суббота, 23.05.2020, 23:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Помогите разобраться, пожалуйста!
Задание: В каком городе Англии, Уэльса, Шотландии и Северной Ирландии, из пред-ставленных в таблице, зафиксировано наибольшее количество жителей?
При этом есть еще условие выполнения: В результирующей ячейке должна быть одна формула, которая обраща-ется только к ячейкам массива с исходными данными, без дополнительных или промежуточных расчётов и/или построений.
файл приложил
К сообщению приложен файл: 2792133.xlsx(58.9 Kb)
 
Ответить
СообщениеПомогите разобраться, пожалуйста!
Задание: В каком городе Англии, Уэльса, Шотландии и Северной Ирландии, из пред-ставленных в таблице, зафиксировано наибольшее количество жителей?
При этом есть еще условие выполнения: В результирующей ячейке должна быть одна формула, которая обраща-ется только к ячейкам массива с исходными данными, без дополнительных или промежуточных расчётов и/или построений.
файл приложил

Автор - Kadet__7
Дата добавления - 23.05.2020 в 23:08
Che79 Дата: Суббота, 23.05.2020, 23:52 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1637
Репутация: 302 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Kadet__7, здравствуйте. По Вашему примеру одной формулой так можно. Выделяете 2 ячейки (диапазон I2:J2), далее в I2 пишите формулу массива (Вводится одновременным нажатием Кнтрл+Шифт+Энтер)
Код
=ВПР(H2;ВЫБОР({1;2;3};$C$2:$C$1001;$A$2:$A$1001;$B$2:$B$1001);{2;3};)
К сообщению приложен файл: 2792133_1.xlsx(59.2 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеKadet__7, здравствуйте. По Вашему примеру одной формулой так можно. Выделяете 2 ячейки (диапазон I2:J2), далее в I2 пишите формулу массива (Вводится одновременным нажатием Кнтрл+Шифт+Энтер)
Код
=ВПР(H2;ВЫБОР({1;2;3};$C$2:$C$1001;$A$2:$A$1001;$B$2:$B$1001);{2;3};)

Автор - Che79
Дата добавления - 23.05.2020 в 23:52
jakim Дата: Воскресенье, 24.05.2020, 09:23 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 963
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Смотрите приложение с формулами
1.наибольшее количество жителей

Код
=AGGREGATE(14;6;B$2:B$5000/(C$2:C$5000=E6);1)

2.город

Код
=INDEX(A$2:A$5000;AGGREGATE(15;6;ROW($1:$5000)/(C$2:C$5000=E6)/(B$2:B$5000=AGGREGATE(14;6;B$2:B$5000/(C$2:C$5000=E6);1));1))
К сообщению приложен файл: 2792133_2.xlsx(64.7 Kb)
 
Ответить
Сообщение
Смотрите приложение с формулами
1.наибольшее количество жителей

Код
=AGGREGATE(14;6;B$2:B$5000/(C$2:C$5000=E6);1)

2.город

Код
=INDEX(A$2:A$5000;AGGREGATE(15;6;ROW($1:$5000)/(C$2:C$5000=E6)/(B$2:B$5000=AGGREGATE(14;6;B$2:B$5000/(C$2:C$5000=E6);1));1))

Автор - jakim
Дата добавления - 24.05.2020 в 09:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » По нескольким критериям найти определенную ячейку из таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!