Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не получается вытащить все данные с базы - аналитика - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не получается вытащить все данные с базы - аналитика (Формулы/Formulas)
Не получается вытащить все данные с базы - аналитика
Olga_Stahurlova Дата: Воскресенье, 24.05.2020, 21:21 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый вечер.

Прошу помочь в решении вопроса.
Вводные данные: есть огромная база данных всех поступлений (во вложении 0,01 часть базы).
Во вложении.
Нужно узнать сколько какого типоразмера шин.
В ручную это очень сложно.

В таблице сделала - описание всех типоразмеров, отформатировала файл и с помощью формулы 
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР($R3;ПОИСК("-";$R3;ПОИСК(HQ$2;$R3))+1;ПОИСК("шт";$R3;ПОИСК(HQ$2;$R3))-ПОИСК("-";$R3;ПОИСК(HQ$2;$R3))-1))*1;"")
нашла данные, НО есть данные, которые не находятся, именно:

1. В которых формула не вычисляет (не находит) типоразмер, который задан и есть в нужной строке.
2. Находит только первые поступления, следующие с таким же типоразмером - не считает.

Вопросы:
1. Как усовершенствовать формулу, чтобы можно было найти все поступления в нужном типоразмере.
2. Можно сделать формулу, которая будет прибавлять несколько типоразмеров сразу (5+20+30). Если нет, то можно, чтобы ячейка просто подсвечивалась и было понятно, что вручную нужно проверить именно этот типоразмер, а не все, что есть в описание.

Буду благодарна за помощь и советы.
 
Ответить
СообщениеДобрый вечер.

Прошу помочь в решении вопроса.
Вводные данные: есть огромная база данных всех поступлений (во вложении 0,01 часть базы).
Во вложении.
Нужно узнать сколько какого типоразмера шин.
В ручную это очень сложно.

В таблице сделала - описание всех типоразмеров, отформатировала файл и с помощью формулы 
Код
=ЕСЛИОШИБКА(СЖПРОБЕЛЫ(ПСТР($R3;ПОИСК("-";$R3;ПОИСК(HQ$2;$R3))+1;ПОИСК("шт";$R3;ПОИСК(HQ$2;$R3))-ПОИСК("-";$R3;ПОИСК(HQ$2;$R3))-1))*1;"")
нашла данные, НО есть данные, которые не находятся, именно:

1. В которых формула не вычисляет (не находит) типоразмер, который задан и есть в нужной строке.
2. Находит только первые поступления, следующие с таким же типоразмером - не считает.

Вопросы:
1. Как усовершенствовать формулу, чтобы можно было найти все поступления в нужном типоразмере.
2. Можно сделать формулу, которая будет прибавлять несколько типоразмеров сразу (5+20+30). Если нет, то можно, чтобы ячейка просто подсвечивалась и было понятно, что вручную нужно проверить именно этот типоразмер, а не все, что есть в описание.

Буду благодарна за помощь и советы.

Автор - Olga_Stahurlova
Дата добавления - 24.05.2020 в 21:21
Olga_Stahurlova Дата: Воскресенье, 24.05.2020, 21:26 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Вот сам файл.
К сообщению приложен файл: ____.xlsx(22.4 Kb)
 
Ответить
СообщениеВот сам файл.

Автор - Olga_Stahurlova
Дата добавления - 24.05.2020 в 21:26
Pelena Дата: Воскресенье, 24.05.2020, 22:16 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16796
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Цитата Olga_Stahurlova, 24.05.2020 в 21:21, в сообщении № 1 ()
не вычисляет (не находит)
если в названии есть дефис. Можно в формуле искать не "-", а "- ". Проверьте в файле

Цитата Olga_Stahurlova, 24.05.2020 в 21:21, в сообщении № 1 ()
чтобы ячейка просто подсвечивалась
правило в Условном форматировании
Код
=(ДЛСТР($C3)-ДЛСТР(ПОДСТАВИТЬ($C3;G$2;))>ДЛСТР(G$2))

оранжевый цвет
К сообщению приложен файл: -2-.xlsx(22.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Цитата Olga_Stahurlova, 24.05.2020 в 21:21, в сообщении № 1 ()
не вычисляет (не находит)
если в названии есть дефис. Можно в формуле искать не "-", а "- ". Проверьте в файле

Цитата Olga_Stahurlova, 24.05.2020 в 21:21, в сообщении № 1 ()
чтобы ячейка просто подсвечивалась
правило в Условном форматировании
Код
=(ДЛСТР($C3)-ДЛСТР(ПОДСТАВИТЬ($C3;G$2;))>ДЛСТР(G$2))

оранжевый цвет

Автор - Pelena
Дата добавления - 24.05.2020 в 22:16
Olga_Stahurlova Дата: Воскресенье, 24.05.2020, 22:23 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, спасибо большое!
Очень помогли!
 
Ответить
СообщениеPelena, спасибо большое!
Очень помогли!

Автор - Olga_Stahurlova
Дата добавления - 24.05.2020 в 22:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не получается вытащить все данные с базы - аналитика (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!