Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение двух значений с одинаковым критерием поиска - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение двух значений с одинаковым критерием поиска (Формулы/Formulas)
Нахождение двух значений с одинаковым критерием поиска
ПАМ Дата: Среда, 27.05.2020, 08:52 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Приветствую всех на этом замечательном форуме! Помогите мне пожалуйста разобраться. Мне нужно, чтобы в ячейке B листа 2 Эксель находил все значения из 5 столбца листа 1, согласно условию A листа 2.
Сам попробовал через
Код
=ВПР(A1;Лист1!$A$2:$E$5;5;ЛОЖЬ)
но к сожалению находит только первое из возможных, а не все.
В идеале лучше, чтобы каждое значение в отдельный столбец.
Заранее очень благодарен. Спасибо!
К сообщению приложен файл: 5387859.xlsx(9.2 Kb)
 
Ответить
СообщениеПриветствую всех на этом замечательном форуме! Помогите мне пожалуйста разобраться. Мне нужно, чтобы в ячейке B листа 2 Эксель находил все значения из 5 столбца листа 1, согласно условию A листа 2.
Сам попробовал через
Код
=ВПР(A1;Лист1!$A$2:$E$5;5;ЛОЖЬ)
но к сожалению находит только первое из возможных, а не все.
В идеале лучше, чтобы каждое значение в отдельный столбец.
Заранее очень благодарен. Спасибо!

Автор - ПАМ
Дата добавления - 27.05.2020 в 08:52
Nic70y Дата: Среда, 27.05.2020, 08:58 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6599
Репутация: 1451 ±
Замечаний: 0% ±

ru13;10;03
вариант формулой массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$E:$E;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$A$2:$A$5=$A1;СТРОКА(Лист1!$A$2:$A$5));СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 1567922.xlsx(9.4 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениевариант формулой массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$E:$E;НАИМЕНЬШИЙ(ЕСЛИ(Лист1!$A$2:$A$5=$A1;СТРОКА(Лист1!$A$2:$A$5));СТОЛБЕЦ(A1)));"")

Автор - Nic70y
Дата добавления - 27.05.2020 в 08:58
ПАМ Дата: Среда, 27.05.2020, 18:21 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 197
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Nic70y, Николай! Огромное Вам спасибо! Идеально подошло!Дай Бог Вам здоровья!
 
Ответить
СообщениеNic70y, Николай! Огромное Вам спасибо! Идеально подошло!Дай Бог Вам здоровья!

Автор - ПАМ
Дата добавления - 27.05.2020 в 18:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение двух значений с одинаковым критерием поиска (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!