Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значений в таблице - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значений в таблице (Формулы/Formulas)
Поиск значений в таблице
Klsva Дата: Суббота, 30.05.2020, 19:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Есть таблица с данными по входящим и исходящим звонкам (указаны номера телефонов). База звонков за большой период времени.
Нужно прописать каждому номеру телефона, к какому отделу он относится. Звонки могут быть и внутри одного отдела.
Для этого я сделала вторую таблицу, которая содержит номера телефонов отделов.
Помогите в первую таблицу прописать отдел.
Файл Пример с несколькими строками из таблицы прикрепляю.
К сообщению приложен файл: 2218201.xls(27.0 Kb)
 
Ответить
СообщениеЕсть таблица с данными по входящим и исходящим звонкам (указаны номера телефонов). База звонков за большой период времени.
Нужно прописать каждому номеру телефона, к какому отделу он относится. Звонки могут быть и внутри одного отдела.
Для этого я сделала вторую таблицу, которая содержит номера телефонов отделов.
Помогите в первую таблицу прописать отдел.
Файл Пример с несколькими строками из таблицы прикрепляю.

Автор - Klsva
Дата добавления - 30.05.2020 в 19:09
gling Дата: Суббота, 30.05.2020, 19:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2194
Репутация: 545 ±
Замечаний: 0% ±

2010
ВПР() поможет.


ЯД-41001506838083
 
Ответить
СообщениеВПР() поможет.

Автор - gling
Дата добавления - 30.05.2020 в 19:22
Che79 Дата: Суббота, 30.05.2020, 19:33 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1638
Репутация: 303 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Klsva, и Вам здравствуйте. Если правильно понял задачу
Код
=ЕСЛИОШИБКА(ВПР(ЕСЛИ(ДЛСТР(A2)>6;B2;A2);$F$2:$G$4;2);"")
К сообщению приложен файл: 2218201_1.xls(28.5 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеKlsva, и Вам здравствуйте. Если правильно понял задачу
Код
=ЕСЛИОШИБКА(ВПР(ЕСЛИ(ДЛСТР(A2)>6;B2;A2);$F$2:$G$4;2);"")

Автор - Che79
Дата добавления - 30.05.2020 в 19:33
Klsva Дата: Суббота, 30.05.2020, 20:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Большое спасибо за помощь!
Вот так все получилось
Код
=ЕСЛИ(ЕНД(ВПР([@[От кого]];Отделы[#Все];2;0));ВПР([@Кому];Отделы[#Все];2;0);ВПР([@[От кого]];Отделы[#Все];2;0))
 
Ответить
СообщениеБольшое спасибо за помощь!
Вот так все получилось
Код
=ЕСЛИ(ЕНД(ВПР([@[От кого]];Отделы[#Все];2;0));ВПР([@Кому];Отделы[#Все];2;0);ВПР([@[От кого]];Отделы[#Все];2;0))

Автор - Klsva
Дата добавления - 30.05.2020 в 20:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значений в таблице (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!