Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск позиции пустых ячеек в диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции пустых ячеек в диапазоне (Формулы/Formulas)
Поиск позиции пустых ячеек в диапазоне
Aleks1964 Дата: Понедельник, 01.06.2020, 16:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день!

Встала задача найти с помощью формул в изменяемом диапазоне по строке позицию пустой ячейки.
Но с помощью функции ПОИСКПОЗ - не удается.
Код
=ПОИСКПОЗ("";D4:K4)
Как я выяснил - ругается на пустоту - "".
В чем подвох?

[p.s.]Хотелось бы без массива...

Заранее благодарен!
К сообщению приложен файл: 7216422.xlsx(9.3 Kb)


Сообщение отредактировал Aleks1964 - Вторник, 02.06.2020, 08:13
 
Ответить
СообщениеДобрый день!

Встала задача найти с помощью формул в изменяемом диапазоне по строке позицию пустой ячейки.
Но с помощью функции ПОИСКПОЗ - не удается.
Код
=ПОИСКПОЗ("";D4:K4)
Как я выяснил - ругается на пустоту - "".
В чем подвох?

[p.s.]Хотелось бы без массива...

Заранее благодарен!

Автор - Aleks1964
Дата добавления - 01.06.2020 в 16:53
Che79 Дата: Понедельник, 01.06.2020, 17:23 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1638
Репутация: 303 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Здравствуйте. Заключите формулу в тэг при помощи кнопки fx в режиме редактирования поста
У меня есть вариант, но он массивный...


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте. Заключите формулу в тэг при помощи кнопки fx в режиме редактирования поста
У меня есть вариант, но он массивный...

Автор - Che79
Дата добавления - 01.06.2020 в 17:23
Nic70y Дата: Вторник, 02.06.2020, 12:11 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6601
Репутация: 1451 ±
Замечаний: 0% ±

ru13;10;03
Код
=ПРОСМОТР(1;СЧЁТЕСЛИ(СМЕЩ(ИНДЕКС(A4:S4;ПОИСКПОЗ(S3;A1:S1));;;;СТРОКА(ДВССЫЛ("1:"&ПОИСКПОЗ(U3;A1:S1)-ПОИСКПОЗ(S3;A1:S1)+1)));"");СТРОКА(1:99))
неправильно, не получается у меня без {}
разве, что так
Код
=СУММПРОИЗВ(ПОИСКПОЗ(0;-ИНДЕКС(A4:S4;ПОИСКПОЗ(S3;A1:S1)):ИНДЕКС(A4:S4;ПОИСКПОЗ(U3;A1:S1));))


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Вторник, 02.06.2020, 12:56
 
Ответить
Сообщение
Код
=ПРОСМОТР(1;СЧЁТЕСЛИ(СМЕЩ(ИНДЕКС(A4:S4;ПОИСКПОЗ(S3;A1:S1));;;;СТРОКА(ДВССЫЛ("1:"&ПОИСКПОЗ(U3;A1:S1)-ПОИСКПОЗ(S3;A1:S1)+1)));"");СТРОКА(1:99))
неправильно, не получается у меня без {}
разве, что так
Код
=СУММПРОИЗВ(ПОИСКПОЗ(0;-ИНДЕКС(A4:S4;ПОИСКПОЗ(S3;A1:S1)):ИНДЕКС(A4:S4;ПОИСКПОЗ(U3;A1:S1));))

Автор - Nic70y
Дата добавления - 02.06.2020 в 12:11
Aleks1964 Дата: Среда, 03.06.2020, 10:16 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Большое человеческое спасибо!
[p.s.]Вариант устраивает! hands


Сообщение отредактировал Aleks1964 - Среда, 03.06.2020, 10:20
 
Ответить
СообщениеБольшое человеческое спасибо!
[p.s.]Вариант устраивает! hands

Автор - Aleks1964
Дата добавления - 03.06.2020 в 10:16
AlexM Дата: Среда, 03.06.2020, 12:07 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
А если конец диапазона не указывать
Код
=ИНДЕКС(ПОИСКПОЗ(;-ИНДЕКС(A4:S4;ПОИСКПОЗ(S3;A1:S1)):S4;);)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеА если конец диапазона не указывать
Код
=ИНДЕКС(ПОИСКПОЗ(;-ИНДЕКС(A4:S4;ПОИСКПОЗ(S3;A1:S1)):S4;);)

Автор - AlexM
Дата добавления - 03.06.2020 в 12:07
Aleks1964 Дата: Четверг, 04.06.2020, 10:47 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо!
Даже затрудняюсь - что выбрать! :D
 
Ответить
СообщениеСпасибо!
Даже затрудняюсь - что выбрать! :D

Автор - Aleks1964
Дата добавления - 04.06.2020 в 10:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции пустых ячеек в диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!