Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод уникальных значений по условию в 2-мерный диапазон - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод уникальных значений по условию в 2-мерный диапазон (Формулы/Formulas)
Вывод уникальных значений по условию в 2-мерный диапазон
Aleks1964 Дата: Среда, 03.06.2020, 10:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем добрый день!
Прошу вашей помощи - проблема решена, но очень некрасиво.
Хотелось бы уйти от создания доп.таблиц.

В чем суть.
Есть таблица A2:L46 (на самом деле несколько сот строк) по комплектованию групп обучения. В столбце А:А - номера групп, в столбце L:L - номера групп по русскому языку (RU01, RU02, и т.д.)
В Таблице A48:E60 - соответствие групп по русскому и учебных (RU - TG).

Задачу решил путем создания двух! вспомогательных таблиц (через формулы массива):
1) M50:V60 - по строкам - поиск в основной таблице всех номеров учебных групп для каждой группы по русскому;
2) X50:AA60 - по строкам - убрал дубликаты.
И уж потом всавил соответствующие номера с добавлением "TG" в результирующую A48:E60.

Можно ли как-то сделать это покрасивше?
Заранее благодарен.
К сообщению приложен файл: _1-2.xlsx(26.8 Kb)
 
Ответить
СообщениеВсем добрый день!
Прошу вашей помощи - проблема решена, но очень некрасиво.
Хотелось бы уйти от создания доп.таблиц.

В чем суть.
Есть таблица A2:L46 (на самом деле несколько сот строк) по комплектованию групп обучения. В столбце А:А - номера групп, в столбце L:L - номера групп по русскому языку (RU01, RU02, и т.д.)
В Таблице A48:E60 - соответствие групп по русскому и учебных (RU - TG).

Задачу решил путем создания двух! вспомогательных таблиц (через формулы массива):
1) M50:V60 - по строкам - поиск в основной таблице всех номеров учебных групп для каждой группы по русскому;
2) X50:AA60 - по строкам - убрал дубликаты.
И уж потом всавил соответствующие номера с добавлением "TG" в результирующую A48:E60.

Можно ли как-то сделать это покрасивше?
Заранее благодарен.

Автор - Aleks1964
Дата добавления - 03.06.2020 в 10:53
Nic70y Дата: Среда, 03.06.2020, 11:59 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6460
Репутация: 1422 ±
Замечаний: 0% ±

ru13;10;03
не массивные,
1-й столбец
Код
="TG"&ИНДЕКС(A:A;ПОИСКПОЗ(A51;L:L;))
остальные
Код
=ЕСЛИОШИБКА("TG"&ИНДЕКС($A:$A;ПОИСКПОЗ($A51;ИНДЕКС($L:$L;ПОИСКПОЗ(ПОДСТАВИТЬ(C51;"TG";)+1;$A:$A;)):$L$47;)+ПОИСКПОЗ(ПОДСТАВИТЬ(C51;"TG";)+1;$A:$A;)-1);"")
где $L$47 для конкретного примера
К сообщению приложен файл: 6433021.xlsx(25.4 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениене массивные,
1-й столбец
Код
="TG"&ИНДЕКС(A:A;ПОИСКПОЗ(A51;L:L;))
остальные
Код
=ЕСЛИОШИБКА("TG"&ИНДЕКС($A:$A;ПОИСКПОЗ($A51;ИНДЕКС($L:$L;ПОИСКПОЗ(ПОДСТАВИТЬ(C51;"TG";)+1;$A:$A;)):$L$47;)+ПОИСКПОЗ(ПОДСТАВИТЬ(C51;"TG";)+1;$A:$A;)-1);"")
где $L$47 для конкретного примера

Автор - Nic70y
Дата добавления - 03.06.2020 в 11:59
gling Дата: Среда, 03.06.2020, 13:34 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2163
Репутация: 540 ±
Замечаний: 0% ±

2010
Ещё вариант Массивной формулой и с пользовательским форматом, для разнообразия.
К сообщению приложен файл: 1438835.xlsx(29.2 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Среда, 03.06.2020, 13:35
 
Ответить
СообщениеЕщё вариант Массивной формулой и с пользовательским форматом, для разнообразия.

Автор - gling
Дата добавления - 03.06.2020 в 13:34
Aleks1964 Дата: Четверг, 04.06.2020, 10:49 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем огромное спасибо!
Интересные и "красивые" решения! hands
 
Ответить
СообщениеВсем огромное спасибо!
Интересные и "красивые" решения! hands

Автор - Aleks1964
Дата добавления - 04.06.2020 в 10:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод уникальных значений по условию в 2-мерный диапазон (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!