Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление круглой даты - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление круглой даты (Формулы/Formulas)
Вычисление круглой даты
dilidong Дата: Понедельник, 08.06.2020, 12:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, уважаемые форумчане!
На ум не приходит решение вот такой задачи.
В таблице в столбец "Юб.возраст" необходимо проставить индикатор (юбиленый возраст) в случае, если одновременно выполняются следующие условие:
1) Дата рождения + N лет находится в диапазоне между Дата 1 и Дата 2;
2) Диапазон Дата 1 и Дата 2 больше или равно 60 календарных дней

N - число лет от 50 до 100 с интервалом 10 лет.

Заранее спасибо.
К сообщению приложен файл: _..xls(6.0 Kb)
 
Ответить
СообщениеДобрый день, уважаемые форумчане!
На ум не приходит решение вот такой задачи.
В таблице в столбец "Юб.возраст" необходимо проставить индикатор (юбиленый возраст) в случае, если одновременно выполняются следующие условие:
1) Дата рождения + N лет находится в диапазоне между Дата 1 и Дата 2;
2) Диапазон Дата 1 и Дата 2 больше или равно 60 календарных дней

N - число лет от 50 до 100 с интервалом 10 лет.

Заранее спасибо.

Автор - dilidong
Дата добавления - 08.06.2020 в 12:01
krosav4ig Дата: Понедельник, 08.06.2020, 13:24 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2323
Репутация: 976 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Добрый день
Массивная формула
Код
=ЕСЛИОШИБКА(40+ПОИСКПОЗ(1;ТЕКСТ(ТЕКСТ(КОНМЕСЯЦА(B2;СТРОКА($5:$10)*120-1)+1;"[>="&C2&"]0;");"[<="&D2&"]0;")^0;)*10;"")
К сообщению приложен файл: 2480188.xls(28.0 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеДобрый день
Массивная формула
Код
=ЕСЛИОШИБКА(40+ПОИСКПОЗ(1;ТЕКСТ(ТЕКСТ(КОНМЕСЯЦА(B2;СТРОКА($5:$10)*120-1)+1;"[>="&C2&"]0;");"[<="&D2&"]0;")^0;)*10;"")

Автор - krosav4ig
Дата добавления - 08.06.2020 в 13:24
Nic70y Дата: Понедельник, 08.06.2020, 13:44 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6590
Репутация: 1450 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(МАКС(0;ЕСЛИ(ОСТАТ(РАЗНДАТ(B2;C2-1;"y")+1;10)+ОСТАТ(РАЗНДАТ(B2;D2;"y");10)=0;РАЗНДАТ(B2;D2;"y"))-40);0;)*10+40;"")
не массивная


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ПОДСТАВИТЬ(МАКС(0;ЕСЛИ(ОСТАТ(РАЗНДАТ(B2;C2-1;"y")+1;10)+ОСТАТ(РАЗНДАТ(B2;D2;"y");10)=0;РАЗНДАТ(B2;D2;"y"))-40);0;)*10+40;"")
не массивная

Автор - Nic70y
Дата добавления - 08.06.2020 в 13:44
jakim Дата: Понедельник, 08.06.2020, 13:48 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 963
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IF(MOD(DATEDIF(B2;D2;"y");10)=0;DATEDIF(B2;D2;"y");"")
К сообщению приложен файл: Copy_of-.xlsx(9.8 Kb)
 
Ответить
Сообщение
Формула

Код
=IF(MOD(DATEDIF(B2;D2;"y");10)=0;DATEDIF(B2;D2;"y");"")

Автор - jakim
Дата добавления - 08.06.2020 в 13:48
dilidong Дата: Понедельник, 08.06.2020, 14:50 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
jakim, благодарю! Ваше решение мне показалось оптимальным! hands
 
Ответить
Сообщениеjakim, благодарю! Ваше решение мне показалось оптимальным! hands

Автор - dilidong
Дата добавления - 08.06.2020 в 14:50
Nic70y Дата: Понедельник, 08.06.2020, 16:56 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6590
Репутация: 1450 ±
Замечаний: 0% ±

ru13;10;03
показалось оптимальным!
нк так в нем не выполняется условия:
1) Дата рождения + N лет находится в диапазоне между Дата 1 и Дата 2

N - число лет от 50


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
показалось оптимальным!
нк так в нем не выполняется условия:
1) Дата рождения + N лет находится в диапазоне между Дата 1 и Дата 2

N - число лет от 50

Автор - Nic70y
Дата добавления - 08.06.2020 в 16:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление круглой даты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!