Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск Значения в Массиве и возвращение опред. параметра - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск Значения в Массиве и возвращение опред. параметра (Формулы/Formulas)
Поиск Значения в Массиве и возвращение опред. параметра
Jungle5 Дата: Понедельник, 08.06.2020, 17:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день! Ищу формулу для решения проблемы:
Есть список цен одного магазина и нескольких его конкурентов.
Задача: Искать цену магазина в столбцах с ценами конкурентов и взависимости от того, в каком столбце найдется эта цена, возвращать название этого столбца "1м_цена" или "2м_цена" и так далее. Пробовали делать с формулой Если(Ечисло), но что-то не работает. Файл прилагаю. Спасибо всем, кто сможет помочь, или хотя бы направить в нужное направление поиски)

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;H:H;0));"1м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;I:I;0)));"2м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;J:J;0)));"3м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;K:K;0)));"4м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;L:L;0)));"5м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;M:M;0)));"6м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;N:N;0)));"7м_цена")
К сообщению приложен файл: prices.xlsx(9.8 Kb)
 
Ответить
СообщениеДобрый день! Ищу формулу для решения проблемы:
Есть список цен одного магазина и нескольких его конкурентов.
Задача: Искать цену магазина в столбцах с ценами конкурентов и взависимости от того, в каком столбце найдется эта цена, возвращать название этого столбца "1м_цена" или "2м_цена" и так далее. Пробовали делать с формулой Если(Ечисло), но что-то не работает. Файл прилагаю. Спасибо всем, кто сможет помочь, или хотя бы направить в нужное направление поиски)

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;H:H;0));"1м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;I:I;0)));"2м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;J:J;0)));"3м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;K:K;0)));"4м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;L:L;0)));"5м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;M:M;0)));"6м_цена";ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(D2;N:N;0)));"7м_цена")

Автор - Jungle5
Дата добавления - 08.06.2020 в 17:39
Pelena Дата: Понедельник, 08.06.2020, 17:53 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16047
Репутация: 3487 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если правильно поняла
Код
=ИНДЕКС($E$1:$K$1;ПОИСКПОЗ(A2;E2:K2;0))
К сообщению приложен файл: 1036097.xlsx(9.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла
Код
=ИНДЕКС($E$1:$K$1;ПОИСКПОЗ(A2;E2:K2;0))

Автор - Pelena
Дата добавления - 08.06.2020 в 17:53
Jungle5 Дата: Вторник, 09.06.2020, 10:42 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, то, что нужно! Спасибо! hands
 
Ответить
СообщениеPelena, то, что нужно! Спасибо! hands

Автор - Jungle5
Дата добавления - 09.06.2020 в 10:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск Значения в Массиве и возвращение опред. параметра (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!