Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Пустые строки в выпадающем списке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пустые строки в выпадающем списке (Формулы/Formulas)
Пустые строки в выпадающем списке
Новичёк Дата: Среда, 10.06.2020, 12:40 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 1 ±
Замечаний: 0% ±

Добрый день. Можете подсказать решение, как убрать пустые значения в выпадающем списке столбец "Организация" на листе "Счета". Лучше формулой в параметрах выпадающего списка. Если такой возможности нет, то любым другим способом желательно без макроса. Таблица поставщики будет дополняться, но формат заполнения будет однотипным.
К сообщению приложен файл: 4041604.xlsx(15.1 Kb)


Сообщение отредактировал Новичёк - Среда, 10.06.2020, 12:44
 
Ответить
СообщениеДобрый день. Можете подсказать решение, как убрать пустые значения в выпадающем списке столбец "Организация" на листе "Счета". Лучше формулой в параметрах выпадающего списка. Если такой возможности нет, то любым другим способом желательно без макроса. Таблица поставщики будет дополняться, но формат заполнения будет однотипным.

Автор - Новичёк
Дата добавления - 10.06.2020 в 12:40
китин Дата: Среда, 10.06.2020, 13:24 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6279
Репутация: 963 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Добрый день. создать формулой отдельный список для проверки данных
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$50;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$50<>"";СТРОКА($A$3:$A$50)-2);СТРОКА(A1)));"")


Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 1066674.xlsx(15.6 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДобрый день. создать формулой отдельный список для проверки данных
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$50;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$50<>"";СТРОКА($A$3:$A$50)-2);СТРОКА(A1)));"")


Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 10.06.2020 в 13:24
Новичёк Дата: Среда, 10.06.2020, 14:34 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 1 ±
Замечаний: 0% ±

=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$50;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$50<>"";СТРОКА($A$3:$A$50)-2);СТРОКА(A1)));"")


При таком решении поставщик в список для проверки добавляется, а выпадающий список приходиться корректировать ручками. Есть ли способ и в выпадающий добавлять?
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$A$50;НАИМЕНЬШИЙ(ЕСЛИ($A$3:$A$50<>"";СТРОКА($A$3:$A$50)-2);СТРОКА(A1)));"")


При таком решении поставщик в список для проверки добавляется, а выпадающий список приходиться корректировать ручками. Есть ли способ и в выпадающий добавлять?

Автор - Новичёк
Дата добавления - 10.06.2020 в 14:34
китин Дата: Среда, 10.06.2020, 15:27 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6279
Репутация: 963 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
есть . используйте формулу или именованный диапазон.
имя в диспетчере имен Организация
формула
Код
=СМЕЩ($H$8;;;ПОИСКПОЗ(1=1;($H$8:$H$500="");0)-1)

[p.s.]при выделении формулы надо использовать не тэг цитаты а тэг fx
К сообщению приложен файл: 3763648.xlsx(15.7 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеесть . используйте формулу или именованный диапазон.
имя в диспетчере имен Организация
формула
Код
=СМЕЩ($H$8;;;ПОИСКПОЗ(1=1;($H$8:$H$500="");0)-1)

[p.s.]при выделении формулы надо использовать не тэг цитаты а тэг fx

Автор - китин
Дата добавления - 10.06.2020 в 15:27
Nic70y Дата: Среда, 10.06.2020, 15:42 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 6460
Репутация: 1422 ±
Замечаний: 0% ±

ru13;10;03
тоже вариант с допом, но немного другой
К сообщению приложен файл: 4041604-1-.xlsx(15.9 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениетоже вариант с допом, но немного другой

Автор - Nic70y
Дата добавления - 10.06.2020 в 15:42
Новичёк Дата: Среда, 10.06.2020, 15:53 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 91
Репутация: 1 ±
Замечаний: 0% ±

Спасибо всем за участие. То что надо.
 
Ответить
СообщениеСпасибо всем за участие. То что надо.

Автор - Новичёк
Дата добавления - 10.06.2020 в 15:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Пустые строки в выпадающем списке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!