Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод значения при нескольких условиях (ЕСЛИ мало) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значения при нескольких условиях (ЕСЛИ мало) (Формулы/Formulas)
Вывод значения при нескольких условиях (ЕСЛИ мало)
Laska Дата: Четверг, 18.06.2020, 01:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Привет, коллеги!
В прикрепленном файле есть задача, с которой никак не удается справиться.
Нужно вывести значение, при условии, что есть повторяющиеся не числовые данные, на которые завязаны числовые. Файл состоит из условных данных, мне нужно понять логику решения такой задачи.
Задача звучит так: бонус 1000 руб. положен каждому сотруднику, но он должен быть проставлен напротив магазина, в котором сотрудник отработал наибольшее кол-во часов.
Буду очень признательна за помощь.

Заранее спасибо. B)
К сообщению приложен файл: 1186119.xlsx(10.8 Kb)


Сообщение отредактировал Laska - Четверг, 18.06.2020, 01:04
 
Ответить
СообщениеПривет, коллеги!
В прикрепленном файле есть задача, с которой никак не удается справиться.
Нужно вывести значение, при условии, что есть повторяющиеся не числовые данные, на которые завязаны числовые. Файл состоит из условных данных, мне нужно понять логику решения такой задачи.
Задача звучит так: бонус 1000 руб. положен каждому сотруднику, но он должен быть проставлен напротив магазина, в котором сотрудник отработал наибольшее кол-во часов.
Буду очень признательна за помощь.

Заранее спасибо. B)

Автор - Laska
Дата добавления - 18.06.2020 в 01:04
amfor Дата: Четверг, 18.06.2020, 06:55 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 204
Репутация: 59 ±
Замечаний: 0% ±

Excel 2016
Привет. Так?
Код
=ЕСЛИ(МАКСЕСЛИ($F$6:$F$12;$A$6:$A$12;A6)=F6;1000;"")
К сообщению приложен файл: 9358618.xlsx(11.3 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеПривет. Так?
Код
=ЕСЛИ(МАКСЕСЛИ($F$6:$F$12;$A$6:$A$12;A6)=F6;1000;"")

Автор - amfor
Дата добавления - 18.06.2020 в 06:55
AlexM Дата: Четверг, 18.06.2020, 07:10 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Вариант с формулой массива. Ввод Ctrl+Shift+Enter
Код
=1000*(МАКС(ЕСЛИ(A$6:A$12=A6;F$6:F$12))=F6)
К сообщению приложен файл: 1186119_01.xlsx(10.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеВариант с формулой массива. Ввод Ctrl+Shift+Enter
Код
=1000*(МАКС(ЕСЛИ(A$6:A$12=A6;F$6:F$12))=F6)

Автор - AlexM
Дата добавления - 18.06.2020 в 07:10
Laska Дата: Четверг, 18.06.2020, 11:38 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Привет. Так?

=ЕСЛИ(МАКСЕСЛИ($F$6:$F$12;$A$6:$A$12;A6)=F6;1000;"")

Это высший пилотаж =) спасибо большое, только вот бы еще понять как работает эта формула :)

Вариант с формулой массива. Ввод Ctrl+Shift+Enter

=1000*(МАКС(ЕСЛИ(A$6:A$12=A6;F$6:F$12))=F6)

Спасибо, этот вариант мне проще понять. Все сработало. Благодарю!
 
Ответить
Сообщение
Привет. Так?

=ЕСЛИ(МАКСЕСЛИ($F$6:$F$12;$A$6:$A$12;A6)=F6;1000;"")

Это высший пилотаж =) спасибо большое, только вот бы еще понять как работает эта формула :)

Вариант с формулой массива. Ввод Ctrl+Shift+Enter

=1000*(МАКС(ЕСЛИ(A$6:A$12=A6;F$6:F$12))=F6)

Спасибо, этот вариант мне проще понять. Все сработало. Благодарю!

Автор - Laska
Дата добавления - 18.06.2020 в 11:38
AlexM Дата: Четверг, 18.06.2020, 12:08 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
как работает эта формула
так же как и другая, написав ее немного иначе мало отличается
Код
=1000*(МАКСЕСЛИ($F$6:$F$12;$A$6:$A$12;A6)=F6)
Массивная формула работает в любой версии Excel, что не скажешь о формуле с функцией МАКСЕСЛИ()



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
как работает эта формула
так же как и другая, написав ее немного иначе мало отличается
Код
=1000*(МАКСЕСЛИ($F$6:$F$12;$A$6:$A$12;A6)=F6)
Массивная формула работает в любой версии Excel, что не скажешь о формуле с функцией МАКСЕСЛИ()

Автор - AlexM
Дата добавления - 18.06.2020 в 12:08
Laska Дата: Суббота, 20.06.2020, 18:32 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
AlexM, Спасибо за разъяснения. Все поняла. Тему можно закрывать.
 
Ответить
СообщениеAlexM, Спасибо за разъяснения. Все поняла. Тему можно закрывать.

Автор - Laska
Дата добавления - 20.06.2020 в 18:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод значения при нескольких условиях (ЕСЛИ мало) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!