Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск строки по нескольким критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строки по нескольким критериям (Формулы/Formulas)
Поиск строки по нескольким критериям
Fireglow Дата: Четверг, 18.06.2020, 19:55 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем привет, помогите пожалуйста с формулой. есть две таблицы. в первой информация записана одной строкой, во второй таблице есть данные, совпадающие с первой, но они разнесены в разные ячейки (из примера "номенклатура", "цвет" и "размер"), например в первой таблице строка "1403 Платье жен. "Далория" Хаки 112" а во второй в разных ячейках "1403" "хаки" и "112". В первой таблице есть колонка остаток, там какая то цифра. задача найти строку из первой таблицы, которая соотвествует совпадениям по 3 значениям из второй таблицы и вставить остаток из первой таблицы в строку из второй в колонку шт продано
К сообщению приложен файл: __1.xlsx(51.9 Kb)
 
Ответить
СообщениеВсем привет, помогите пожалуйста с формулой. есть две таблицы. в первой информация записана одной строкой, во второй таблице есть данные, совпадающие с первой, но они разнесены в разные ячейки (из примера "номенклатура", "цвет" и "размер"), например в первой таблице строка "1403 Платье жен. "Далория" Хаки 112" а во второй в разных ячейках "1403" "хаки" и "112". В первой таблице есть колонка остаток, там какая то цифра. задача найти строку из первой таблицы, которая соотвествует совпадениям по 3 значениям из второй таблицы и вставить остаток из первой таблицы в строку из второй в колонку шт продано

Автор - Fireglow
Дата добавления - 18.06.2020 в 19:55
Pelena Дата: Четверг, 18.06.2020, 21:14 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16045
Репутация: 3487 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ВПР(B2&"*"&D2&"*"&E2&"*";Клиент!$A$10:$D$368;4;0);"")
К сообщению приложен файл: _1-1-.xlsx(61.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ВПР(B2&"*"&D2&"*"&E2&"*";Клиент!$A$10:$D$368;4;0);"")

Автор - Pelena
Дата добавления - 18.06.2020 в 21:14
Fireglow Дата: Четверг, 18.06.2020, 22:43 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, спасибо, все заработало, с формулой разобрался.
 
Ответить
СообщениеPelena, спасибо, все заработало, с формулой разобрался.

Автор - Fireglow
Дата добавления - 18.06.2020 в 22:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строки по нескольким критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!