Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить дни рождения сотрудников ближайшие 30 дней. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить дни рождения сотрудников ближайшие 30 дней. (Формулы/Formulas)
Определить дни рождения сотрудников ближайшие 30 дней.
Fixer96 Дата: Пятница, 19.06.2020, 09:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день. Помогите пожалуйста , у меня имеется список сотрудников с днями рождения. Стоит задача, сделать 2 дополнительный столбца, в которых должно о отображаться:
1. У кого из сотрудников день рождения ближайшие 30 дней. Точнее в этой строке, если у него день рождения, отобразится символ "!"
2. У кого ЮБИЛЕЙ ближайшие 30 дней. И тоже если совпадает то отобразится символ "!"
К сообщению приложен файл: 4010068.xlsx(8.9 Kb)


Сообщение отредактировал Fixer96 - Пятница, 19.06.2020, 09:54
 
Ответить
СообщениеДобрый день. Помогите пожалуйста , у меня имеется список сотрудников с днями рождения. Стоит задача, сделать 2 дополнительный столбца, в которых должно о отображаться:
1. У кого из сотрудников день рождения ближайшие 30 дней. Точнее в этой строке, если у него день рождения, отобразится символ "!"
2. У кого ЮБИЛЕЙ ближайшие 30 дней. И тоже если совпадает то отобразится символ "!"

Автор - Fixer96
Дата добавления - 19.06.2020 в 09:23
AlexM Дата: Пятница, 19.06.2020, 09:27 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Как вам помочь без вашего файла-примера?



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеКак вам помочь без вашего файла-примера?

Автор - AlexM
Дата добавления - 19.06.2020 в 09:27
Pelena Дата: Пятница, 19.06.2020, 09:29 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16764
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Нужен небольшой файл с примерами дат без конф. информации.
И да, второй пункт полностью входит в первый. Может, для юбиляров какой-нибудь другой символ придумать?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Нужен небольшой файл с примерами дат без конф. информации.
И да, второй пункт полностью входит в первый. Может, для юбиляров какой-нибудь другой символ придумать?

Автор - Pelena
Дата добавления - 19.06.2020 в 09:29
Nic70y Дата: Пятница, 19.06.2020, 09:32 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6584
Репутация: 1449 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИ(И(ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A1);ДЕНЬ(A1))>=СЕГОДНЯ()-30;ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A1);ДЕНЬ(A1))<=СЕГОДНЯ());"!";"")
Код
=ЕСЛИ(И(B1="!";ОСТАТ(ГОД(СЕГОДНЯ())-ГОД(A1);10)=0);"!";"")


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(И(ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A1);ДЕНЬ(A1))>=СЕГОДНЯ()-30;ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(A1);ДЕНЬ(A1))<=СЕГОДНЯ());"!";"")
Код
=ЕСЛИ(И(B1="!";ОСТАТ(ГОД(СЕГОДНЯ())-ГОД(A1);10)=0);"!";"")

Автор - Nic70y
Дата добавления - 19.06.2020 в 09:32
Fixer96 Дата: Пятница, 19.06.2020, 09:55 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Как вам помочь без вашего файла-примера?

Прошу прощения, почему-то сразу не прикрепилось.
 
Ответить
Сообщение
Как вам помочь без вашего файла-примера?

Прошу прощения, почему-то сразу не прикрепилось.

Автор - Fixer96
Дата добавления - 19.06.2020 в 09:55
Fixer96 Дата: Пятница, 19.06.2020, 09:57 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте.
Нужен небольшой файл с примерами дат без конф. информации.
И да, второй пункт полностью входит в первый. Может, для юбиляров какой-нибудь другой символ придумать?

Извиняюсь, добавил. Так юбиляры же в отдельном столбце. Ну можно другой символ, это не принципиально. Просто у руководства будет потребность делать фильтр по столбцу и видеть среди всех сотрудников тех у кого юбилей скоро
 
Ответить
Сообщение
Здравствуйте.
Нужен небольшой файл с примерами дат без конф. информации.
И да, второй пункт полностью входит в первый. Может, для юбиляров какой-нибудь другой символ придумать?

Извиняюсь, добавил. Так юбиляры же в отдельном столбце. Ну можно другой символ, это не принципиально. Просто у руководства будет потребность делать фильтр по столбцу и видеть среди всех сотрудников тех у кого юбилей скоро

Автор - Fixer96
Дата добавления - 19.06.2020 в 09:57
Nic70y Дата: Пятница, 19.06.2020, 10:35 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 6584
Репутация: 1449 ±
Замечаний: 0% ±

ru13;10;03
ну почти правильно написал в посте №4
Код
=ЕСЛИ(И(ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(D2);ДЕНЬ(D2)-30)<=СЕГОДНЯ();ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(D2);ДЕНЬ(D2))>=СЕГОДНЯ());"!";"")
К сообщению приложен файл: 0354615.xlsx(9.6 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениену почти правильно написал в посте №4
Код
=ЕСЛИ(И(ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(D2);ДЕНЬ(D2)-30)<=СЕГОДНЯ();ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(D2);ДЕНЬ(D2))>=СЕГОДНЯ());"!";"")

Автор - Nic70y
Дата добавления - 19.06.2020 в 10:35
AlexM Дата: Пятница, 19.06.2020, 10:41 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Вычисление ближайшего ДР и Юбилея
К сообщению приложен файл: 4010068_01.xlsx(9.9 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеВычисление ближайшего ДР и Юбилея

Автор - AlexM
Дата добавления - 19.06.2020 в 10:41
Fixer96 Дата: Пятница, 19.06.2020, 11:38 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
К сообщению приложен файл: 0354615.xlsx(9.6 Kb)

Спасибо большое!)
 
Ответить
Сообщение
К сообщению приложен файл: 0354615.xlsx(9.6 Kb)

Спасибо большое!)

Автор - Fixer96
Дата добавления - 19.06.2020 в 11:38
Fixer96 Дата: Пятница, 19.06.2020, 11:38 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Вычисление ближайшего ДР и Юбилея
К сообщению приложен файл: 4010068_01.xlsx(9.9 Kb)

Вам тоже спасибо огромное за помощь. Ваша работа, тоже пригодится!
 
Ответить
Сообщение
Вычисление ближайшего ДР и Юбилея
К сообщению приложен файл: 4010068_01.xlsx(9.9 Kb)

Вам тоже спасибо огромное за помощь. Ваша работа, тоже пригодится!

Автор - Fixer96
Дата добавления - 19.06.2020 в 11:38
jakim Дата: Пятница, 19.06.2020, 12:37 | Сообщение № 11
Группа: Друзья
Ранг: Ветеран
Сообщений: 963
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Немного другие формулы

Ближайший День Рождения

Код
=DATE(YEAR(TODAY());MONTH(D2);DAY(D2))

Ближайший юбилей 10

Код
=DATE(YEAR(EDATE(D2;CEILING.PRECISE(YEARFRAC(D2;TODAY();1);10)*12));MONTH(D2);DAY(D2))

Только исправьте разнобой в датах дня рождения.


Сообщение отредактировал jakim - Пятница, 19.06.2020, 12:39
 
Ответить
Сообщение
Немного другие формулы

Ближайший День Рождения

Код
=DATE(YEAR(TODAY());MONTH(D2);DAY(D2))

Ближайший юбилей 10

Код
=DATE(YEAR(EDATE(D2;CEILING.PRECISE(YEARFRAC(D2;TODAY();1);10)*12));MONTH(D2);DAY(D2))

Только исправьте разнобой в датах дня рождения.

Автор - jakim
Дата добавления - 19.06.2020 в 12:37
AlexM Дата: Пятница, 19.06.2020, 12:54 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
jakim, не корректно ближайший ДР определяет. Например 23.02.1980, ближайший 23.02.2021, а не 23.02.2020



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеjakim, не корректно ближайший ДР определяет. Например 23.02.1980, ближайший 23.02.2021, а не 23.02.2020

Автор - AlexM
Дата добавления - 19.06.2020 в 12:54
jakim Дата: Пятница, 19.06.2020, 14:03 | Сообщение № 13
Группа: Друзья
Ранг: Ветеран
Сообщений: 963
Репутация: 251 ±
Замечаний: 0% ±

Excel 2010
Тогда так
Ближайший День Рождения

Код
=DATE(YEAR(EDATE(D2;CEILING(YEARFRAC(D2;TODAY();1);1)*12));MONTH(D2);DAY(D2))
 
Ответить
Сообщение
Тогда так
Ближайший День Рождения

Код
=DATE(YEAR(EDATE(D2;CEILING(YEARFRAC(D2;TODAY();1);1)*12));MONTH(D2);DAY(D2))

Автор - jakim
Дата добавления - 19.06.2020 в 14:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить дни рождения сотрудников ближайшие 30 дней. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!