Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сортировка данных таблицы по данным другой таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сортировка данных таблицы по данным другой таблицы (Формулы/Formulas)
сортировка данных таблицы по данным другой таблицы
Allexsin Дата: Воскресенье, 28.06.2020, 12:07 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! возникла необходимость сортировки данных одной таблицы по данным другой (основной) таблицы в автоматическом режиме. Необходимо чтобы данные из второй таблицы (будет располагаться справа) распределялись по строкам и становились на против данных из первой таблицы по критериям которых производиться сортировка (1. Дата, 2. гос.номер автомобиля, 3. фио водителя). Необходимо еще учесть, что в первой таблице автомобиль в один и тот же день может встречаться несколько раз (несколько выездов), а строчка из второй таблицы по дате и гос.номеру должна становиться напротив первой, встреченной строчки. Как и каким инструментом это сделать не могу понять. Во вложении файл сданными, которые необходимо отсортировать.
К сообщению приложен файл: 2900568.xlsx(30.4 Kb)
 
Ответить
СообщениеДобрый день! возникла необходимость сортировки данных одной таблицы по данным другой (основной) таблицы в автоматическом режиме. Необходимо чтобы данные из второй таблицы (будет располагаться справа) распределялись по строкам и становились на против данных из первой таблицы по критериям которых производиться сортировка (1. Дата, 2. гос.номер автомобиля, 3. фио водителя). Необходимо еще учесть, что в первой таблице автомобиль в один и тот же день может встречаться несколько раз (несколько выездов), а строчка из второй таблицы по дате и гос.номеру должна становиться напротив первой, встреченной строчки. Как и каким инструментом это сделать не могу понять. Во вложении файл сданными, которые необходимо отсортировать.

Автор - Allexsin
Дата добавления - 28.06.2020 в 12:07
Pelena Дата: Воскресенье, 28.06.2020, 13:42 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16766
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Формула массива
Код
=ЕСЛИ(СЧЁТЕСЛИМН($B$8:$B8;$B8;$C$8:$C8;$C8;$D$8:$D8;$D8)=1;ИНДЕКС(K$8:K$177;ПОИСКПОЗ($B8&$C8&$D8;$L$8:$L$177&$M$8:$M$177&$N$8:$N$177;0));"")
К сообщению приложен файл: 8456490.xlsx(74.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Формула массива
Код
=ЕСЛИ(СЧЁТЕСЛИМН($B$8:$B8;$B8;$C$8:$C8;$C8;$D$8:$D8;$D8)=1;ИНДЕКС(K$8:K$177;ПОИСКПОЗ($B8&$C8&$D8;$L$8:$L$177&$M$8:$M$177&$N$8:$N$177;0));"")

Автор - Pelena
Дата добавления - 28.06.2020 в 13:42
Allexsin Дата: Среда, 01.07.2020, 00:39 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день! Спасибо, вреде бы работает. Одно, но. Подскажите, пожалуйста, причину появления (в прилагаемом Вами файле) в ячейке с представленной формулой - "#знач", вместо результата при двойном щелчке по ячейке и выходе в режим редактирования формулы и с последующим выходом из редактирования нажатием "enter".
 
Ответить
СообщениеДобрый день! Спасибо, вреде бы работает. Одно, но. Подскажите, пожалуйста, причину появления (в прилагаемом Вами файле) в ячейке с представленной формулой - "#знач", вместо результата при двойном щелчке по ячейке и выходе в режим редактирования формулы и с последующим выходом из редактирования нажатием "enter".

Автор - Allexsin
Дата добавления - 01.07.2020 в 00:39
Pelena Дата: Среда, 01.07.2020, 10:06 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16766
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
нажатием "enter"
Формула массива вводится сочетанием клавиш Ctrl+Shift+Enter


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
нажатием "enter"
Формула массива вводится сочетанием клавиш Ctrl+Shift+Enter

Автор - Pelena
Дата добавления - 01.07.2020 в 10:06
Allexsin Дата: Среда, 01.07.2020, 19:19 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 39
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Понятно, спасибо!!!
 
Ответить
СообщениеПонятно, спасибо!!!

Автор - Allexsin
Дата добавления - 01.07.2020 в 19:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сортировка данных таблицы по данным другой таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!