Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Синхронизация файлов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Синхронизация файлов (Формулы/Formulas)
Синхронизация файлов
Kirito Дата: Воскресенье, 05.07.2020, 20:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем доброго времени суток! Помогите с решением вопроса. Имеем два файла Файл1 и Файл2, где файл 1 является исходником, а файл2 будет документом предназначенный для сбора данных.
В файл2 при помощи функций (см. столбец "B")
Код
=ЕСЛИ(СЧЁТЕСЛИ([Файл1.xlsx]Лист1!$F$2:$F$33;$D$1)>=СТРОКА(1:1);ИНДЕКС([Файл1.xlsx]Лист1!$B$1:$B$33;НАИМЕНЬШИЙ(ЕСЛИ([Файл1.xlsx]Лист1!$F$2:$F$33=$D$1;СТРОКА([Файл1.xlsx]Лист1!$B$2:$B$33));СТРОКА(1:1)));"")

переносятся детали с признаком «п» и во вторую таблицу с признаком «о» во вторую. Также при помощи «ВПР» переносятся все необходимые данные.
Суть вопроса такова: как синхронизировать эти файлы при изменении в «Файле1» так что бы менялись данные в файле2 (пример изменения данных в столбце «Е») не открывая «файл1». На данный момент, это возможно при открытии двух файлов. Если нажать в «файле1» кнопку обновить, то все данные теряются. Но есть необходимость собирать данные из нескольких файлов и не хочется каждый раз открывать каждый файл.

P.S: или же есть возможность переносить данные из файла1 в файл2 по определенному признаку использую формулы а не функции?
Замечу, что при использовании ВПР можно не открывать файл1, чтобы изменились данные в файле 2.
Прошу вашей помощи!
К сообщению приложен файл: 9335206.xlsx(9.6 Kb) · 7078770.xlsx(14.0 Kb)


Сообщение отредактировал Kirito - Воскресенье, 05.07.2020, 20:24
 
Ответить
СообщениеВсем доброго времени суток! Помогите с решением вопроса. Имеем два файла Файл1 и Файл2, где файл 1 является исходником, а файл2 будет документом предназначенный для сбора данных.
В файл2 при помощи функций (см. столбец "B")
Код
=ЕСЛИ(СЧЁТЕСЛИ([Файл1.xlsx]Лист1!$F$2:$F$33;$D$1)>=СТРОКА(1:1);ИНДЕКС([Файл1.xlsx]Лист1!$B$1:$B$33;НАИМЕНЬШИЙ(ЕСЛИ([Файл1.xlsx]Лист1!$F$2:$F$33=$D$1;СТРОКА([Файл1.xlsx]Лист1!$B$2:$B$33));СТРОКА(1:1)));"")

переносятся детали с признаком «п» и во вторую таблицу с признаком «о» во вторую. Также при помощи «ВПР» переносятся все необходимые данные.
Суть вопроса такова: как синхронизировать эти файлы при изменении в «Файле1» так что бы менялись данные в файле2 (пример изменения данных в столбце «Е») не открывая «файл1». На данный момент, это возможно при открытии двух файлов. Если нажать в «файле1» кнопку обновить, то все данные теряются. Но есть необходимость собирать данные из нескольких файлов и не хочется каждый раз открывать каждый файл.

P.S: или же есть возможность переносить данные из файла1 в файл2 по определенному признаку использую формулы а не функции?
Замечу, что при использовании ВПР можно не открывать файл1, чтобы изменились данные в файле 2.
Прошу вашей помощи!

Автор - Kirito
Дата добавления - 05.07.2020 в 20:24
Pelena Дата: Воскресенье, 05.07.2020, 21:19 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16764
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Вместо условия
Код
СЧЁТЕСЛИ([Файл1.xlsx]Лист1!$F$2:$F$33;$D$1)>=СТРОКА(1:1)
попробуйте использовать
Код
СУММПРОИЗВ(--([Файл1.xlsx]Лист1!$F$2:$F$33=$D$1))>=СТРОКА(1:1)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вместо условия
Код
СЧЁТЕСЛИ([Файл1.xlsx]Лист1!$F$2:$F$33;$D$1)>=СТРОКА(1:1)
попробуйте использовать
Код
СУММПРОИЗВ(--([Файл1.xlsx]Лист1!$F$2:$F$33=$D$1))>=СТРОКА(1:1)

Автор - Pelena
Дата добавления - 05.07.2020 в 21:19
Kirito Дата: Воскресенье, 05.07.2020, 21:47 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, да получилось!!!! Очень сильно выручили!!!!!)))))
 
Ответить
СообщениеPelena, да получилось!!!! Очень сильно выручили!!!!!)))))

Автор - Kirito
Дата добавления - 05.07.2020 в 21:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Синхронизация файлов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!