Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменить формулу макросом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменить формулу макросом (Формулы/Formulas)
Изменить формулу макросом
BotBa3ilio Дата: Понедельник, 06.07.2020, 12:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Товарищи, подскажите, как с помощью макроса изменить в формуле
Код
=ИНДЕКС(B3:B14;ПОИСКПОЗ("Ошибка:*";B3:B14;0))
ячейки B14 на последнюю заполненную ячейку с столбце B?
Например: если в столбце B последняя ячейка с данными B34, то в формуле должно быть так
Код
=ИНДЕКС(B3:B34;ПОИСКПОЗ("Ошибка:*";B3:B34;0))


Сообщение отредактировал BotBa3ilio - Понедельник, 06.07.2020, 13:57
 
Ответить
СообщениеТоварищи, подскажите, как с помощью макроса изменить в формуле
Код
=ИНДЕКС(B3:B14;ПОИСКПОЗ("Ошибка:*";B3:B14;0))
ячейки B14 на последнюю заполненную ячейку с столбце B?
Например: если в столбце B последняя ячейка с данными B34, то в формуле должно быть так
Код
=ИНДЕКС(B3:B34;ПОИСКПОЗ("Ошибка:*";B3:B34;0))

Автор - BotBa3ilio
Дата добавления - 06.07.2020 в 12:50
китин Дата: Понедельник, 06.07.2020, 13:26 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6255
Репутация: 961 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
BotBa3ilio, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеBotBa3ilio, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 06.07.2020 в 13:26
Nic70y Дата: Понедельник, 06.07.2020, 14:00 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6356
Репутация: 1401 ±
Замечаний: 0% ±

ru13;10;03
а чем
Код
=ИНДЕКС(B:B;ПОИСКПОЗ("Ошибка:*";B:B;0))
не устраивает?


Яндекс Деньги 41001841029809
 
Ответить
Сообщениеа чем
Код
=ИНДЕКС(B:B;ПОИСКПОЗ("Ошибка:*";B:B;0))
не устраивает?

Автор - Nic70y
Дата добавления - 06.07.2020 в 14:00
китин Дата: Понедельник, 06.07.2020, 15:51 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6255
Репутация: 961 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Коля
на последнюю заполненную ячейку с столбце B?

или я что не так понял

Код
=$B$3:ИНДЕКС($B$3:$B$10000;ПРОСМОТР(2;1/("ошибка"=$B$3:$B$100);СТРОКА($1:$100)))

а вообще по хорошему файлик бы ваш посмотреть


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеКоля
на последнюю заполненную ячейку с столбце B?

или я что не так понял

Код
=$B$3:ИНДЕКС($B$3:$B$10000;ПРОСМОТР(2;1/("ошибка"=$B$3:$B$100);СТРОКА($1:$100)))

а вообще по хорошему файлик бы ваш посмотреть

Автор - китин
Дата добавления - 06.07.2020 в 15:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменить формулу макросом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!