Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Дни недели согласно номерам дней - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дни недели согласно номерам дней (Формулы/Formulas)
Дни недели согласно номерам дней
Gopronotmore Дата: Понедельник, 13.07.2020, 19:29 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 139
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Коллеги, подскажите какую формулу прописать что бы дни трансформировались в названия дней недели
К сообщению приложен файл: 2801446.xlsx(9.8 Kb)
 
Ответить
СообщениеКоллеги, подскажите какую формулу прописать что бы дни трансформировались в названия дней недели

Автор - Gopronotmore
Дата добавления - 13.07.2020 в 19:29
прохожий2019 Дата: Понедельник, 13.07.2020, 19:45 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 50 ±
Замечаний: 0% ±

365 Current Channel
Код
=ТЕКСТ(дата;"ДДД")
 
Ответить
Сообщение
Код
=ТЕКСТ(дата;"ДДД")

Автор - прохожий2019
Дата добавления - 13.07.2020 в 19:45
Pelena Дата: Понедельник, 13.07.2020, 19:48 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 16244
Репутация: 3518 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Я бы просто форматом сделала. Обратите внимание в файле даты и во второй строке и в третьей
К сообщению приложен файл: 4928150.xlsx(10.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЯ бы просто форматом сделала. Обратите внимание в файле даты и во второй строке и в третьей

Автор - Pelena
Дата добавления - 13.07.2020 в 19:48
Che79 Дата: Понедельник, 13.07.2020, 20:07 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1595
Репутация: 297 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Расширяя горизонты немного апгрейдил - выпадающий список месяцев в виде текста, две формулы и УФ.
К сообщению приложен файл: 4928150_2.xlsx(11.2 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеРасширяя горизонты немного апгрейдил - выпадающий список месяцев в виде текста, две формулы и УФ.

Автор - Che79
Дата добавления - 13.07.2020 в 20:07
Gopronotmore Дата: Вторник, 14.07.2020, 19:31 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 139
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Che79, а можно оставить не месяцы а СЕГОДНЯ() в ячейке B2
 
Ответить
СообщениеChe79, а можно оставить не месяцы а СЕГОДНЯ() в ячейке B2

Автор - Gopronotmore
Дата добавления - 14.07.2020 в 19:31
Che79 Дата: Вторник, 14.07.2020, 20:52 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1595
Репутация: 297 ±
Замечаний: 0% ±

2013 Win, 365 Mac
а можно
можно)
К сообщению приложен файл: 4928150_3.xlsx(11.1 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
а можно
можно)

Автор - Che79
Дата добавления - 14.07.2020 в 20:52
прохожий2019 Дата: Вторник, 14.07.2020, 21:25 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 50 ±
Замечаний: 0% ±

365 Current Channel
до кучи
Код
=ЕСЛИ(СТОЛБЕЦ(A1)<=ДЕНЬ(КОНМЕСЯЦА($B$2;0));СТОЛБЕЦ(A1);"")
Код
=ТЕКСТ(ДАТА(ГОД($B$2);МЕСЯЦ($B$2);C2);"ДДД")

а теперь ещё и так можно
Код
=ПОСЛЕД(1;ДЕНЬ(КОНМЕСЯЦА(B2;0)))
Код
=ТЕКСТ(КОНМЕСЯЦА(B2;-1)+ПОСЛЕД(1;ДЕНЬ(КОНМЕСЯЦА(B2;0)));"ДДД")
К сообщению приложен файл: 9976111.xlsx(12.1 Kb)


Сообщение отредактировал прохожий2019 - Среда, 15.07.2020, 00:43
 
Ответить
Сообщениедо кучи
Код
=ЕСЛИ(СТОЛБЕЦ(A1)<=ДЕНЬ(КОНМЕСЯЦА($B$2;0));СТОЛБЕЦ(A1);"")
Код
=ТЕКСТ(ДАТА(ГОД($B$2);МЕСЯЦ($B$2);C2);"ДДД")

а теперь ещё и так можно
Код
=ПОСЛЕД(1;ДЕНЬ(КОНМЕСЯЦА(B2;0)))
Код
=ТЕКСТ(КОНМЕСЯЦА(B2;-1)+ПОСЛЕД(1;ДЕНЬ(КОНМЕСЯЦА(B2;0)));"ДДД")

Автор - прохожий2019
Дата добавления - 14.07.2020 в 21:25
Gopronotmore Дата: Понедельник, 20.07.2020, 18:39 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 139
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Спасибо за вариативность вариантов
 
Ответить
СообщениеСпасибо за вариативность вариантов

Автор - Gopronotmore
Дата добавления - 20.07.2020 в 18:39
Юрий_Ф Дата: Четверг, 23.07.2020, 14:58 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Самый первый вариант отлично работает!
 
Ответить
СообщениеСамый первый вариант отлично работает!

Автор - Юрий_Ф
Дата добавления - 23.07.2020 в 14:58
Юрий_Ф Дата: Четверг, 23.07.2020, 15:35 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 100
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
В сообщении "До кучи" в приложенном примере в ячейке В2 можно ставить дату в виде Июль-20! Отлично работает.
А с помощью условного форматирования можно окрашивать Сб и Вс в воскресные цвета!
Спасибо!
К сообщению приложен файл: 0204524.jpg(24.4 Kb)
 
Ответить
СообщениеВ сообщении "До кучи" в приложенном примере в ячейке В2 можно ставить дату в виде Июль-20! Отлично работает.
А с помощью условного форматирования можно окрашивать Сб и Вс в воскресные цвета!
Спасибо!

Автор - Юрий_Ф
Дата добавления - 23.07.2020 в 15:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Дни недели согласно номерам дней (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!