Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отсортировать значения в столбце по условию. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отсортировать значения в столбце по условию. (Формулы/Formulas)
Отсортировать значения в столбце по условию.
russcand Дата: Четверг, 16.07.2020, 23:35 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 98
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте , спасители!
Маленькая задачка.
Есть таблица. В ней значения в столбцах 1-11 привязаны к столбцу "В" по-строчно.
В таблице также есть столбец "С" , в котором значения располагаются не_урегулировано и могут быть не уникальными один-к-другому.
Значения в столбце "В" привязаны к столбцу "С" по-строчно ( ну , то есть , перемещение строки в столбце "С" приводит к перемещению за ним всей строчки ).
Надо столбец "С" урегулировать по убыванию ( с соответствующей пересортице в столбце "В" и столбцов 1-11 ).
Вообщем , если описал мутно , то во вложении все сразу понятно.
Спасибо.
П.С. решение инструментами Эксел.
К сообщению приложен файл: _Microsoft_Exce.xlsx(11.2 Kb)
 
Ответить
СообщениеЗдравствуйте , спасители!
Маленькая задачка.
Есть таблица. В ней значения в столбцах 1-11 привязаны к столбцу "В" по-строчно.
В таблице также есть столбец "С" , в котором значения располагаются не_урегулировано и могут быть не уникальными один-к-другому.
Значения в столбце "В" привязаны к столбцу "С" по-строчно ( ну , то есть , перемещение строки в столбце "С" приводит к перемещению за ним всей строчки ).
Надо столбец "С" урегулировать по убыванию ( с соответствующей пересортице в столбце "В" и столбцов 1-11 ).
Вообщем , если описал мутно , то во вложении все сразу понятно.
Спасибо.
П.С. решение инструментами Эксел.

Автор - russcand
Дата добавления - 16.07.2020 в 23:35
прохожий2019 Дата: Пятница, 17.07.2020, 00:12 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 50 ±
Замечаний: 0% ±

365 Current Channel
Маленькая задачка
что ж вы самостоятельно свои "маленькие несложные" задачки не решаете?
номер:
Код
=ИНДЕКС($B$3:$B$13;ПОИСКПОЗ(НАИБОЛЬШИЙ($C$3:$C$13-СТРОКА($C$3:$C$13)%%;СТРОКА(A1));$C$3:$C$13-СТРОКА($C$3:$C$13)%%;))
остальное
Код
=ИНДЕКС(C$3:C$13;ПОИСКПОЗ($B29;$B$3:$B$13;))

или в новой эксельке:
Код
=СОРТ(B3:N13;2;-1)
К сообщению приложен файл: 2857485.xlsx(13.9 Kb)


Сообщение отредактировал прохожий2019 - Пятница, 17.07.2020, 00:45
 
Ответить
Сообщение
Маленькая задачка
что ж вы самостоятельно свои "маленькие несложные" задачки не решаете?
номер:
Код
=ИНДЕКС($B$3:$B$13;ПОИСКПОЗ(НАИБОЛЬШИЙ($C$3:$C$13-СТРОКА($C$3:$C$13)%%;СТРОКА(A1));$C$3:$C$13-СТРОКА($C$3:$C$13)%%;))
остальное
Код
=ИНДЕКС(C$3:C$13;ПОИСКПОЗ($B29;$B$3:$B$13;))

или в новой эксельке:
Код
=СОРТ(B3:N13;2;-1)

Автор - прохожий2019
Дата добавления - 17.07.2020 в 00:12
Nic70y Дата: Пятница, 17.07.2020, 09:03 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 6345
Репутация: 1399 ±
Замечаний: 0% ±

ru13;10;03
если избавиться от формул в "Номера ячеек",
то с задачей вполне справится настраиваемая сортировка


Яндекс Деньги 41001841029809
 
Ответить
Сообщениеесли избавиться от формул в "Номера ячеек",
то с задачей вполне справится настраиваемая сортировка

Автор - Nic70y
Дата добавления - 17.07.2020 в 09:03
russcand Дата: Суббота, 18.07.2020, 01:35 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 98
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Не , именно то , что сделал прохожий.
Спасибо , дай бог ему послушную жену или мужа , или обоих сразу +))).


Сообщение отредактировал russcand - Суббота, 18.07.2020, 01:36
 
Ответить
СообщениеНе , именно то , что сделал прохожий.
Спасибо , дай бог ему послушную жену или мужа , или обоих сразу +))).

Автор - russcand
Дата добавления - 18.07.2020 в 01:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отсортировать значения в столбце по условию. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!