Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Из базы чисел выделить числа по условию. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из базы чисел выделить числа по условию. (Формулы/Formulas)
Из базы чисел выделить числа по условию.
russcand Дата: Понедельник, 27.07.2020, 08:57 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте!
Надо из базы чисел выделить числа:
а. С заданным окончанием ( 0-1-2-3-4... ) , н-р , 1 , 21 , 31 , 61 , 11...
б. Имеющие в своем составе указанные числа , н-р , 13 , 31 , 11 , 41 , 19...

К сообщению приложен файл: 3349623.xlsx(8.8 Kb)
 
Ответить
СообщениеЗдравствуйте!
Надо из базы чисел выделить числа:
а. С заданным окончанием ( 0-1-2-3-4... ) , н-р , 1 , 21 , 31 , 61 , 11...
б. Имеющие в своем составе указанные числа , н-р , 13 , 31 , 11 , 41 , 19...


Автор - russcand
Дата добавления - 27.07.2020 в 08:57
Nic70y Дата: Понедельник, 27.07.2020, 09:05 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6605
Репутация: 1453 ±
Замечаний: 0% ±

ru13;10;03
массивные:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ПРАВБ($B6:$D12)="1";$B6:$D12);СТОЛБЕЦ(A1));"")
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(1;$B6:$D12));$B6:$D12);СТОЛБЕЦ(A1));"")
К сообщению приложен файл: 5974721.xlsx(9.2 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениемассивные:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ПРАВБ($B6:$D12)="1";$B6:$D12);СТОЛБЕЦ(A1));"")
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК(1;$B6:$D12));$B6:$D12);СТОЛБЕЦ(A1));"")

Автор - Nic70y
Дата добавления - 27.07.2020 в 09:05
russcand Дата: Понедельник, 27.07.2020, 14:51 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо.
Вместо цифры "1" как можно ввести ссылку на ячейку , чтобы каждое изменение в этой ячейке меняло условие ( н-р , с 1 на 0 или любое другое число 0-9 ).
У мня при указании в формуле на ссылку дает пусто.
 
Ответить
СообщениеСпасибо.
Вместо цифры "1" как можно ввести ссылку на ячейку , чтобы каждое изменение в этой ячейке меняло условие ( н-р , с 1 на 0 или любое другое число 0-9 ).
У мня при указании в формуле на ссылку дает пусто.

Автор - russcand
Дата добавления - 27.07.2020 в 14:51
Nic70y Дата: Понедельник, 27.07.2020, 14:56 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6605
Репутация: 1453 ±
Замечаний: 0% ±

ru13;10;03
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ПРАВБ($B6:$D12)=$G5&"";$B6:$D12);СТОЛБЕЦ(A1));"")
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($G5;$B6:$D12));$B6:$D12);СТОЛБЕЦ(A1));"")
и не забывайте:
{формула массива вводится одновременным нажатием Ctrl Shift Enter}


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ПРАВБ($B6:$D12)=$G5&"";$B6:$D12);СТОЛБЕЦ(A1));"")
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(ПОИСК($G5;$B6:$D12));$B6:$D12);СТОЛБЕЦ(A1));"")
и не забывайте:
{формула массива вводится одновременным нажатием Ctrl Shift Enter}

Автор - Nic70y
Дата добавления - 27.07.2020 в 14:56
russcand Дата: Понедельник, 27.07.2020, 15:16 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо , все получилось!!!
 
Ответить
СообщениеСпасибо , все получилось!!!

Автор - russcand
Дата добавления - 27.07.2020 в 15:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из базы чисел выделить числа по условию. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!