Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет значения по нескольким условиям в формуле - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет значения по нескольким условиям в формуле (Формулы/Formulas)
Расчет значения по нескольким условиям в формуле
Nata_Li Дата: Понедельник, 03.08.2020, 14:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Пожалуйста, подскажите как проставить в одной ячейке формулу с несколькими условиями (у меня вышло на 4 ячейки):
есть 4 условия:
если меньше 109,5, то Цена =0
если от 109,5 до 146 то = (Цена - 109,5) * 35%
если от 146 до 182,5 то = 12,78 + (Цена - 146) * 45%
если от 182 то = 29,2 + (Цена - 182,5) * 30%

Файл с примером вложен.
К сообщению приложен файл: 3335239.xlsx(136.9 Kb)
 
Ответить
СообщениеЗдравствуйте!
Пожалуйста, подскажите как проставить в одной ячейке формулу с несколькими условиями (у меня вышло на 4 ячейки):
есть 4 условия:
если меньше 109,5, то Цена =0
если от 109,5 до 146 то = (Цена - 109,5) * 35%
если от 146 до 182,5 то = 12,78 + (Цена - 146) * 45%
если от 182 то = 29,2 + (Цена - 182,5) * 30%

Файл с примером вложен.

Автор - Nata_Li
Дата добавления - 03.08.2020 в 14:00
YouGreed Дата: Понедельник, 03.08.2020, 14:17 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 565
Репутация: 119 ±
Замечаний: 0% ±

Excel 2010
Nata_Li,
Код
=ЕСЛИ(A11<109,5;0;ЕСЛИ(И(A11>109,5;A11<146);(A11-109,5)*0,35;ЕСЛИ(И(A11>146;A11<182,5);12,78+(A11-146)*0,45;29,2+(A11-182,5)*0,3)))
 
Ответить
СообщениеNata_Li,
Код
=ЕСЛИ(A11<109,5;0;ЕСЛИ(И(A11>109,5;A11<146);(A11-109,5)*0,35;ЕСЛИ(И(A11>146;A11<182,5);12,78+(A11-146)*0,45;29,2+(A11-182,5)*0,3)))

Автор - YouGreed
Дата добавления - 03.08.2020 в 14:17
Nata_Li Дата: Понедельник, 03.08.2020, 14:23 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
YouGreed,
Спасибо вам большое!!! yes
 
Ответить
СообщениеYouGreed,
Спасибо вам большое!!! yes

Автор - Nata_Li
Дата добавления - 03.08.2020 в 14:23
Nic70y Дата: Понедельник, 03.08.2020, 14:25 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6601
Репутация: 1451 ±
Замечаний: 0% ±

ru13;10;03
еще вариант
Код
=ВЫБОР(ПОИСКПОЗ(A11;{0:109,5:146:182,5});0;(A11-109,5)*0,35;12,78+(A11-165)*0,45;29,2+(A11-182,5)*0,3)
вдруг правильно


Яндекс Деньги 41001841029809
 
Ответить
Сообщениееще вариант
Код
=ВЫБОР(ПОИСКПОЗ(A11;{0:109,5:146:182,5});0;(A11-109,5)*0,35;12,78+(A11-165)*0,45;29,2+(A11-182,5)*0,3)
вдруг правильно

Автор - Nic70y
Дата добавления - 03.08.2020 в 14:25
Nata_Li Дата: Понедельник, 03.08.2020, 17:21 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y,
Спасибо большое, работает!!! :)
 
Ответить
СообщениеNic70y,
Спасибо большое, работает!!! :)

Автор - Nata_Li
Дата добавления - 03.08.2020 в 17:21
TheJha Дата: Среда, 05.08.2020, 15:42 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 1 ±
Замечаний: 0% ±

Excel 2019
У меня получилось немного по другому
Код
=ЕСЛИ(A17<109,5;0;ЕСЛИ(ИЛИ(A17=109,5;A17<146);(A17-109,5)*0,35;ЕСЛИ(ИЛИ(A17=146;A17<182,5);(12,78+(A17-146)*0,45);ЕСЛИ(A17>=182,5;29,2+(A17-182,5)*0,3;))))


в первом варианте, если ставить пограничные значения 109,5 и т.д. выходит неправильный результат.. поправьте если не так


Сообщение отредактировал TheJha - Среда, 05.08.2020, 15:43
 
Ответить
СообщениеУ меня получилось немного по другому
Код
=ЕСЛИ(A17<109,5;0;ЕСЛИ(ИЛИ(A17=109,5;A17<146);(A17-109,5)*0,35;ЕСЛИ(ИЛИ(A17=146;A17<182,5);(12,78+(A17-146)*0,45);ЕСЛИ(A17>=182,5;29,2+(A17-182,5)*0,3;))))


в первом варианте, если ставить пограничные значения 109,5 и т.д. выходит неправильный результат.. поправьте если не так

Автор - TheJha
Дата добавления - 05.08.2020 в 15:42
Nic70y Дата: Среда, 05.08.2020, 16:52 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 6601
Репутация: 1451 ±
Замечаний: 0% ±

ru13;10;03
в первом варианте
нужно просто заменить > на >=


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
в первом варианте
нужно просто заменить > на >=

Автор - Nic70y
Дата добавления - 05.08.2020 в 16:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет значения по нескольким условиям в формуле (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!