Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение макс. кол-ва дней в данном месяце для вычислений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение макс. кол-ва дней в данном месяце для вычислений (Формулы/Formulas)
Определение макс. кол-ва дней в данном месяце для вычислений
Юрий_Ф Дата: Понедельник, 03.08.2020, 18:09 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 228
Репутация: -3 ±
Замечаний: 0% ±

Excel 2010
Дано: Для вычислений коэффициента необходимо использовать количество дней в данном месяце.
Когда в календаре были просто числа, использовал формулу (например, для 5го числа:
Код
=ЕСЛИ(G9>0;СУММ(C9:G9)/МАКС(C2:AG2);"Х")

Максимальное число для августа было 31 и всё работало как надо. В сентябре будет 30 - тоже всё понятно. Формулы менять не надо, а только вручную убиралось (или потом подставлялось) 31е число.
Но вот по мере своего развития (с помощью грамотных спецов на этом сайте), числа были преображены в порядковые номера с начала ХХ века. И коэф. перестал грамотно подсчитывать.
Подскажите, пожалуйста, как вместо поиска МАКС числа в месяце, поставить МАКС число дней в данном месяце (строка 10)?
К сообщению приложен файл: 2868842.xlsx(15.7 Kb)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Понедельник, 03.08.2020, 18:12
 
Ответить
СообщениеДано: Для вычислений коэффициента необходимо использовать количество дней в данном месяце.
Когда в календаре были просто числа, использовал формулу (например, для 5го числа:
Код
=ЕСЛИ(G9>0;СУММ(C9:G9)/МАКС(C2:AG2);"Х")

Максимальное число для августа было 31 и всё работало как надо. В сентябре будет 30 - тоже всё понятно. Формулы менять не надо, а только вручную убиралось (или потом подставлялось) 31е число.
Но вот по мере своего развития (с помощью грамотных спецов на этом сайте), числа были преображены в порядковые номера с начала ХХ века. И коэф. перестал грамотно подсчитывать.
Подскажите, пожалуйста, как вместо поиска МАКС числа в месяце, поставить МАКС число дней в данном месяце (строка 10)?

Автор - Юрий_Ф
Дата добавления - 03.08.2020 в 18:09
Pelena Дата: Понедельник, 03.08.2020, 18:14 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16817
Репутация: 3623 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Замените МАКС(C2:AG2) на ДЕНЬ(МАКС(C2:AG2)) или на ДЕНЬ(КОНМЕСЯЦА($A$2;0))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗамените МАКС(C2:AG2) на ДЕНЬ(МАКС(C2:AG2)) или на ДЕНЬ(КОНМЕСЯЦА($A$2;0))

Автор - Pelena
Дата добавления - 03.08.2020 в 18:14
Юрий_Ф Дата: Понедельник, 03.08.2020, 18:24 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 228
Репутация: -3 ±
Замечаний: 0% ±

Excel 2010
Отлично! Но! Не работает для ячейки C10, даже если я заменяю СУММА (C9:C9) на С9!
Что я делаю не так?


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеОтлично! Но! Не работает для ячейки C10, даже если я заменяю СУММА (C9:C9) на С9!
Что я делаю не так?

Автор - Юрий_Ф
Дата добавления - 03.08.2020 в 18:24
Юрий_Ф Дата: Понедельник, 03.08.2020, 18:37 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 228
Репутация: -3 ±
Замечаний: 0% ±

Excel 2010
Спасибо! Вопрос снимается! В моей таблице всё работает!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеСпасибо! Вопрос снимается! В моей таблице всё работает!

Автор - Юрий_Ф
Дата добавления - 03.08.2020 в 18:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение макс. кол-ва дней в данном месяце для вычислений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!