Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отобразить в шахматке числа из массива уникальных данных. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отобразить в шахматке числа из массива уникальных данных. (Формулы/Formulas)
Отобразить в шахматке числа из массива уникальных данных.
russcand Дата: Вторник, 11.08.2020, 14:08 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем здрасьте!
В массиве данных уникальные числа "0-99".
Есть Таблица_3 , построенная по принципу шахматки с размерностью "10х10" , в которую вписываются числа "0-99".
Горизонтальная шкала имеет шаг 10 "от 0 до 90".
Вертикальная - шаг 1 " от 0 до 9".
Пересечение вертикали и горизонтали внутри шахматки дает ячейку с числом сложения ( например "30"+"5"="35" ).
Задача:
Отобразить в соответствующих ячейках шахматки ( Таблица_3 ) все числа из базы данных , присвоив им значения "1".
Например , есть в базе число "4". В Таблице_3 ( результата ) должна проставиться "1" на пересечении вертикали "4" и горизонтали "0".

П.С. Решение инструментами Эксэл.
П.С. Во вложенном файле смотрим Лист_2.
К сообщению приложен файл: 5183-.xlsx(23.5 Kb)
 
Ответить
СообщениеВсем здрасьте!
В массиве данных уникальные числа "0-99".
Есть Таблица_3 , построенная по принципу шахматки с размерностью "10х10" , в которую вписываются числа "0-99".
Горизонтальная шкала имеет шаг 10 "от 0 до 90".
Вертикальная - шаг 1 " от 0 до 9".
Пересечение вертикали и горизонтали внутри шахматки дает ячейку с числом сложения ( например "30"+"5"="35" ).
Задача:
Отобразить в соответствующих ячейках шахматки ( Таблица_3 ) все числа из базы данных , присвоив им значения "1".
Например , есть в базе число "4". В Таблице_3 ( результата ) должна проставиться "1" на пересечении вертикали "4" и горизонтали "0".

П.С. Решение инструментами Эксэл.
П.С. Во вложенном файле смотрим Лист_2.

Автор - russcand
Дата добавления - 11.08.2020 в 14:08
прохожий2019 Дата: Вторник, 11.08.2020, 22:23 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
и чем формула из прошлой темы не угодила?
Код
=СЧЁТЕСЛИ($B$5:$H$14;K5)
и формат 1;;;
К сообщению приложен файл: 5394474.xlsx(24.1 Kb)
 
Ответить
Сообщениеи чем формула из прошлой темы не угодила?
Код
=СЧЁТЕСЛИ($B$5:$H$14;K5)
и формат 1;;;

Автор - прохожий2019
Дата добавления - 11.08.2020 в 22:23
russcand Дата: Среда, 12.08.2020, 13:26 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо , все подошло.
Формула из прошлой темы более наглядно показывает расстановку чисел , но , если складывать ( следующая задача ) содержимое ячеек в 3-х шахматках , то получим , например , 55+55+55=165.
Если же там стоят "1" , то этот счет равен 3 ( 1+1+1 ).
Мне нужен именно второй вариант.
 
Ответить
СообщениеСпасибо , все подошло.
Формула из прошлой темы более наглядно показывает расстановку чисел , но , если складывать ( следующая задача ) содержимое ячеек в 3-х шахматках , то получим , например , 55+55+55=165.
Если же там стоят "1" , то этот счет равен 3 ( 1+1+1 ).
Мне нужен именно второй вариант.

Автор - russcand
Дата добавления - 12.08.2020 в 13:26
прохожий2019 Дата: Четверг, 13.08.2020, 00:11 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
следующая задача
если бы вы сразу озвучили конечную цель, возможно получили бы более простое решение
 
Ответить
Сообщение
следующая задача
если бы вы сразу озвучили конечную цель, возможно получили бы более простое решение

Автор - прохожий2019
Дата добавления - 13.08.2020 в 00:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отобразить в шахматке числа из массива уникальных данных. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!