Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Простой одновременный поиск по нескольким параметрам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простой одновременный поиск по нескольким параметрам (Формулы/Formulas)
Простой одновременный поиск по нескольким параметрам
AK4eva Дата: Пятница, 14.08.2020, 15:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день, пользовался поиском, но т.к. не могу точно сформулировать суть вопроса, то ответа не нашел.
Имеется таблица состоящая из ячеек в которых буквы и цифры. В ней необходимо найти и выделить любым цветом (не делая сортировок) ячейки в которых встречаются допустим 1 символ "a" и 1 символ "b".( символы потом я буду изменять сам на нужные). Если симоволо "а" будет 2 в строке или больше то такие ячейки не подходят.
1a2b - подходит
ab12 - подходит
b1a2 - подходит
123b - не подходит
aab1 - не подходит.
Подскажите, пожалуйста, решение. Спасибо.
 
Ответить
СообщениеДобрый день, пользовался поиском, но т.к. не могу точно сформулировать суть вопроса, то ответа не нашел.
Имеется таблица состоящая из ячеек в которых буквы и цифры. В ней необходимо найти и выделить любым цветом (не делая сортировок) ячейки в которых встречаются допустим 1 символ "a" и 1 символ "b".( символы потом я буду изменять сам на нужные). Если симоволо "а" будет 2 в строке или больше то такие ячейки не подходят.
1a2b - подходит
ab12 - подходит
b1a2 - подходит
123b - не подходит
aab1 - не подходит.
Подскажите, пожалуйста, решение. Спасибо.

Автор - AK4eva
Дата добавления - 14.08.2020 в 15:34
китин Дата: Пятница, 14.08.2020, 15:44 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6289
Репутация: 964 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Имеется таблица

нетути


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Имеется таблица

нетути

Автор - китин
Дата добавления - 14.08.2020 в 15:44
китин Дата: Пятница, 14.08.2020, 16:05 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6289
Репутация: 964 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
нам коленке формула в УФ
Код
=СУММ(1*(ПСТР(A1;СТРОКА($1:$10);1)="a"))+СУММ(1*(ПСТР(A1;СТРОКА($1:$10);1)="b"))=2

чисто по ТЗ без файла
К сообщению приложен файл: AK4eva.xlsm(29.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениенам коленке формула в УФ
Код
=СУММ(1*(ПСТР(A1;СТРОКА($1:$10);1)="a"))+СУММ(1*(ПСТР(A1;СТРОКА($1:$10);1)="b"))=2

чисто по ТЗ без файла

Автор - китин
Дата добавления - 14.08.2020 в 16:05
AK4eva Дата: Пятница, 14.08.2020, 17:01 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо, всё работает! А как во вложенном файле изменять "a" и "b" не могу найти где находится эта формула? Или как копировать эту формулу в новый файл?
 
Ответить
СообщениеСпасибо, всё работает! А как во вложенном файле изменять "a" и "b" не могу найти где находится эта формула? Или как копировать эту формулу в новый файл?

Автор - AK4eva
Дата добавления - 14.08.2020 в 17:01
Юрий_Ф Дата: Суббота, 15.08.2020, 11:47 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 228
Репутация: -3 ±
Замечаний: 0% ±

Excel 2010
Ну как не можете найти? Посмотрите внимательно!
Код
="a"))

и
Код
="b"))


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеНу как не можете найти? Посмотрите внимательно!
Код
="a"))

и
Код
="b"))

Автор - Юрий_Ф
Дата добавления - 15.08.2020 в 11:47
AK4eva Дата: Суббота, 15.08.2020, 20:25 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Я увидел "a" и "b" в формуле
Код
=СУММ(1*(ПСТР(A1;СТРОКА($1:$10);1)="a"))+СУММ(1*(ПСТР(A1;СТРОКА($1:$10);1)="b"))=2
.
А где в прикрепленном файле найти эту формулу? Она вбита в какую-либо ячейку или как то применена ко всему документу?
 
Ответить
СообщениеЯ увидел "a" и "b" в формуле
Код
=СУММ(1*(ПСТР(A1;СТРОКА($1:$10);1)="a"))+СУММ(1*(ПСТР(A1;СТРОКА($1:$10);1)="b"))=2
.
А где в прикрепленном файле найти эту формулу? Она вбита в какую-либо ячейку или как то применена ко всему документу?

Автор - AK4eva
Дата добавления - 15.08.2020 в 20:25
Che79 Дата: Суббота, 15.08.2020, 20:39 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1629
Репутация: 301 ±
Замечаний: 0% ±

2013 Win, 365 Mac
AK4eva, Вкладка Главная -- Условное форматирование -- Управление правилами
К сообщению приложен файл: 8505045.png(116.5 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеAK4eva, Вкладка Главная -- Условное форматирование -- Управление правилами

Автор - Che79
Дата добавления - 15.08.2020 в 20:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Простой одновременный поиск по нескольким параметрам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!