Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление разницы ячеек по критерию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление разницы ячеек по критерию (Формулы/Formulas)
Вычисление разницы ячеек по критерию
ViktorNsk Дата: Воскресенье, 16.08.2020, 02:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет! пишу впервые) пытаюсь придумать формулу, которая бы вычитала время изделия со статусом "отремонтировано" и время того же изделия со статусом "в ремонте". пробовал формулы СУММЕСЛИМН, но ничего не выходит. Данные должны заноситься в столбцы ССИ1 и ССИ2. Таким образом хочу высчитать какое время изделие находилось в конкретной ячейке. Помогите! Уперся в свой потолок ЭКСЕЛЕЗРЕНИЯ))))
К сообщению приложен файл: 9926397.xlsm(17.6 Kb)
 
Ответить
СообщениеВсем привет! пишу впервые) пытаюсь придумать формулу, которая бы вычитала время изделия со статусом "отремонтировано" и время того же изделия со статусом "в ремонте". пробовал формулы СУММЕСЛИМН, но ничего не выходит. Данные должны заноситься в столбцы ССИ1 и ССИ2. Таким образом хочу высчитать какое время изделие находилось в конкретной ячейке. Помогите! Уперся в свой потолок ЭКСЕЛЕЗРЕНИЯ))))

Автор - ViktorNsk
Дата добавления - 16.08.2020 в 02:04
Pelena Дата: Воскресенье, 16.08.2020, 08:36 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16646
Репутация: 3599 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Покажите в файле вручную, какой должен получиться результат


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Покажите в файле вручную, какой должен получиться результат

Автор - Pelena
Дата добавления - 16.08.2020 в 08:36
ViktorNsk Дата: Воскресенье, 16.08.2020, 08:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прописал формулу результата
К сообщению приложен файл: 4581428.xlsm(18.4 Kb)
 
Ответить
СообщениеПрописал формулу результата

Автор - ViktorNsk
Дата добавления - 16.08.2020 в 08:43
Pelena Дата: Воскресенье, 16.08.2020, 09:28 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 16646
Репутация: 3599 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Можно так
Код
=ЕСЛИ(И($E4="в ремонте";$C4=G$3);АГРЕГАТ(15;6;$D4:$D$19/($F4=$F4:$F$19)/($E4:$E$19="отремонтирован");1)-$D4;"")
К сообщению приложен файл: 5227944.xlsm(19.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожно так
Код
=ЕСЛИ(И($E4="в ремонте";$C4=G$3);АГРЕГАТ(15;6;$D4:$D$19/($F4=$F4:$F$19)/($E4:$E$19="отремонтирован");1)-$D4;"")

Автор - Pelena
Дата добавления - 16.08.2020 в 09:28
AlexM Дата: Воскресенье, 16.08.2020, 09:35 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Код
=ЕСЛИ(И($E4="в ремонте";$C4=G$3);ВПР($F4;ЕСЛИ({1;0};$F5:$F99;$D5:$D99);2;)-$D4;"")
К сообщению приложен файл: 4581428_01.xlsm(17.1 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 16.08.2020, 09:38
 
Ответить
Сообщение
Код
=ЕСЛИ(И($E4="в ремонте";$C4=G$3);ВПР($F4;ЕСЛИ({1;0};$F5:$F99;$D5:$D99);2;)-$D4;"")

Автор - AlexM
Дата добавления - 16.08.2020 в 09:35
ViktorNsk Дата: Воскресенье, 16.08.2020, 10:11 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
спасибо огромное!!! Про функцию "Агрегат" даже не не слышал! Это то, что нужно. И есть ещё один вопрос: первый столбец "сканирование" будет заполняться сканером штрих кода. Есть ли возможность задать условия правильности ввода: т.е, сначала должна быть отсканирована квитанция (2 столбец), потом ячейка (3 столбец). В противном случае ячейка не заполняется и издает звуковой сигнал. Файлы те же
 
Ответить
Сообщениеспасибо огромное!!! Про функцию "Агрегат" даже не не слышал! Это то, что нужно. И есть ещё один вопрос: первый столбец "сканирование" будет заполняться сканером штрих кода. Есть ли возможность задать условия правильности ввода: т.е, сначала должна быть отсканирована квитанция (2 столбец), потом ячейка (3 столбец). В противном случае ячейка не заполняется и издает звуковой сигнал. Файлы те же

Автор - ViktorNsk
Дата добавления - 16.08.2020 в 10:11
Pelena Дата: Воскресенье, 16.08.2020, 11:12 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 16646
Репутация: 3599 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Этот вопрос к данной теме не относится, создайте новую


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЭтот вопрос к данной теме не относится, создайте новую

Автор - Pelena
Дата добавления - 16.08.2020 в 11:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление разницы ячеек по критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!